Results 1 to 5 of 5

Thread: PackageKit problem

  1. #1
    Pushan NNTP User

    Default PackageKit problem

    I was updating and this popped up in PackageKit:

    Can't provide file './suse/i586/tack-5.6-83.1.i586.rpm' from repository 'openSUSE-DVD 11.0'


    I don't know whether the problem is with PackageKit, the repository, or my setup, but it won't skip the package that the file is needed for and update the rest (rather, I don't know how to force it to skip the package that needs this and update the rest).

    Does anyone know how to fix this?

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    69

    Default Re: PackageKit problem

    In your software repositories "openSUSE-DVD 11.0" is enabled and YaST looks for the openSUSE-DVD when updating. One way to resolved the issue is to insert the DVD (openSUSE 11.0) when YaST asked for it.

    If you don't like to do it every time (which I don't) goto YaST > Software Repositories, and in the list find "openSUSE-DVD 11.0". Select it and at bottom of the windows under Properties, uncheck the Enabled option. Now it is disabled and YaST wont look for it.

  3. #3
    Pushan NNTP User

    Default Re: PackageKit problem

    Many Thanks!

  4. #4
    Join Date
    Jan 2008
    Location
    Kenton, TN USA
    Posts
    1,023

    Default Re: PackageKit problem

    Thread moved to Applications
    opensuse.org.help.applications
    Last edited by kastorff; 19-Jul-2008 at 17:59.
    Keith Kastorff

  5. #5
    Join Date
    Jun 2008
    Location
    Omaha, NE
    Posts
    526

    Default Re: PackageKit problem

    I really think it would be neat if openSUSE enabled the DVD repository automatically when there was no internet connection, and disabled that repository when there is an internet connection.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •