Is there any way to install both gcc3.4.x and gcc4.1.x in opensuse? In Fedora they provide some gcc34-compat packages that install a gcc34 binary and libs so you can run the older gcc if you need to.

Is there anything equivalent in opensuse?