Results 1 to 8 of 8

Thread: Dependancy failure

  1. #1

    Default Dependancy failure

    Hi All
    I am getting this alarm continually, I dont use irq and it is annoying, further info displays

    xchat-lang-2.8.4-109.1.i586 requires xchat = 2.8.4, but this requirement cannot be provided
    liferea-lang-1.4.15-18.1.i586 requires liferea = 1.4.15, but this requirement cannot be provided
    gstreamer-0_10-plugins-good-lang-0.10.7-38.1.i586 requires gstreamer-0_10-plugins-good = 0.10.7, but this requirement cannot be provided

    got XChat 2.8.6 released (the Linux version) from :: View topic - XChat 2.8.6 released and it is an iso file, how do I handle this please and is it the right one to use?

    Help would be much appreciated

  2. #2
    Join Date
    Jan 2008
    U.K East Anglia

    Default Re: Dependancy failure

    have you tried installing xchat from your install cd/dvd ?

    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  3. #3

    Default Re: Dependancy failure

    I would install the one from the packman repository.

    Put that one on and it should be able to find and resolve all dependencies for you.

    Just go to add software repositories, and look for the packman community repository.

    Once that is on and loaded you should be able to find xchat the easy way through Yast

  4. #4

    Default Re: Dependancy failure

    Thanks for your response

    On search of cd I downloaded suse 11 from net there is only desktop config file listed under xchat

    Looking at YAST package selection under packman repos following listed
    mdp plug in
    these look like development tools

    I am a newbie to linux, asa you can probably see

  5. #5
    Join Date
    Jun 2008
    Ardrishaig, Argyll. Scotland UK - GMT/BST
    Blog Entries

    Default Re: Dependancy failure

    go to yast - software management
    in search type: xchat

    it is also in Packman but different/newer version

    make sure you have the oss, nonoss and packman repos' enabled
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: Dependancy failure

    Thx u advise caf4926
    following u instructions only repos available are those listed in #4 with a pile of bundle-lang-gnome and audacious plug ins, none of which look applicable

    all repos enabled as you listed

    when filter xchat Installed, then listed
    bundle-lang-gnome en
    xchat with ! mark indicating upgrade required
    xchat lang

    On trying to upgrade the above advised "There are some conflicts on the transaction that must be solved manually."
    listing "xchat-lang-2.8.4-109.1.i586 requires xchat=2.8.4, but this requirement cannot be provided"
    then offers some alternatives, being
    1 deinstall xchat-lang-2.8.4-109.1.i58
    2 do not install
    3 ignore some dependancies of xchat lang

    Going around in circles


  7. #7
    Join Date
    Jun 2008
    United States

    Default Re: Dependancy failure

    Would you be able to run the command: zypper sl in a terminal and paste the output, please?

    That would show us which repositories you have installed. The only reason I ask is because I've had a similar problem where a package was "not provided" and the reason turned out to be that some of my repositories didn't match the version of OpenSUSE (11.0) I was running. For example: I was using Factory repositories when I was running 11.0. This created some conflicting packages, and the update failed because unneeded packages were missing.

    Help save lives with Folding@Home

  8. #8

    Default Re: Dependancy failure

    Thanks for your response, data below

    graham@linux-adyl:~> zypper sl
    # | Alias | Name | Enabled | Refresh
    1 | repo-oss | openSUSE-11.0-Oss | Yes | No
    2 | openSUSE-DVD 11.0 | openSUSE-DVD 11.0 | Yes | No
    3 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes | Yes
    4 | VideoLan Repository | VideoLan Repository | Yes | Yes
    5 | repo-debug | openSUSE-11.0-Debug | No | No
    6 | Index of /pub/packman/suse/11.0 | Packman Repository | Yes | Yes
    7 | repo-non-oss | openSUSE-11.0-Non-Oss | Yes | No
    8 | Main Repository (OSS) | Main Repository (OSS) | Yes | Yes
    9 | Main Repository (NON-OSS) | Main Repository (NON-OSS) | Yes | Yes


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts