Results 1 to 6 of 6

Thread: Media player won't start from Firefox 3

  1. #1

    Default Media player won't start from Firefox 3

    Hi,
    I installed 11.0 recently as a clean install, and tried to use it to listen to an online program while I did some other work on the computer last night. I had firefox 3 up as the browser, and had previously used the one click restricted format installer from the opensuse-community.

    When I clicked on the icon on the webpage, a player won't start to play the windows media player selection. I looked back at the one click install and wasn't sure if it actually linked anything to a particular player like in 10.3. I then set a preference for mms protocol in firefox as follows:

    1. Go to about:config
    2. Right click and select New>Boolean
    3. Enter "network.protocol-handler.external.mms" without quotes, and clicked ok.
    4.I selected true for the value, and clicked ok.
    5. I right clicked again, and selected New>string
    6. I entered "network.protocol-handler.app.mms" and clicked ok
    7. I found "network.protocol-handler.app.mms" in the list and right clicked on it.
    8. I selected New>String
    9. In the box I typed /opt/kde3/bin/kaffeine and clicked ok

    When I click on the icon on the web page to start the media player for windows player, nothing happens. If I click on the icon to start the same media with real player, nothing happens. I tried it on another website, and had the same result.

    I opened konqueror to /opt/kde3/bin/ and clicked on the kaffeine gear, and the program opens. I can open kaffeine from the application menu as well. Once kaffeine is open, I can copy and paste the url from the website media that I want to hear to kaffeine, and it will play the media.

    Seems like a problem with something in firefox, anybody have any ideas how to get this working normally?

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Media player won't start from Firefox 3

    We have a forum policy of one post per problem. Is this the same problem you reported here:
    Media won't play - openSUSE Forums

  3. #3

    Default Re: Media player won't start from Firefox 3

    HI,
    no, this is a differant problem. Please read the posts carefully.

    On this one the media player programs (Kaffeine or Real Player) won't open when I click on the icon which should open the player and the link.

    On the other post, when I click on an icon to open the link, the player opens but immediately shuts off and won't play.

  4. #4

    Default Re: Media player won't start from Firefox 3

    Hi,
    one more piece to this puzzle is this post refers to Opensuse 11.0 that I installed on my home desktop.

    I recently upgraded FF2 to Firefox 3 on my laptop, which has Opensuse 10.3 installed. I used one click restricted format installation when I originally installed 10.3. With the totem package that it installed I could click on the icon and launch an mms audio stream. Immediately after upgrading to Firefox 3, the icon on the webpage stopped responding and wouldn't launch Totem anymore.

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Media player won't start from Firefox 3

    Sometimes the Media Player Connectivity plugin works for firefox for users in trying to play streaming from "stubborn" sites.
    see above quote from a link oldcpu gave you
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: Media player won't start from Firefox 3

    Hi,
    my omission in response to OldCPU's suggestion. When I read his original post I immediately installed the media connectivity plugin. There was no change, the problem still persists.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •