Results 1 to 7 of 7

Thread: Sony VAIO Vgn-sz430n Touchpad is badly recognized

  1. #1

    Default Sony VAIO Vgn-sz430n Touchpad is badly recognized

    Whenever I move my finger up or down to move the mouse that way, OS 11 recognizes it as scrolling, even though I do it in the middle or the opposite side of the touchpad! Also, I cannot tap the touchpad to click.

    I know it works in Linux because in ubuntu it works perfectly (except horizontal scrolling). What could be the problem?

  2. #2

    Default Re: Sony VAIO Vgn-sz430n Touchpad is badly recognized

    I'm curious, in your yast pointing devices configuration, how many devices are listed? Also, are there any besides the touchpad that you can't account for in terms of peripherals you have plugged in?

    I had a similar issue and noticed that openSUSE had detected an additional ps2 mouse besides my pointer, and which the laptop does not have. When I removed it, touchpad functionality was sane and predictable and easy to configure in KDE 4.

  3. #3

    Default Re: Sony VAIO Vgn-sz430n Touchpad is badly recognized

    Four are listed, even though I only have a touchpad and mouse. One for the USB mouse, two for the touchpad, and one for a Sony Jogdial thing. It's really confusing.

  4. #4

    Default Re: Sony VAIO Vgn-sz430n Touchpad is badly recognized

    Do you have a jogdial? I would suggest removing the second touchpad listed in the pointing devices configuration. If you don't have a jogdial, I would remove that as well.

  5. #5

    Default Re: Sony VAIO Vgn-sz430n Touchpad is badly recognized

    Thank you! I disabled the extra two and now my touchpad works fine!

    Mods: please mark this thread as [SOLVED] for other users.

  6. #6
    Chapbass NNTP User

    Default Re: Sony VAIO Vgn-sz430n Touchpad is badly recognized

    Sweet, thanks for figuring that out, ive had that problem too, and while i havent tried it yet, heres hoping it works. Thanks all

  7. #7

    Default Re: Sony VAIO Vgn-sz430n Touchpad is badly recognized

    where can i disable or delete the second one (Touch Dial) on open SUSE ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •