Results 1 to 6 of 6

Thread: openSUSE 11 and Radeon x1600

  1. #1

    Default openSUSE 11 and Radeon x1600

    Hello all,

    I just upgraded to openSUSE 11 (KDE4) via a fresh install. After the install, things look fine, and function ok. I went to the following site and did the 1-click install for the ATI drivers:

    ATI - openSUSE

    This worked on my system running openSUSE 11 (gnome) with a Radeon HD3840. However, my KDE4 system with a x1600 I get less than desireable results.

    The install seems to work, I don't get any errors, however, after the install, I open a terminal and type in fglrxinfo I get the following:

    Code:
    ~> fglrxinfo
    display: :0.0  screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.4 (2.1 Mesa 7.0.3)
    per the 1-click page, it mentions that I don't have to run sudo aticonfig --initial, I do restart X, but still the Mesa drivers show up.

    Now, when I do run sudo aticonfig --initial and restart X, I get very bizarre results.

    1) my refresh rate is fubar (can barely read the text on the screen)
    2) The monitor setting in YAST/HARDWARE/Graphics Card and Monitor is set to some bizarre monitor with a resolution width greater than 1920x1200. I have a DELL 20" widescreen with a default resolution of 1680x1050. I change the setting back to either LCD with 1680x1050 or the correct DELL monitor with proper resolution and refresh rate, things are "ok" until I restart X, and they go back to the crazy monitor with resolution greater than 1900 and high refresh rate.

    3) When I go into YaST2, search for "fglrx", the packages that are displayed are:

    ati-fglrxG01-kmp-debug
    ati-fglrxG01-kmp-default
    ati-fglrxG01-kmp-pae (selected)
    x11-video-fglrxG01 (selected)
    I have an AMD 3800+ processor with 2 gigs of RAM. and I noticed that when I first installed openSUSE that I didn't choose the pae kernel, and I've never had the pae kernel running in openSUSE on my rigs, and frankly, I don't think my rigs are pae rigs, so I'm not sure why this driver is showing up selected.

    Any idea what is going on? Any way to get the driver to work with the x1600, as I know it works with the HD3870.

    any help is always appreciated.

    --kevin

  2. #2

    Default Re: openSUSE 11 and Radeon x1600

    Does anyone have any ideas what could be going on or how to fix this?

    --Kp

  3. #3

    Default Re: openSUSE 11 and Radeon x1600

    I'm getting in over my head here, but have you tried getting the resolution you want by using KRandRTray or sax2? You can open up a terminal and type krandrtray, and it will give you a utility for changing refresh rate, etc. Or type sax2, which will let you configure the screen size.

  4. #4
    Join Date
    Jun 2008
    Location
    Taiwan
    Posts
    150

    Default Re: openSUSE 11 and Radeon x1600

    You can modify xorg.conf fulfill your environment.
    Here is my example.
    Bryan's technical world: How to change X window configuration (Ubuntu, openSUSE, Fedora)
    Regards,
    Bryan Yu
    http://lifestory.moqin.com/

  5. #5

    Default Re: openSUSE 11 and Radeon x1600

    You might want to try oyur luck at phoronix.com this thread:

    Problem with Catalyst v8.6 and 8.7 - Phoronix Forums
    If you are looking for just good performance, and not necessarily Xgl, you might just want to run with AIGLX enabled(by default).

  6. #6

    Default Re: openSUSE 11 and Radeon x1600

    I also have had this issue ever since I upgraded to openSUSE 11.0, and hence, was forced to move to a newer version of fglrx than 8.40.4. The guys at phoronix thread say that I might have an installation problem, but I somehow know that it is not that, as I have tried it on both ubuntu 8,04, and openSUSE 11.0, with exactly the same problem. I dug around a bit, and then saw in Xorg.93.log(with Xgl enabled), that my fglrx_dri.so is not being loaded and MESA-PROXY is being used for GL. Hence, the crappy performance with Xgl. AIGLX loads the library fine.

    To get fglrxinfo right, I modified the /etc/sysconfig/displaymanager file:
    original :
    #DISPLAYMANAGER_XGL_OPTS="-accel glxbuffer -accel xvbuffer"
    modified :
    DISPLAYMANAGER_XGL_OPTS="-accel glx -accel xv"

    ..my fglrxinfo shows ATI, but my direct rendering is still off. I have asked the question, but I am not sure if I am going to get any sane answer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •