Results 1 to 3 of 3

Thread: OpenSuse 10.2/10.3 and Gfortran 4.1

  1. #1

    Question OpenSuse 10.2/10.3 and Gfortran 4.1

    HI all,
    I'm using LAM/MPI that in the opensuse 10.2 is stick to gfortran (for what I'm able to verify).
    gfortran 4.1/4.2 has an annoying bug that prevent emacs to correctly process errors messages.
    The GCC version 4.3 fixes this bug.
    I'm asking for an advice. Is it possible to install gcc 4.3 on opensuse 10.2 or I have to move to OS 11?
    I have a slow internet connection and LIVECD of opensuse11. Is the gcc 4.3 in the LIVECD?
    Thanks in advance
    Saluti
    R

  2. #2
    Join Date
    Jun 2008
    Location
    Southeast USA
    Posts
    9

    Default Re: OpenSuse 10.2/10.3 and Gfortran 4.1

    Howdy.

    I believe openSuSE 11 uses a different package format than the openSuSE 10 series. This will probably proclude you from snatching the pkg from the 11.0 livecd.

    openSuSE 11.0 does come with gcc 4.3 though.

    Code:
    bwayne@linux-3wes:~> gcc --version
    gcc (SUSE Linux) 4.3.1 20080507 (prerelease) [gcc-4_3-branch revision 135036]
    Copyright (C) 2008 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions.  There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
    My suggestion would be to install openSuSE 11 on a separate partition, setting up a temporary dual-boot environment, just to see if 11 will work for you. I say this because you seem to be using 10.2 as a production environment, and I'd hate for something awful to happen.

    Alternatively you could download it from one of the mirrors.
    GCC mirror sites - GNU Project - Free Software Foundation (FSF)

    I'd suggest using wget since it can automatically resume from a timeout, but I'm sure you already knew that.

  3. #3

    Default Re: OpenSuse 10.2/10.3 and Gfortran 4.1

    Thank you for your information.
    I'll try to install the liveCD on a test machine.
    Only one more request, I have limited download bandwith so how can I know which pkgs come with the liveCD to be sure about the presence of development tools like emacs etc.. on the CD?
    Saluti
    R

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •