Results 1 to 2 of 2

Thread: Opensuse 11, webcam problem

  1. #1

    Default Opensuse 11, webcam problem

    Hi,

    in my Acer Aspire 7720G there is a Crystal Eye WebCam (Model: "Suyin Acer CrystalEye webcam").

    This is the output of hwinfo:

    46: USB 00.1: 0000 Unclassified device
    [Created at usb.122]
    UDI: /org/freedesktop/Hal/devices/usb_device_64e_a101_CN0314_OV03_VA_R02_00_00_if1
    Unique ID: 0vOp.hU0xiHqkSs4
    Parent ID: pBe4.9T1GDCLyFd9
    SysFS ID: /devices/pci0000:00/0000:00:1d.7/usb2/2-4/2-4:1.1
    SysFS BusID: 2-4:1.1
    Hardware Class: unknown
    Model: "Suyin Acer CrystalEye webcam"
    Hotplug: USB
    Vendor: usb 0x064e "Suyin Corp."
    Device: usb 0xa101 "Acer CrystalEye webcam"
    Revision: "1.00"
    Serial ID: "CN0314-OV03-VA-R02.00.00"
    Driver: "uvcvideo"
    Driver Modules: "uvcvideo"
    Speed: 480 Mbps
    Module Alias: "usb:v064EpA101d0100dcEFdsc02dp01ic0Eisc02ip00"
    Config Status: cfg=new, avail=yes, need=no, active=unknown
    Attached to: #55 (Hub)

    The webcam doesn't work (ekiga, gqcam) and the strange thing is the output of lsusb:

    Bus 003 Device 002: ID 064e:a101 Suyin Corp. HP Pavilion dv9640us WebCam


    Can you help me?

    Thanks.

  2. #2
    Join Date
    Mar 2008
    Location
    Kentucky
    Posts
    1,126

    Default Re: Opensuse 11, webcam problem

    Quote Originally Posted by sorry1 View Post
    Hi,
    The webcam doesn't work (ekiga, gqcam) and the strange thing is the output of lsusb:

    Bus 003 Device 002: ID 064e:a101 Suyin Corp. HP Pavilion dv9640us WebCam


    Can you help me?

    Thanks.
    I'll try (although I see you have "uvcvideo"
    You may want to see if there's a later version, see below, or, skip to the build your own from src to match the running kernel below

    Search google/linux <Linux> - Google Search for "064e:a101" like
    064e:a101 - Google Search
    then
    [Linux-uvc-devel] [Linphone-developers] 064e:a101 Suyin Corp. Cam in Acer Notebook
    says
    > I'm the maintainer of linphone (video chat tool), and I use uvcvideo driver
    > without major problems every day,
    So where to find "uvcvideo"

    Start @ Index of /repositories/drivers:/webcam
    then
    Index of /repositories/drivers:/webcam/openSUSE_11.0
    then
    Index of /repositories/drivers:/webcam/openSUSE_11.0/x86_64
    Page down & there's uvcvideo-kmp-default-r171_2.6.25.5_1.1-3.4.x86_64.rpm

    Get the one that matches your running kernel or it won't work
    "uname -a" in a terminal.

    If you have upgraded the kernel and one's not there:
    download the source = uvcvideo-r171-3.4.src.rpm @ Index of /repositories/drivers:/webcam/openSUSE_11.0/src
    Build you own to maatch the running kernel with:
    in a terminal as root
    Code:
    cd /pathto/rpm
    rpmbuild --rebuild /uvcvideo-r171-3.4.src.rpm
    your rpms will be in /usr/src/packages/RPMS/x86_64
    cd /tothatfolder
    install with
    "rpm -Uhv /packagename.rpm"

    See if that helps
    Last edited by snakedriver; 19-Jul-2008 at 15:20.
    Desktop Asus X-99 Viper. uefi & secure Boot, Win10, Leap 15.1; Laptop: ASUS GL752VW Optimus, uefi+Secure Boot, Win10, Leap 15.1 & T-weed and IMac

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •