Results 1 to 5 of 5

Thread: More dependency erros with YaST2 - a Catch-22?

Hybrid View

  1. #1
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default More dependency erros with YaST2 - a Catch-22?

    Over the past 2 weeks I have received notifications of despondency errors when using YaST. I don't understand why this should happen - I thought the idea of the RPM concept was to avoid these errors?

    Today I have what seems to be a Catch-22 - the error is with Yast2, so Yast fails when I try to find the missing package. The 'more details' are:

    Nothing provides YaST2 >= 2.17.7 needed by yast2-installation-2.17.0-2.noarch
    gcon2-branding-opensuse-2.20.60.noarch requires desktop-delta-openSUSE = 11.0 but this requirement cannot be provided.


    I don't think I did anything that precipitated these errors, so what happened?

    I tried to search for an rpm for YaST2 in google, but it found repos that were 18 months old or older. So I cannot see how to get out of these problems.
    They said I wasn't fit to live with a pig; my brother stood up for me and said I was.

  2. #2

    Default Re: More dependency erros with YaST2 - a Catch-22?

    Not sure why exactly this might have happened. Do you have any repositories besides the basics enabled? Where exactly did you find gconf2-branding-2.20.60.noarch? I was not able to find it in any of the package repositories I checked. Same with the yast2 file. It seems, based on the version numbers, that you may be running bleeding-edge software which is not compatible with the standard distro RPMs.

    RPM is supposed to help with these dependencies sure, but it is possible that certain packages can get you into impossible situations (same with .debs), if not enough time is taken into making sure that dependencies can be satisfied.

    You might try downgrading those RPMs in yast to the standard ones from the 11.0 repository. If yast doesn't put up a fuss, or threaten to downgrade or uninstall multiple packages, that may solve your issue right there.

  3. #3
    Join Date
    Jun 2008
    Location
    Sarasota
    Posts
    301

    Default Re: More dependency erros with YaST2 - a Catch-22?

    Quote Originally Posted by XEyedBear View Post
    I don't understand why this should happen - I thought the idea of the RPM concept was to avoid these errors?


    Nothing provides YaST2 >= 2.17.7 needed by yast2-installation-2.17.0-2.noarch
    gcon2-branding-opensuse-2.20.60.noarch requires desktop-delta-openSUSE = 11.0 but this requirement cannot be provided.


    I don't think I did anything that precipitated these errors, so what happened?

    I tried to search for an rpm for YaST2 in google, but it found repos that were 18 months old or older. So I cannot see how to get out of these problems.
    The correct version of YAST2, for SUSE 11.0 systems, is 2.16.50.

    So, you time-traveled a bit too far into the future, it seems!

    The only ways I'd think that would be possible would be
    (1) if one were to get SOURCE-code for YAST2 and compile and install that.
    (2) Or, maybe go grab an RPM off the Internet that contained a
    newer version of YAST2 and install that.
    (3) Or, setup a repository that is incompatible with 11.0, that contained (newer) YAST2,
    and then do an 'upgrade'. [I'm betting that repos for 11.1 might already exist somewhere.]

    Do any of those ring a bell?
    [I'm guessing #3.]

    [None of those are recommended if you want your system to function correctly.
    As to how to fix it, I'd suggest re-installing openSUSE 11.0.]

    Just a guess...

    Dave

  4. #4
    Join Date
    Jun 2008
    Location
    Sarasota
    Posts
    301

    Default Re: More dependency erros with YaST2 - a Catch-22?

    Here's a similar problem, so you weren't the first:
    Zypper Librabry Issue - openSUSE Forums

  5. #5
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: More dependency erros with YaST2 - a Catch-22?

    As posted in the link above: I have had a similar issue happen.

    The problem was that my repositories (the version of OpenSUSE that the repository was for) were mixed. The first thing is to check which repositories you are currently using. To do this, open a terminal window and enter the command zypper sl. This will print the repositories that are currently installed for YaST. If you see any repositories with the name Factory installed, or a repository for another version of OpenSUSE (you are using 11.0 but have a 10.3 repository installed), be sure to remove them. The biggest thing I can say is not to ignore any dependencies or downgrade any packages: that only caused me to lose my ability to use YaST and I had to reformat to repair that problem. If you need further help, post the output for zypper sl so we can see which repositories are currently in use.

    Best of luck.

    Folding@Home
    Help save lives with Folding@Home

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •