Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: OpenSuse 11, laptop microphone

  1. #1

    Default OpenSuse 11, laptop microphone

    Hello,

    this is the output of alsa-info.sh:

    general pastebin - root - post number 1073174

    My laptop microphone doesn't work. If I use the headset microphone is all Ok.

    Can you help me?

    Thanks...

    p.s: I have a Acer laptop 7720 G

  2. #2

    Default Re: OpenSuse 11, laptop microphone

    obviously check you volume levels. You might want to switch on the mic boost. In the volume control go to the switches tab and make sure all of them are turned on.
    I have an Acer 5920 and my mic is working so I guess yours should work as well.
    Good luck.

  3. #3
    Join Date
    Jun 2008
    Location
    Kln, Deutschland
    Posts
    1,054

    Default Re: OpenSuse 11, laptop microphone

    Look up a user on the forum called oldcpu, he is the audio master .

  4. #4

    Default Re: OpenSuse 11, laptop microphone

    All volumes are ok...

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: OpenSuse 11, laptop microphone

    Quote Originally Posted by sorry1 View Post
    this is the output of alsa-info.sh:
    general pastebin - root - post number 1073174 My laptop microphone doesn't work. If I use the headset microphone is all Ok.
    ... p.s: I have a Acer laptop 7720 G
    Surfing a couple of the Linux laptop sites, I note a few users have not succeeded in getting their internal microphones to work under Linux (Ubuntu/Gentoo) on the Acer 7720G.

    When it comes to a microphone, my experience is that one's mixer settings are very important (and very finicky). For mixer settings, the tsalsa diagnostic script provides better formatted information (a nicer summary) than the alsa-info.sh script. So can you please run the tsalsa script by copying and pasting the following into an xterm/konsole:
    Code:
    wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'
    When running the tsalsa diagnostic script, when prompted for a password, enter the root password. Type "NO" for every question you do not understand, please give an accurate answer to the # of input/output jacks, and please post here the URL that you will be provided when the script completes.

    Please also provide the output of copying and pasting the following commands (one line at a time) into an xterm/konsole:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    cat /etc/modprobe.d/sound


    Also, are you using KDE or Gnome? If KDE, is it 3.5.9 or 4.x ?

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: OpenSuse 11, laptop microphone

    Quote Originally Posted by sorry1 View Post
    All volumes are ok...
    The alsa-info-sh script has this for your mixer:

    Code:
    # Simple mixer control 'Input Source',0
    #  Capabilities: cenum
    #  Items: 'Mic' 'Internal Mic' 'Line'
    #  Item0: 'Mic'
    Ie you have it set to your external mic, and not an internal mic.

    When looking at your boost for your internal mic:
    Code:
    # Simple mixer control 'Internal Mic Boost',0
    #  Capabilities: volume
    #  Playback channels: Front Left - Front Right
    #  Capture channels: Front Left - Front Right
    #  Limits: 0 - 2
    #  Front Left: 0 [0%]
    #  Front Right: 0 [0%]
    the levels are at zero. Why?

    If you want the Internal Mic to work, I think you need to set your mixer to the Internal Mic. Also, as gielhendriks noted, move up your boost levels.

    That's not to say there are not other problems, but the above is rather obvious.

  7. #7

    Default Re: OpenSuse 11, laptop microphone

    Hi,

    I have changed the mic boost volume. Now, this is the output of alsa-info.sh:

    general pastebin - root - post number 1074132

    This is the output of tsalsa:

    tsalsa.txt - nopaste.com (beta)

    rpm -qa | grep alsa:

    alsa-oss-32bit-1.0.15-48.1
    alsa-utils-1.0.17.git20080715-1.1
    alsa-plugins-pulse-1.0.17.git20080715-1.1
    alsa-1.0.17.git20080715-1.1
    alsa-devel-1.0.17.git20080715-1.1
    alsa-firmware-1.0.16.92.git20080617-3.1
    alsa-tools-1.0.17.git20080715-1.1
    alsa-plugins-1.0.17.git20080715-1.1
    alsa-oss-1.0.17.git20080715-1.1

    rpm -qa | grep pulse:

    pulseaudio-0.9.10-26.1
    pulseaudio-module-gconf-0.9.10-26.1
    libpulse0-0.9.10-26.1
    pulseaudio-module-zeroconf-0.9.10-26.1
    libpulsecore4-0.9.10-26.1
    libpulse-browse0-0.9.10-26.1
    pulseaudio-module-x11-0.9.10-26.1
    pulseaudio-esound-compat-0.9.10-26.1
    alsa-plugins-pulse-1.0.17.git20080715-1.1
    pulseaudio-utils-0.9.10-26.1
    pulseaudio-module-lirc-0.9.10-26.1
    libpulse0-32bit-0.9.10-26.1
    libpulse-mainloop-glib0-0.9.10-26.1
    pulseaudio-module-bluetooth-0.9.10-26.1
    gstreamer-0_10-pulse-0.9.5-54.1

    rpm -q libasound2:
    libasound2-1.0.17.git20080715-1.1

    cat /etc/modprobe.d/sound:


    options snd slots=snd-hda-intel
    # u1Nb.Z0J4Co96n9E:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel


    I use Gnome.

    Thanks,

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: OpenSuse 11, laptop microphone

    Quote Originally Posted by sorry1 View Post
    I have changed the mic boost volume. Now, this is the output of alsa-info.sh: general pastebin - root - post number 1074132

    This is the output of tsalsa: tsalsa.txt - nopaste.com (beta)
    Thanks for this. But when I look at your mixer, you have it set for "mic" (which I assume is the mic "in" jack, and not the internal mic. If you wish to test the internal mic, do you not have to select it? You don't have it selected.

    Amixer contents for card 0 [Intel] _____________________________________
    amixer set 'Master',0 98%,98% on
    amixer set 'PCM',0 66% 66%
    amixer set 'Line In Boost',0 100% 100%
    amixer set 'Mic Boost',0 100% 100%
    amixer set 'Capture',0 Capture 24 77%,Capture 24 77% on
    amixer set 'Beep',0 92%,92% on
    amixer set 'Input Source',0 Items: 'Mic' 'Internal Mic' 'Line' Item0: 'Mic'
    amixer set 'Internal Mic Boost',0 100% 100%
    Again, the above illustrates you do NOT have the 'Internal Mic" selected. Instead you have the headphone Mic selected!

    Quote Originally Posted by sorry1 View Post
    cat /etc/modprobe.d/sound:
    Code:
    options snd slots=snd-hda-intel
    # u1Nb.Z0J4Co96n9E:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    Thanks!

    If setting your mic to "Internal Mic" does not work, then you could try a custom edit to your /etc/modprobe.d/sound file. The ALSA-Configuration.txt file notes the following entries are applicable for an ALC268 (which your laptop has):
    Linux Kernel Documentation :: sound : alsa : ALSA-Configuration.txt
    Code:
    824		ALC268
    825		  3stack	3-stack model
    826		  toshiba	Toshiba A205
    827		  acer		Acer laptops
    828		  dell		Dell OEM laptops (Vostro 1200)
    829		  test		for testing/debugging purpose, almost all controls can
    830				adjusted.  Appearing only when compiled with
    831				$CONFIG_SND_DEBUG=y
    832		  auto		auto-config reading BIOS (default)
    I've also read the default "auto" setting is not being applied by default for some openSUSE-11.0 users. So first try the "auto" setting, and if that fails, since you have an acer laptop, try the "acer" setting... ie. more specifically, try this /etc/modprobe.d/sound file first:

    Code:
    options snd slots=snd-hda-intel
    options snd-hda-intel model=auto
    # u1Nb.Z0J4Co96n9E:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    and then restart your alsa from an xterm with root permissions with rcalsasound restart and test your audio/mic. Don't forget to check your mixer.

    If that doesn't work, then try
    Code:
    options snd slots=snd-hda-intel
    options snd-hda-intel model=acer
    # u1Nb.Z0J4Co96n9E:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    and then restart your alsa from an xterm with root permissions with rcalsasound restart and test your audio/mic. Don't forget to check your mixer.

    As a final note, no amount of editing the /etc/modprobe.d/sound file will work, if you do not setup your mixer correctly.

  9. #9

    Default Re: OpenSuse 11, laptop microphone

    HI,

    How can I do to set my mic to "Internal Mic".

    Thakns for your help...

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: OpenSuse 11, laptop microphone

    Quote Originally Posted by sorry1 View Post
    How can I do to set my mic to "Internal Mic".
    I am a KDE user. I don't have such problems. In the case of KDE, kmix provides a simple mouse click setting. For non KDE desktops, also check your desktop setup, as some desktop's control the mic via a desktop window manager setting.

    Maybe also look at amixer or alsamixer.

    amixer: amixer(1): mixer for ALSA soundcard driver - Linux man page
    alsamixer: alsamixer(1) - Linux man page or Alsamixer - ALSA wiki

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •