Results 1 to 3 of 3

Thread: Compiling for old glibc

  1. #1

    Exclamation Compiling for old glibc

    Hi,

    I noticed that a JNI library compiled on openSUSE 11 cannot be used on openSUSE 10.3, it complains about glibc being to old (<= 2_7). Now this library is as tiny as can be and definitely does not use fancy new code from glibc 2.7.

    Is there a switch or a trick I can use to be able to compile the library such that other and older Linuces are able to use it as well?

    Thanks, H.

  2. #2

    Default Re: Compiling for old glibc

    Provide the source, let everyone compile it against their own glibc they have.

  3. #3

    Thumbs down Re: Compiling for old glibc

    Well, yes, of course. The code is GPL and can be gotten from svn. However, I dont expect my users to be able to compile anything, certainly not JNI code. So I would like to offer an installer which just works.

    I suppose the solution would be to make an rpm on a 10.3 machine.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •