Results 1 to 8 of 8

Thread: ./ not working

  1. #1
    bhavikdbavishi NNTP User

    Question ./ not working

    Hi,
    I've install openSUSE11.0 recently...
    i was about to install 'gmake',so....
    i try cd to dir. where 'configure' is there, then
    i tried './configure' but it display "Permission Denied!!!"
    then i checked it permission and make it executable...
    but still it is throwing same error???
    I tried with bash, sh and zsh.......!!!!!!!

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: ./ not working

    Why do you need to install gmake? The make in Linux is normally already GNU make.

  3. #3
    bhavikdbavishi NNTP User

    Default Re: ./ not working

    Ohhh.. OK.. that i don't know.....
    anyway but ./<script_name> should work right..!!!
    Or I have to change setting..??????

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: ./ not working

    Maybe you tried to run it on a filesystem without exec permission in the mount? You can see the options in the output of mount. If noexec is in there, you can't run programs in that partition.

  5. #5
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    52

    Default Re: ./ not working

    to run a shell script make sure you have permission to run it(chmod a+x) then when you are in the directory where the script is ./script name

    easy!

  6. #6
    ab@novell.com NNTP User

    Default Re: ./ not working

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    And to verify post the output from:

    ls -l ./configure
    and:
    mount

    Good luck.




    chef d wrote:
    > to run a shell script make sure you have permission to run it(chmod a+x)
    > then when you are in the directory where the script is ./script name
    >
    > easy!
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFI6h3n3s42bA80+9kRAlVWAKCJi/fG+eBnD0Vi3IcC1MIK49nc3wCfS3P5
    GOoEvpcJfzjyeVryVx7i8w8=
    =daiW
    -----END PGP SIGNATURE-----

  7. #7
    bhavikdbavishi NNTP User

    Question Re: ./ not working

    Quote Originally Posted by ken_yap View Post
    Maybe you tried to run it on a filesystem without exec permission in the mount? You can see the options in the output of mount. If noexec is in there, you can't run programs in that partition.
    Thanx for the reply, to be frank I don't know about exec permission filesystem...
    So can u plz tell me what to do if I found noexec is in o/p of 'mount' cmd...????

  8. #8
    ab@novell.com NNTP User

    Default Re: ./ not working

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Respond to other post.

    Good luck.





    bhavikdbavishi wrote:
    > ken_yap;1880070 Wrote:
    >> Maybe you tried to run it on a filesystem without exec permission in the
    >> mount? You can see the options in the output of mount. If noexec is in
    >> there, you can't run programs in that partition.

    >
    > Thanx for the reply, to be frank I don't know about exec permission
    > filesystem...
    > So can u plz tell me what to do if I found noexec is in o/p of 'mount'
    > cmd...????
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFI62p33s42bA80+9kRAh3aAJoCT9z63JWbNhalPGJQyI27VpvDTACfR4GD
    xw4p+ECtY6DdAIpXmH7ifpQ=
    =Ylsb
    -----END PGP SIGNATURE-----

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •