Results 1 to 4 of 4

Thread: 11.0 Postgresql Downgrade Repositories

  1. #1
    skywalka_de NNTP User

    Unhappy 11.0 Postgresql Downgrade Repositories

    Hello,

    I'm using LX-Office 2.4.3 with openSuse 11.0. In 10.3 everything worked fine, but when I upgraded to 11.0 I had problems with INSERT and UPDATE commands via plpgsql.so.

    Error:
    Code:
    FEHLER: konnte Bibliothek /usr/lib/postgresql/plpgsql.so nicht laden: /usr/lib/postgresql/plpgsql.so: undefined symbol: pg_re_throw
    No one has a solution to this problem, so I will try to downgrad postgresql.

    Can I use repositories for that? If yes, which ones?

  2. #2
    skywalka_de NNTP User

    Default Re: 11.0 Postgresql Downgrade Repositories

    No way... I added the 10.3 oss repo again, and checked the dependencies. Yast would downgrade not only postgresql, but also pidgin, libpurple, tcl, tk .... and many more. That can't be the solution....

  3. #3
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: 11.0 Postgresql Downgrade Repositories

    Mixing distribution version repositories will break your system - infact you most likely already did a considerable amount of damage if you downgraded the postgre libs to 10.3 level.

    Undefined symbol means your postgre files have mixed versions.

  4. #4
    skywalka_de NNTP User

    Default Re: 11.0 Postgresql Downgrade Repositories

    Yes, I realized that.

    And I found a solution for lx-office.

    - create a dump of the database or maybe two (to work with one of them)
    - change all CREATE TABLE commands to end with "WITH OIDS", like:
    Code:
    CREATE TABLE "Umsätze" (
    "Kennzeichen" character(10) NOT NULL,
    "Datum" date[] NOT NULL,
    "km-Stand" integer NOT NULL,
    "Kostenart" character(1) NOT NULL,
    "Betrag" money
    ) WITH OIDS;
    - delete the old database
    - import the changed dump (WITH OIDS) again
    - lx-office 2.4.3 works again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •