I currently have the 2.6.22.17-0.1-default #1 SMP x86_64 kernel. I want to update my kernel to stay current. However, when the automatic updater shows me the little red triangle with the exclamation mark in it, and I click on it to upgrade to the new kernel, I get this error message:

20 Problems: Problem: No valid solution found with just resolvables of best architecture. Problem: libFLAC8-32bit cannot be installed due to missing dependencies Problem: yast2-gtk cannot be installed due to missing dependencies Problem: xine-lib cannot be installed due to missing dependencies Problem: opera cannot be installed due to missing dependencies
...
With this run only resolvables with the best architecture have been regarded. Regarding all possible resolvables takes time, but can come to a valid result. Solution 1: Make a solver run with ALL possibilities. Regarding all resolvables with a compatible architecture.
I searched in Yast, but I cannot figure out how to make the solver run with all possibilities. Can someone please point me in the right direction?