Results 1 to 9 of 9

Thread: alien arena

  1. #1

    Default alien arena

    hi all,
    i have installed alien arena on my pc,
    but the program wont start, i dont recieve any error
    but the icon will just stop on bouncing
    i dont know what the problem is

    thanks

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: alien arena

    * giancarlos20,

    try launching it from a console, that often shows some errors.

    Uwe

  3. #3
    oldmanken NNTP User

    Default Re: alien arena

    I had a similar problem - followed the advice from Uwe and got a 'could not find file' error. Checked the Alienarena script in usr/bin and found it was looking for a file 'crx.sdl' in usr/lib but on my system it's in usr/lib64. I edited the line accordingly and it fires up from the menu.

    Now I just have to get it to run with sound.

    Hope this helps.

    Ken

  4. #4

    Default Re: alien arena

    thanks everyone,
    it's working perfectly now

  5. #5
    sijdal NNTP User

    Default Re: alien arena

    HI
    NEWBIE TO sUsE
    AMD 64 running OpenSuse 11

    cant get AlienArena to work
    following error

    ./crx.sdl: error while loading shared libraries: libSDL-1.2.so.0: cannot open shared object file: No such file or directory

    don't know what file to edit to change the path to this file
    Please Help
    thanks

  6. #6
    Join Date
    Jul 2008
    Location
    Ljubljana
    Posts
    522

    Default Re: alien arena

    IIRC you can just create a symlink (with the name required by your game, in the path required by your game) to the actual library you have on your system; this can even be done from Konqueror, although it may require you to launch Konqueror as root. Correct me if I'm wrong.
    http://stopsoftwarepatents.eu/
    Even if free software were ****, it should still get our preference over the non-free **** secreted by IT corporations.
    A free rephrasing of RMS

  7. #7
    toympas NNTP User

    Exclamation Re: alien arena

    installed the package and i get 3 executables, the crded / crx / crx.sdl

    When i run either crx or crx.sdl it exits with "libcurl.so.3 cannot be found". Im sure im using the .4 version and although i tried to load the .3 i couldnot.

    Any help please

  8. #8
    Join Date
    Jul 2008
    Location
    Ljubljana
    Posts
    522

    Default Re: alien arena

    It's as I told you; go to the directory where your libcurl.so.4 library resides and create a symlink to it (naming it exactly as your program requires -- that would be libcurl.so.3). This is the general workaround to use when an older program requires an older version of a certain library, of which you only have a newer version. If the two versions are compatible (as is generally the case), your program should now find the .3 library symlink, which should redirect it to the real library (the .4 version) and everything should work. If that's still not the case, then the program is obviously looking for the library in a different folder; but once you discover which folder is that, the procedure to follow is trivial.
    Good luck!
    http://stopsoftwarepatents.eu/
    Even if free software were ****, it should still get our preference over the non-free **** secreted by IT corporations.
    A free rephrasing of RMS

  9. #9
    toympas NNTP User

    Cool Re: alien arena

    Thanx it worked.

    For all people who got the same problem the solution is easy.
    When you the the error about cant find libcurl.so.3 do this.

    cd /usr/lib

    <hit enter>

    sudo ln libcurl.so.4 libcurl.so.3

    <hit enter>

    crx

    <hit enter>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •