Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Zypper Librabry Issue

  1. #1
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Zypper Librabry Issue

    Hey all,

    Even after I reinstalled OpenSUSE 11.0 , I still seem to have a problem with the library files for Zypper. When I go to install any library file through YaST, such as cups-lib, I get the following error: click here. I don't want to jump and make any changes because that is what caused YaST and Zypper to fail last time an error like this happened. The other program I have is that when I go to install standard patched and updates, I get this error...

    nothing provides libexiv2.so.4 needed by libkexiv2-3-0.1.7-15.i586
    nothing provides libexiv2.so.4 needed by ufraw-0.13-52.i586
    nothing provides libexiv2.so.4 needed by ufraw-gimp-0.13-52.i586
    nothing provides yast2 >= 2.17.7 needed by yast2-installation-2.17.0-2.noarch
    zvbi-0.2.30-3.i586 requires libzvbi.so.0, but this requirement cannot be provided
    gconf2-branding-openSUSE-2.20-60.noarch requires desktop-data-openSUSE = 11.0, but this requirement cannot be provided
    libtunepimp5-mp4-0.5.3-100.pm.9.i586 requires libtunepimp5 = 0.5.3-100.pm.9, but this requirement cannot be provided
    zypper-0.11.9-0.1.i586 requires libzypp.so.424, but this requirement cannot be provided
    I added the KDE4 Factory repository to see if that would help (since I use Gnome), but that really didn't do much, maybe just stopped one of the errors. So, my question is, should I simply ignore this, or is this a problem with OpenSUSE: that the patches do not match the version of the needed by the programs?

    Thank you in advance!

    Folding@Home
    Help save lives with Folding@Home

  2. #2

    Default Re: Zypper Librabry Issue

    Looks like you have the zypp:svn repository. And it's trying to mix zypper from the official repository with libzypp from zypp:svn.

    Anyway, "do not install libzypp-5.0.2-5.i586" looks like the correct answer to me.

    A "zypper sl" would make things clearer.

  3. #3
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: Zypper Librabry Issue

    I ran zypper sl, and got the following...

    Code:
    #  | Alias                                                                           | Name                                   | Enabled | Refresh
    ---+---------------------------------------------------------------------------------+----------------------------------------+---------+--------
    1  | http://download.opensuse.org/repositories/mozilla/openSUSE_11.0/                | openSUSE BuildService - Mozilla        | Yes     | Yes    
    2  | openSUSE:Factory                                                                | openSUSE:Factory                       | Yes     | Yes    
    3  | OpenSUSE_11.0:_Zaitor_Factory                                                   | OpenSUSE 11.0: Zaitor Factory          | Yes     | Yes    
    4  | http://download.nvidia.com/opensuse/11.0                                        | NVIDIA Repository                      | Yes     | Yes    
    5  | KDE4_Factory                                                                    | KDE4 Factory                           | Yes     | Yes    
    6  | Apache                                                                          | Apache                                 | Yes     | Yes    
    7  | http://download.opensuse.org/repositories/games/openSUSE_11.0/                  | openSUSE BuildService - Games          | Yes     | Yes    
    8  | http://download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_11.0/          | openSUSE BuildService - GNOME:STABLE   | Yes     | Yes    
    9  | http://download.opensuse.org/repositories/X11:/XGL/openSUSE_11.0/               | openSUSE BuildService - X11:XGL        | Yes     | Yes    
    10 | repo-non-oss                                                                    | openSUSE-11.0-Non-Oss                  | Yes     | No     
    11 | Server:_Database                                                                | Server: Database                       | Yes     | Yes    
    12 | repo-oss                                                                        | openSUSE-11.0-Oss                      | Yes     | No     
    13 | http://download.opensuse.org/repositories/OpenOffice.org:/STABLE/openSUSE_11.0/ | openSUSE BuildService - OpenOffice.org | Yes     | Yes    
    14 | Server:_PHP                                                                     | Server: PHP                            | Yes     | Yes    
    15 | repo-debug                                                                      | openSUSE-11.0-Debug                    | No      | No     
    16 | openSUSE-11.0-Updates                                                           | openSUSE-11.0-Updates                  | Yes     | Yes    
    17 | openSUSE-DVD 11.0                                                               | openSUSE-DVD 11.0                      | Yes     | No     
    18 | Wine_MS_Emulator                                                                | Wine MS Emulator                       | Yes     | Yes    
    19 | http://ftp.skynet.be/pub/packman/suse/11.0/                                     | Packman Repository                     | Yes     | Yes

    Folding@Home
    Help save lives with Folding@Home

  4. #4

    Default Re: Zypper Librabry Issue

    And are you sure you want all of them???
    Specially the "Factory" (openSUSE development version) ones...

  5. #5
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: Zypper Librabry Issue

    Most of them were added when I installed 1 single package, and I kept them.

    But which one would cause the problem I'm having?

    Folding@Home
    Help save lives with Folding@Home

  6. #6
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: Zypper Librabry Issue

    Well, went along with the downgrading thing, and now none of the YaST commands work...

    If I go to Install Software, I get the error...

    Error while creating client module sw_single
    I also have an update for Zypper available, but I get the dependency error of...

    zypper-0.11.9-0.1.i586 requires libzypp.so.424, but this requirement cannot be provided
    To add to that, I have an alert on the bottom Gnome panel telling me that I have to restart the computer (which I did and nothing happened).

    Looks like 1 giant cycle: I can't upgrade Zypper because I can't access YaST, but Zypper is too low of a version...and I can't update it now...

    Hmmm...I guess I'm just going to have to reinstall OpenSUSE 11.0 again.

    If anyone has any other ideas that will solve this problem, please mention them: it would be much easier than reinstalling at this point.

    Folding@Home
    Help save lives with Folding@Home

  7. #7

    Default Re: Zypper Librabry Issue

    Your problem is already know : you have mixed some factory repo with the 11.0 stable one (repo 2 and 3).

    Remember to _never_ do that, if you want to avoid some pain in the future.

    PS: Don't 1-click-install Factory stuff too.

  8. #8
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: Zypper Librabry Issue

    Okay, so just simply install only the STABLE versions of packages from now on?

    Folding@Home
    Help save lives with Folding@Home

  9. #9

    Default Re: Zypper Librabry Issue

    Not exactly : do not mix repo of different openSUSE version (Factory repo with 11.0, or 11.0 repo with 10.3 repo, ...).

    Package depends of other specific version packages, and the dependancy solver check at rules of each package to install them with their respective depandancies.

    If you introduce some 'false' rules (other repo, with _same_ rules but for _other_ version package), you break the chain and your system too.

  10. #10
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: Zypper Librabry Issue

    Okay, so don't install general repositories, like Factory reps?

    Because the Zaitor repository has a Factory, and a 11.0 version, so the 11.0 version would be fine to install?

    (Sorry for all the questions, just trying to be positive and keep this from happening again.)

    Thank you again.

    Folding@Home
    Help save lives with Folding@Home

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •