Results 1 to 4 of 4

Thread: Problems with sound

  1. #1
    beosoundftw NNTP User

    Default Problems with sound

    Hey,

    I have a problem with the sound on my laptop, I can't adjust the volume anymore. When I just had installed Opensuse 11, everything worked flawlessly, but now, when I'm choosing Realtek ALC861 (OSS Mixer) and then the PCM-2 it just jumps to maximum volume when I try to adjust the volume.
    In addition there is no sound at all when I'm using VLC-Player.
    I'm using a Zepto Znote 6214W.

    Suggestions?

    Thanks in advance..

    Beosound

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Problems with sound

    Quote Originally Posted by beosoundftw View Post
    I have a problem with the sound on my laptop, I can't adjust the volume anymore. When I just had installed Opensuse 11, everything worked flawlessly, but now, when I'm choosing Realtek ALC861 (OSS Mixer) and then the PCM-2 it just jumps to maximum volume when I try to adjust the volume. ........I'm using a Zepto Znote 6214W.
    So if I read this correctly, it was working before, but it is not now?

    Typically that means 1 of 3 things, ... either:
    a. you changed your software configuration by adding/replacing existing rpms, or
    b. you changed your mixer settings, in inadvertently disabling the volume control, or
    c. you changed your hardware some how (in BIOS or somewhere else).

    I suspect you messed up your mixer. Please check your mixer thoroughly.

    Also, can you post here the output of:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    cat /etc/modprobe.d/sound
    uname -a


    Also, with your Laptop connected to the internet, if you can run the following two audio diagnostic scripts (one at a time) in an xterm/konsole (copy and paste them). These scripts, when complete, will provide you a URL. Please post the URL here:
    Code:
    wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh
    In this next script, when prompted for a password, please enter the root password. And please type "NO" to every question that you do not understand.
    Code:
    wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'
    Again, please post here the URL they provide.

    Quote Originally Posted by beosoundftw View Post
    In addition there is no sound at all when I'm using VLC-Player.
    Typically this can be because:
    a. VLC is missing the codec for the file you are trying to play, or
    b. the file you are trying to play is corrupted, or
    c. you have VLC set to the wrong sound output module, or
    d. you have something in your graphics setup that is interfering with VLC (such as having the wrong graphics output module selected), or
    e. you have mixed packman and videolan applications, and the two different applications do not always mix well together.

    Yesterday, a user on IRC#suse was complaining vlc would not play AC3 audio. I don't have that problem, but they were adament it existed in both the Packman and Videolan versions of vlc. They were a 64-bit openSUSE-11.0 user, and they refused to give (or produce) me a sample copy of the files that were giving them problems. There are limits to how much one can propose without more information.

    Good luck.

  3. #3
    beosoundftw NNTP User

    Smile Re: Problems with sound

    Also, can you post here the output of:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    cat /etc/modprobe.d/sound
    uname -a
    Here is the output:

    Code:
    schlinux:/home/albert # rpm -qa | grep alsa
    alsa-1.0.16-39.1
    alsa-plugins-pulse-1.0.16-57.1
    alsa-firmware-1.0.16-24.1
    alsa-oss-32bit-1.0.15-48.1
    alsa-utils-1.0.16-35.1
    alsa-oss-1.0.15-48.1
    alsa-plugins-1.0.16-57.1
    schlinux:/home/albert # rpm -qa | grep pulse
    libpulse0-0.9.10-26.1
    pulseaudio-utils-0.9.10-26.1
    pulseaudio-module-bluetooth-0.9.10-26.1
    pulseaudio-esound-compat-0.9.10-26.1
    libpulse-mainloop-glib0-0.9.10-26.1
    alsa-plugins-pulse-1.0.16-57.1
    pulseaudio-0.9.10-26.1
    pulseaudio-module-lirc-0.9.10-26.1
    libpulse0-32bit-0.9.10-26.1
    pulseaudio-module-gconf-0.9.10-26.1
    libpulsecore4-0.9.10-26.1
    pulseaudio-module-zeroconf-0.9.10-26.1
    gstreamer-0_10-pulse-0.9.7-42.pm.1
    libpulse-browse0-0.9.10-26.1
    pulseaudio-module-x11-0.9.10-26.1
    schlinux:/home/albert # rpm -q libasound2
    libasound2-1.0.16-39.1
    schlinux:/home/albert # cat /etc/modprobe.d/sound
    
    options snd slots=snd-hda-intel
    # u1Nb.JZIjACQr6o8:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel
    schlinux:/home/albert # uname -a
    Linux schlinux 2.6.25.9-0.2-default #1 SMP 2008-06-28 00:00:07 +0200 x86_64 x86_64 x86_64 GNU/Linux
    Also, with your Laptop connected to the internet, if you can run the following two audio diagnostic scripts (one at a time) in an xterm/konsole (copy and paste them). These scripts, when complete, will provide you a URL. Please post the URL here:
    Code:

    wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh
    There wasn't any URL.

    In this next script, when prompted for a password, please enter the root password. And please type "NO" to every question that you do not understand.
    Code:

    wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'
    URL:
    tsalsa.txt - nopaste.com (beta)

    Thanks for the answer, I have solved my problem with VLC by resetting the settings.

    BR Beosound

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Problems with sound

    Quote Originally Posted by beosoundftw View Post
    Here is the output:

    Code:
    schlinux:/home/albert # rpm -qa | grep alsa ........
    Thanks, the alsa apps look good.

    Quote Originally Posted by beosoundftw View Post
    Code:
    schlinux:/home/albert # rpm -qa | grep pulse
    libpulse0-0.9.10-26.1
    pulseaudio-utils-0.9.10-26.1
    pulseaudio-module-bluetooth-0.9.10-26.1
    pulseaudio-esound-compat-0.9.10-26.1
    libpulse-mainloop-glib0-0.9.10-26.1
    alsa-plugins-pulse-1.0.16-57.1
    pulseaudio-0.9.10-26.1
    pulseaudio-module-lirc-0.9.10-26.1
    libpulse0-32bit-0.9.10-26.1
    pulseaudio-module-gconf-0.9.10-26.1
    libpulsecore4-0.9.10-26.1
    pulseaudio-module-zeroconf-0.9.10-26.1
    gstreamer-0_10-pulse-0.9.7-42.pm.1
    libpulse-browse0-0.9.10-26.1
    pulseaudio-module-x11-0.9.10-26.1
    That is a lot of pulse audio applications. Pulse audio is not as stable on 11.0 as had been hoped. It is possible that is your problem (I don't know). One solution some openSUSE-11.0 users are adopting is to remove all pulse audio applications. I don't know if that is the best solution, but it is a possibility to consider.

    Quote Originally Posted by beosoundftw View Post
    Code:
    # cat /etc/modprobe.d/sound
    
    options snd slots=snd-hda-intel
    # u1Nb.JZIjACQr6o8:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel
    Ok, thanks for this. One thing you could do is try various options from the /etc/modprobe.d/sound file for your ALC861. The options are:
    Code:
    	ALC861/660
    	  3stack	3-jack
    	  3stack-dig	3-jack with SPDIF I/O
    	  6stack-dig	6-jack with SPDIF I/O
    	  3stack-660	3-jack (for ALC660)
    	  uniwill-m31	Uniwill M31 laptop
    	  toshiba	Toshiba laptop support
    	  asus		Asus laptop support
    	  asus-laptop	ASUS F2/F3 laptops
    	  auto		auto-config reading BIOS (default)
    So try the following edit to your /etc/modprobe.d/sound file as a start:
    options snd slots=snd-hda-intel
    # u1Nb.JZIjACQr6o8:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel

    options snd-hda-intel model=auto

    then restart your alsa sound from an xterm/konsole with root permissions with rcalsasound restart and then test your volume again.

    If that does not work, then in the /etc/modprobe.d/sound file, replace "auto" with each of the models one at a time, restart alsa after each change (ie replace with "asus-laptop", "asus", "toshiba", "uniwill-m31", "6stack-dig", "3stack-dig", and finally "3stack" one at a time (restarting alsa after each attempt). I suspect "auto" and "3stack" has the best chance of working.

    Also, do not forget to check your BIOS to ensure there are no inappropriate audio settings there (although I see no evidence of this from what you have posted).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •