Results 1 to 6 of 6

Thread: Problem when trying to copy a file

  1. #1
    Join Date
    Jul 2008
    Location
    Tr4nc3LanD
    Posts
    24

    Question Problem when trying to copy a file

    I have tried to copy a file from my USB to 1 of my mounted NTFS partitions, but everytime I tried to copy the file it throwed this warning:

    Code:
    Invalid or incomplete multibyte or wide character
    After a while I tried renaming the file to a different name (it has an special character in its name, the character was ""). Why happened to me that ? Is not supposed to be Linux Unicode ?

    By Unicode I understand that it can handle most of the characters from other languages or I'm wrong ?

    PD: I dont remember to have had a problem like this in the past, and I have files named not only in English.

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Problem when trying to copy a file

    * rax369,

    you say you copy it TO an NTFS partition, so I guess that NTFS has a problem with that character.

    Uwe

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,450

    Default Re: Problem when trying to copy a file

    There are several different implementations of Unicode. Linux uses utf8 which varies the length of the character depending on its place in the Unicode sequence but MS uses a 16 bit format which keeps the length the same throughout the sequence.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,382
    Blog Entries
    1

    Default Re: Problem when trying to copy a file

    Some useful mounting options discussed in this ubuntu thread, concerning iocharset and locale options when mounting partitions for reading files. Quite interesting, as I often take it for granted as an English only user.

  5. #5
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Problem when trying to copy a file

    rax369 wrote:

    >
    > I have tried to copy a file from my USB to 1 of my mounted NTFS
    > partitions, but everytime I tried to copy the file it throwed this
    > warning:
    >
    >
    > Code:
    > --------------------
    > Invalid or incomplete multibyte or wide character
    > --------------------
    >
    >
    > After a while I tried renaming the file to a different name (it has an
    > special character in its name, the character was "ó"). Why happened to
    > me that ? Is not supposed to be Linux Unicode ?
    >
    > By Unicode I understand that it can handle most of the characters from
    > other languages or I'm wrong ?
    >
    > PD: I dont remember to have had a problem like this in the past, and I
    > have files named not only in English.
    >
    >


    It's NTFS having the issue. It doesn't like multibyte characters. I know it
    *should*... but.. uh.. it doesn't.

    My usual (potentially irritating answer) here is "Welcome to Windows"

    Oh, try copying a file with a colon ':' in the name. Windows filesystems
    refuse. ({Grin} works on linux though!)

    Linux filenames (directory names, device names, etc) can contain just about
    ANY character. I believe 0 bytes and slashes are excluded.

    Loni

    --
    L R Nix
    lornix@lornix.com

  6. #6
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Problem when trying to copy a file

    L R Nix wrote:

    > rax369 wrote:
    >
    >>
    >> I have tried to copy a file from my USB to 1 of my mounted NTFS
    >> partitions, but everytime I tried to copy the file it throwed this
    >> warning:
    >>
    >>
    >> Code:
    >> --------------------
    >> Invalid or incomplete multibyte or wide character
    >> --------------------
    >>
    >>
    >> After a while I tried renaming the file to a different name (it has an
    >> special character in its name, the character was "ó"). Why happened to
    >> me that ? Is not supposed to be Linux Unicode ?
    >>
    >> By Unicode I understand that it can handle most of the characters from
    >> other languages or I'm wrong ?
    >>
    >> PD: I dont remember to have had a problem like this in the past, and I
    >> have files named not only in English.
    >>
    >>

    >
    > It's NTFS having the issue. It doesn't like multibyte characters. I know
    > it *should*... but.. uh.. it doesn't.
    >
    > My usual (potentially irritating answer) here is "Welcome to Windows"
    >
    > Oh, try copying a file with a colon ':' in the name. Windows filesystems
    > refuse. ({Grin} works on linux though!)
    >
    > Linux filenames (directory names, device names, etc) can contain just about
    > ANY character. I believe 0 bytes and slashes are excluded.
    >
    > Loni
    >


    the 'ntfs' filesystem type does support two options which might help filename
    issues, 'nsl=' and 'utf8', which deal with charsets.

    ntfs-3g, the improved ntfs driver, says it supports 'ALL' characters, with the
    exception of \0 bytes and '/'. Might be helpful in your case.

    There are threads (somewhere, they move...) here in opensuse forums that
    discuss how to mount ntfs volumes using ntfs-3g instead of 'ntfs'.

    Take Care,

    Loni

    --
    L R Nix
    lornix@lornix.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •