Results 1 to 6 of 6

Thread: protein folding ( need 100% cpu usage) how?

  1. #1
    Join Date
    Jun 2008
    Location
    Hertfordshire, England
    Posts
    46

    Default protein folding ( need 100% cpu usage) how?

    Hi all,

    I am protein folding on my Q6600 computer which is overclocked to 3.150. I am using OpenSuse 11 and KDE 3.5.9.

    The folding is slower than when I was running OpenSuse 10.3 and I have just checked and the cpu usage never goes above 50%. As the computer is only used for folding I need to set folding to use 100% of the cpu usage, but I do not see an option of doing this.

    I have looked at the "client.cfg", but see no reference to the cpu usage.

    Any help would be appreciated.

    Best regards Keith

  2. #2
    ab@novell.com NNTP User

    Default Re: protein folding ( need 100% cpu usage) how?

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    This may depend a lot more on your app than anything else. For example
    a single-threaded process on a multi-proc system will never take 100% of
    all the CPUs/cores no matter how bored the computer is. The BOINC
    client I use is fairly smart and runs one process per core so
    collectively I'm using my entire box as much as possible and get the
    total number of results as high as possible, though each result takes
    longer than it would if it could somehow receive all the power of the
    computer at once.

    Good luck.






    tinca wrote:
    | Hi all,
    |
    | I am protein folding on my Q6600 computer which is overclocked to
    | 3.150. I am using OpenSuse 11 and KDE 3.5.9.
    |
    | The folding is slower than when I was running OpenSuse 10.3 and I have
    | just checked and the cpu usage never goes above 50%. As the computer is
    | only used for folding I need to set folding to use 100% of the cpu
    | usage, but I do not see an option of doing this.
    |
    | I have looked at the "client.cfg", but see no reference to the cpu
    | usage.
    |
    | Any help would be appreciated.
    |
    | Best regards Keith
    |
    |
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFIepEp3s42bA80+9kRAjwDAJ9YWDrdrPjoXiILkExCgN8pB+C1lwCdHR1N
    znsFK1aTDHym0z8v4HFrh+M=
    =6jFO
    -----END PGP SIGNATURE-----

  3. #3
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: protein folding ( need 100% cpu usage) how?

    Is your cpu policy set correct ? could be that you have set it to power-save.

    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: protein folding ( need 100% cpu usage) how?

    > Q6600 computer

    a google tells me that your computer is dual core....so, run two
    instances of folding...(no, i don't know how but i'd guess you can find
    it somewhere near the cite just following)

    OR, read up on the SMP client at http://folding.stanford.edu/English/FAQ-SMP

    --
    DenverD (Linux Counter 282315)
    A Texan in Denmark

  5. #5

    Default Re: protein folding ( need 100% cpu usage) how?

    Are you using a parellel version of the folding software? Did you compile for OpenMP or some flavor of MPI? Which software are you using? Perhaps the listserver for the specific package might have some insights.

  6. #6
    Join Date
    Jun 2008
    Location
    Hertfordshire, England
    Posts
    46

    Default Re: protein folding ( need 100% cpu usage) how?

    Hi all,

    Whatever the problem was seems to be my fault. I was running OpenSuse 10.3 for several months and for the final week I had been diligently keeping track of its folding times. I shut down folding and then copied the whole directory to my USB pendrive.

    I reformatted the hardrive and installed OpenSuse 11. Once it was up and running I copied the folding folder back into my home directory and started folding again.

    This was when it was patently obvious that it was very slow indeed. I have just deleted the folder, downloaded a new client from "Stanford", set it up and it is now folding at the correct speed.

    It is my fault for taking the lazy option and not doing it properly.

    Thank you to all who replied.

    Best regards Keith

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •