Results 1 to 5 of 5

Thread: sax2 error: cannot deactivate all displays

  1. #1
    Join Date
    Jun 2008
    Location
    Morecambe Bay
    Posts
    103

    Default sax2 error: cannot deactivate all displays

    I'm running Suse11 and have just installed my video driver for the ATI Radeon 9550 via the one-click install. At first the catalyst center wouldn't open, telling me I didn't have a driver installed. Sax2 showed the graphics card and the correct monitor (LG1917) and correct resolution.
    Trying to run the compiz deskop effects were received with a blank black and then white screen.

    After googling I read a few times that I had to type "aticonfig --initial" after installing the ati driver.
    My screen wobbled a bit, and the resolution was changed to 1440x900 and the monitor is now showing as ATI.
    When I start Sax2, I get the error message "Cannot Deactivate All Displays - At least one display must be active".
    When I try and change the monitor from ATI back to the LG and the correct resolution I get the following message
    Saving Configuration Failed
    The following report has been created:
    SAX library: Success
    X configuration: Data incomplete in file /var/lib/sax/xorg.conf
    Undefined screen "aticonfig-Screen[D]" referenced by Server Layout "Layoug [all]".
    The catalyst control centre now works, but I can't change the monitor in there and setting the correct screen resolution doesn't work in there either.

    Any help is greatly appreciated

  2. #2

    Default Re: sax2 error: cannot deactivate all displays

    I'm having the same problem, except with ATI X600 on my Acer laptop. When I first installed Suse and tried to enable compiz, I got white screen, after a lot of surfing, and installation dvd I managed to remove compiz and fglxr drivers and I got my desktop back. Then I downloaded ati drivers from their site and installed them, now I can't change the screen or enable 3d in SAX2. I get the same Error. I tried editing xorg.conf file, but after I start sax2 it changes back. Also when I start sax2 I get: Cannot deactivate all displays At least one display must be active.

  3. #3
    Join Date
    Aug 2008
    Location
    Earth, UK, England, London
    Posts
    88

    Default Re: sax2 error: cannot deactivate all displays

    Hi there,

    I just had the same problem today. I installed the ATI drivers and typed in "sudo aticonfig --initial". After I restarted X, Sax2 was giving me the same message "Cannot Deactivate All Displays - At least one display must be active"

    To fix this I had to configure Sax2 to use the new ATI driver.

    > su
    > your password
    > sax2 -r -m 0=fglrx
    It fixed it for me. But read the instructions, they are from here. ATI - openSUSE


    Step 4 - Configuring the newly installed ATI driver

    After the driver has been installed it now needs to be configured. Run this command after you have installed the driver.

    # sax2 -r -m 0=fglrx

    This forces sax2 to use the fglrx driver. Setup your resolution and save and exit

    Attention: If you have ati radeon x1650 then you may want to skip previous command because sax2 doesn't make correct settings. You should run sax -a before installing the driver and after installing driver just run following command:

    # aticonfig --initial input=/etc/x11/xorg.conf

    And after that you should modify xorg.conf by yourself.

    Attention: If sax2 goes to a blank screen then try the below method, if that doesn't work, follow the the steps from the Troubleshooting section.

  4. #4
    Join Date
    Aug 2008
    Location
    Earth, UK, England, London
    Posts
    88

    Default Re: sax2 error: cannot deactivate all displays

    Actually forget that, it worked until I restarted, now I'm presented with a lovely blank black screen when I turn on the computer..

    AAAGGGHHHHHHH!!!!

  5. #5
    Join Date
    Aug 2008
    Location
    Earth, UK, England, London
    Posts
    88

    Default Re: sax2 error: cannot deactivate all displays

    PLEASE DON'T LISTEN TO MY ADVICE ABOVE IT WOULD PROBABLY GIVE YOU THE BLACK SCREEN PALAVER.

    Ok, I fixed my black screen by booting with init 3

    Then I used the commands:

    > sax2 -r -m 0=vesa
    > init 5
    This reverts it back to default, then I installed my good old ATI repo drivers from the opensuse - 1 click install.

    > sudo aticonfig --initial
    -> CTRL+ALT+BACKSPACE
    login again..

    and BAM, I was back to normal.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •