Results 1 to 5 of 5

Thread: How to use modprobe?? Please Help!!

  1. #1
    matt_SUSE NNTP User

    Default How to use modprobe?? Please Help!!

    Hi, I'm a new user (SUSE 11.0). I really want to break with MS Windows but so far having some trouble - help will be greatly appreciated.

    To install the madwifi driver needed for my Atheros 802.11 card the instructions located at:
    Atheros madwifi - openSUSE
    tell me I need to perform

    "modprobe ath_pci"

    I assume it's telling me to type this in a terminal command line, but when I do that the reply is:

    "bash: modprobe: command not found"

    I've checked in YaST and I already have the package "module-init-tools" installed, which says it contains the "modprobe" command. If it means anything to you I find another command from the package ie "lsmod" works, but none of the few others I try do.

    Please help me to get "modprobe" working properly.

  2. #2

    Default Re: How to use modprobe?? Please Help!!

    you also have to be root to type that command in. So type


    followed by your root password first.

    then it can modprobe for you

  3. #3
    matt_SUSE NNTP User

    Default Re: How to use modprobe?? Please Help!!

    Thanks a lot for answering me gregosmith . . . I think it worked, but now there's a new error message which may be related to more "modprobe" problems, or may be related to some error I've made in previous steps . . .

    So now I type "su <username> modprobe ath_pci" then it asks me for my password. Then the next line displayed is:

    "bash: modprobe: No such file or directory"

    Is that related to "modprobe" again or the "ath_pci"?

  4. #4
    Join Date
    Jun 2008
    Omaha, NE

    Default Re: How to use modprobe?? Please Help!!


    and then hit enter, and then put in the password. That logs you in as super user (root). Or you can do:

    sudo modprobe ath_pci

    that will also prompt for the password, but it just runs the one command as super user, as opposed to logging you as super user.

  5. #5
    matt_SUSE NNTP User

    Default Re: How to use modprobe?? Please Help!!

    Well that definitely did something (the letters turned red . . . ooooo!); thanks for your help. Unfortunately I must have something previous wrong because it says:

    Module ath_pci not found.

    There are many files called ath_pci in one of the subdirectories I'm doing this from (I tried switching to the directory containing them and still no good) - could you possibly tell me what file extensions modprobe should work on?

    After that I'll search through the wiki/forums for more specific info before I bother anyone further.

    Thanks again!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts