Results 1 to 9 of 9

Thread: re-enable windows on grub

  1. #1

    Default re-enable windows on grub

    hello everyone,
    ive installed opensuse 11 a couple of days ago, dual boot with my windows xp. then my hardisk start disk annoying sounds then i decided to reboot. my pc won't boot so i decided to repair the boot loader. so i repaired my boot loader with 2 options: * opensuse 11 * failsafe opensuse 11. how do i include again my windows on the boot options?? opensuse boot differently now (text mode)
    I want to dual boot again with my win xp and opensuse(graphical mode)
    my xp partition is on a 40 IDE HD
    my opensuse 11 is on a 160 SATA HD

    please help me,
    thanks in advance

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: re-enable windows on grub

    go to : /boot/grub
    see if there is a menu.lst.old
    open it, there may be an entry there for windows

    copy it
    add to your menu.lst

    need to be su
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: re-enable windows on grub

    thanks for replying
    but i think there was no winxp on the menu.lst.old
    heres my file
    Code:
     
    # Modified by YaST2. Last modification on Sun Jul 13 20:13:15 PHT 2008
    default 0
    timeout 8
    gfxmenu (hd1,5)/boot/message
    
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.0
        root (hd1,5)
        kernel /boot/vmlinuz root=/dev/disk/by-id/scsi-SATA_ST3160215AS_6RA617GY-part6    splash=silent showopts
        initrd /boot/initrd
    
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.0
        root (hd1,5)
        kernel /boot/vmlinuz root=/dev/disk/by-id/scsi-SATA_ST3160215AS_6RA617GY-part6 showopts ide=nodma apm=off acpi=off noresume edd=off  x11failsafe
        initrd /boot/initrd

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: re-enable windows on grub

    You should have installed grub to your suse HD MBR not to your windows HD MBR

    Read my guide here: Partitioning/Install Guide - openSUSE Forums

    but you could try using my entry for menu.lst for windows
    you may need to edit it a bit
    keep a copy of your original menu.lst

    try adding this to your menu.lst:

    title WIN XP
    map (hd0) (hd1)
    map (hd1) (hd0)
    rootnoverify (hd1,0)
    chainloader +1
    Last edited by caf4926; 13-Jul-2008 at 00:11. Reason: typo
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: re-enable windows on grub

    i copied the menu.lst that you gave.
    when I select windows, there was an error saying no NTDLR

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: re-enable windows on grub

    ntdlr is a windows file needed to boot windows,

    try here:
    Ntldr Not Found - openSUSE Forums

    or
    "kernel Panic" When Booting... - openSUSE Forums

    If you can't get going from here I suggest restoring your xp MBR with your xp disc
    and installing grub for suse on your suse drive's MBR
    use the help page I gave you earlier
    you need to change the boot priority in your bios to have the suse HD booting first to run the grub loader
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: re-enable windows on grub

    Can you post back here the output from this console command:
    Code:
    sudo /sbin/fdisk -l
    that's letter l.
    And also say which of the lines in the fdisk output corresponds to the windows c drive.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  8. #8

    Default Re: re-enable windows on grub

    Code:
    Disk /dev/sda: 160.0 GB, 160041885696 bytes
    255 heads, 63 sectors/track, 19457 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x5b1c0063
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1               1        6375    51199816+   7  HPFS/NTFS
    Partition 1 does not end on cylinder boundary.
    /dev/sda2            6375       12749    51199848    7  HPFS/NTFS
    Partition 2 does not end on cylinder boundary.
    /dev/sda3   *       12750       19457    53882010    f  W95 Ext'd (LBA)
    /dev/sda5           12750       13011     2104483+  82  Linux swap / Solaris
    /dev/sda6           13012       15559    20466778+  83  Linux
    /dev/sda7           15560       19457    31310653+  83  Linux
    
    Disk /dev/sdb: 40.0 GB, 40020664320 bytes
    255 heads, 63 sectors/track, 4865 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x94619461
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1   *           1        4864    39070048+   7  HPFS/NTFS
    i tried restoring mbr of windows, but i cant use linux

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: re-enable windows on grub

    if you restored the mbr for windows and windows now boots

    you need to boot from the suse install dvd to restore the grub,
    make sure you aim it at the mbr
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •