Results 1 to 3 of 3

Thread: Secuirty Update Error

  1. #1
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Secuirty Update Error

    NOTE: I posted this in the wrong area.

    Would a moderator be able to move this to the appropriate forum. Thank you!


    Hey all,

    I haven't been on my OpenSUSE 11.0 machine for about a week and a half due to traveling, and when I got back and logged in, there were security updates available. I went to update and got the dependency errors found below in quotes after I clicked the install button. The problem is that I looked for these files in YaST and around the internet, and have yet to find these packages. My question is: is there any pattern of packages or specific packages I should install; and, where can I find the packages required in the error from PackageKit below?

    Thank you.


    Quote Originally Posted by [B]PackageKit Error[/B]
    nothing provides yast2 >= 2.17.7 needed by yast2-installation-2.17.0-2.noarch
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    zvbi-0.2.30-2.i586 requires libzvbi.so.0, but this requirement cannot be provided
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    libtunepimp5-mp4-0.5.3-100.pm.9.i586 requires libtunepimp5 = 0.5.3-100.pm.9, but this requirement cannot be provided
    zypper-0.11.9-0.1.i586 requires libzypp.so.424, but this requirement cannot be provided
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    nothing provides phonon-backend >= 4.1.83 needed by phonon-4.1.83-8.i586
    Last edited by Unseen-Ghost; 12-Jul-2008 at 12:59. Reason: Wrong area

    Folding@Home
    Help save lives with Folding@Home

  2. #2
    Join Date
    Jun 2008
    Location
    Cleveland USA
    Posts
    138

    Default Re: Secuirty Update Error

    Yast2, phonon-backend, zypper, libtunepimp, zvbi are all packages that can be found in the default opensuse repository. I'm not sure what keywords you were using in yast and on the interwebs, but if you search for the ones I just listed, you can find them.

    If for some reason, you don't have the opensuse default repository available in yast software manager, you may want to check your repository manager (if you have yast software open, look under repositories menu) to see if it's been disabled. You can add it from the repo manager - it should be listed under the community repositories.
    Unintentionally left blank...

  3. #3
    Join Date
    Jun 2008
    Location
    United States
    Posts
    423

    Default Re: Secuirty Update Error

    Okay, I think I fixed the problem.

    I went to the package manager and installed the library package for Zypper. The problem was that the package had a lot of dependencies and conflicting errors: meaning that one package needed the other, and the other package needed the first package. So I just ignored the dependencies and it installed fine. After that, I was able to install the Zypper package without any problems, and now my system updated fines as well.

    Thank you for your help: it is very much appreciated!

    EDIT: Now I can't start YaST Package Manager.

    I ran it in the terminal and got the error:

    Code:
    Error while creating client module sw_single
    Last edited by swerdna; 12-Jul-2008 at 18:26. Reason: edit: at request of Unseen-Ghost

    Folding@Home
    Help save lives with Folding@Home

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •