Soon after 10.3 came out, I installed it to a new partition. At the time I was bothered with the fuzzy fonts and, after reading the forum and web posts, finally figured out how to get laser-sharp screen fonts. Just like on paper from a postscript printer! The final (say) 30% improvement was by chance, it happens, and it is that which I wouldlike to share with you.

A few weeks ago I upgraded to a new MB (M2NPV-VM > M2N-SLI) and decided that the 10.3 installation (which I use day-in and day-out was getting a little fragile. So I created a new partition and installed 10.3 again from scratch to it, intending to have a "fresh, new" 10.3. I thought I did all the steps originally taken to get hinting and sub-pixel working the same as my original 10.3 but, try as I did, I could not get the laser-sharp fonts again. Close, but still a bit fuzzy ... although I suspect a lot of openSuse users would kill to get what I considered "close, but still fuzzy". So I looked at what I had done:

1. Used the precompiled Freetype2 rpm from Download file which has the goodies in it. You may find it elsewhere. Just remember to tell Yast that it is now a protected file ... don't update it!

2. The KDE "enable hinting and sub-pixel" procedure, from a non-root account, described at opensuse-community.org. Look for the FAQ section.

3. The "Gnome-Control-Center" installation and font configuration routine described at both openSuse.org and -community wikis. Note, it doesn't seem necessary to follow the creation of the symbolic link to ~.kde as described in one of them at the bottom of the page.

After all this, I still couldn't get the new "standby" version's 10.3 fonts to look like those in the original install. I compared the xorg.conf files, the .fonts.conf files, everything. I even deleted the Nvidia 173.14.09 drivers and command-line installed the 169.12_2.6.22..... version I had in the original install. Only a few places on the web still have these. No laser sharpness, but perhaps a bit better. My firefox 2 setting were exactly the same (I went with the default font settings), ditto Kwrite, Konquerer file manager, but something was still (visibly and annoyingly) different.

My last comparison, after installing the Nvidia drivers, was to check the settings in the Nvidia control panel. The only thing I found different was the entries under my monitor (DFP-O-Samsung Syncmaster) near the bottom of the left hand column. The entry "Force Full GPU Scaling" was checked in the new install, but unchecked in the old install.

As soon as I unchecked that box in my new install, the screen went blank/black and, after a few seconds, POOF and the screen was back and all fonts were laser sharp! Desktop, Firefox, Applications, Yast, the whole nine yards. The final 30% to laser-sharpness. And that's the end of the story.

Your mileage may vary, of course, but if you have 10.3/KDE/LCD and a Nvidia card, you may want to spend a few moments to see if you can get laser-sharp screen fonts too. And I don't know if all the things I did above, including version, are necessary ... but I ain't changing a thing, as they say. It may even have applicability and help in 11.0, I don't know.

My Configuration: Asus M2N-SLI, Samsung Syncmaster 213T @1024x768x16, Nvidia 8600GT-25M.
(Legibility was excellent when connected originally to onboard NV6150 VGA adapter of M2NPV-VM,
but really went up a notch when the DVI (or is it HDMI) port was used on 8600GT.)

Some Settings:
Firefox2 - autohinting: false (default)
enable: false (default)
printing: true (default)
unhinted: true (default)
layout.css.dpi: -1 (default)
Default Font in Preferences: blank (default), 15, 12, none (out of the box settings)
and "let sites use their own fonts" is checked.

KDE Font Preferences: force to 96 dpi (Monitor dpi query returns value of 60)
Use Anti-Aliasing: enabled
Exclude Range: not selected
Use Sub-Pixel: RGB
Hinting Style: Medium
All Fonts: 9pt Arial, except Monospace 9

Gnome-Control-Center: Used those setting recommended by openSuse-community.org FAQ, adjusted only for font-size.