Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: no suspend/sleep now

  1. #1

    Default no suspend/sleep now

    I was really impressed with osuse 11 because when I played with the livecd and then installed most everything I wanted worked.
    I can't say for certain that it was the last kernel upgrade, I'm using x86_64 btw, but now suspend or sleep doesn't work and I know it did.
    I can choose sleep from the shutdown menu but besides putting up a panel to log back in by it doesn't actually suspend.

    The other day I had closed the lid on this HP Pavilion dv6707us (specs here) and put it in it's bag when I got home I realized it was still running and very warm too!
    I have closed the lid previous to this last update and I know it had suspended and resumed ok then.

    I have a ubuntu install on this laptop. In ubuntu it will actually suspend but getting it to successfully resume has been a toss of the dice. I don't know how to troubleshoot this in suse or if there is anything I can do?

  2. #2
    Join Date
    Jan 2008
    Location
    Kenton, TN USA
    Posts
    1,023

    Default Re: no suspend/sleep now

    Thread moved to Laptop
    Keith Kastorff

  3. #3
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: no suspend/sleep now

    It could be you have to set an extra s2ram option to get the laptop to suspend.
    I'm guessing you are using openSUSE 11.0? Have a look here for more info on suspending in openSUSE : Pm-utils - openSUSE

    See point 6 ' Triggering suspend manually ' in particular for steps to take...

    Hope that helps,
    Wj
    Have a lot of fun!

  4. #4

    Default Re: no suspend/sleep now

    Thanks for the response Magic31. I did go through some of the info from that link. Unfortunately calling pm-suspend as root doesn't do anything and s2ram -n outputs unknown machine. So I must have been wrong about it suspending before-the front lights acted like the laptop was in suspend the hard drive and fan stopped but I was delusional. Sorry it's frustrating but it's the nature of the beast. Thanks for your help.

  5. #5
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: no suspend/sleep now

    Can understand that.. hang in there as there are other options

    Have you tried running 's2ram -f -a 3' as root?

    Just to give the steps, open a terminal console, enter ' su - ' and root's pw. Now see if 's2ram -f -a 3' will bring the laptop into a full suspend.

    There are other combinations you can try found here : Suspend to RAM - openSUSE

    If one of those options work you can create a file 'config' in /etc/pm/config.d, edit it and add ' S2RAM_OPTS="-f -a 3" ' (or other working switch you have found) as line to the file.
    It will then apply that switch when suspending...

    Hope that helps,
    Wj
    Have a lot of fun!

  6. #6

    Default Re: no suspend/sleep now

    I appreciate your knowledge in this area.
    s2ram -f -a 3 as root does indeed put the laptop into full suspend.
    I created that file, as root, and edited with vim adding that line.

    #created file & entry 7-11-08 with advice from opensuse forum
    S2RAM_OPTS= "-f-a 3"
    Spacing between symbols is sometimes a little confusing so I tried that line with and without a space after the "=" sign but closing the lid or selecting sleep does not activate suspend with either edit.

  7. #7

    Default Re: no suspend/sleep now

    I just retried that and suspend does not work from selecting suspend or closing the lid. All that happens from those is the panel pops up requiring a password to get back to the desktop. The s2ram -f -a 3 command does work though and that's something.

  8. #8
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: no suspend/sleep now

    Good to hear it works using the option.

    It looks like you are missing a space in the config file?

    S2RAM_OPTS= "-f-a 3" should be S2RAM_OPTS= "-f -a 3"

    Other than that what you did should work.

    ps. Also double check your power settings are set to suspend when the lid closes.
    Have a lot of fun!

  9. #9

    Default Re: no suspend/sleep now

    Power settings were the 1st thing I checked they're ok.
    The spacing was the problem closing the lid does suspend the laptop now.
    Thank for the help on this!
    I do have unfortunately another problem now. When I open the lid I get this:
    PackageKit Error:
    An internal system error has occurred
    A problem we were not expecting has occurred.
    Please report this bug with the error description.
    openSUSE-11.0-Oss: Valid metadata not found at specified URL(s)
    And my network connection (I'm using madwifi) is no longer working. I can't bring it back up without rebooting. I think there's another file I have to add that module to? In debian it's /etc/default/acpi-? I forget the exact filename but that doesn't exsist in opensuse.

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: no suspend/sleep now

    Hi rad1er

    Sounds like you're nearly there with your suspend issues. Regarding the 'PackageKit' error, you could try using the Zypper backend instead. From the opensuseupdater icon, you can select 'Configure Applet' to change this setting.

    It is well known that some hardware can cause problems with power management. The solution to your madwifi wireless networking issue is explained here. You just need to add the script to your /etc/pm/power.d directory.

    Hopefully, that will do the trick for you.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •