Results 1 to 6 of 6

Thread: [Solved] Nvidia driver issue

  1. #1
    dada1958 NNTP User

    Default [Solved] Nvidia driver issue

    I'm playing with openSUSE 11 KDE 4.1 beta 2, with latest kernel now, for a week or so and I like this distro very much; it does the job better than Kubuntu 8.04 imho ...
    YaST2 is a great package manager. Unfortunately I'm not able to install the x11-video-nvidiaG01 - nvidia GL drivers and kernel modules properly until now. I tried the one-click, zypper and YaST2 installs without any success. My GeForce 6200 (AGP) card doesn't work, X-server isn't detected. Sax2 aborts the job and I'm stuck in the terminal and the only way out is to uninstall the G01 stuff with YaST2 in console modus.
    Is this a temporarily issue? I read about more people having trouble ...
    Any clues I didn't see yet?
    TIA

  2. #2
    Join Date
    Jun 2008
    Location
    Glasgow Area, UK
    Posts
    35

    Default Re: Nvidia driver issue

    Hi
    Try installing the drivers manually, follow the advice in this post by james.
    1. Make sure you have all the right build tools, to allow you to build a Kernel module. (Open Yast's Software management, choose the patterns option and select Base Development, C/C++, and Kernel Development options).

    2. Download the latest NVIDIA Driver (NVIDIA-Linux-x86-173.14.05-pkg1.run) is the latest at the time of writing.

    Code:

    wget http://us.download.nvidia.com/XFree8...14.05-pkg1.run

    3. Press Ctrl + Alt + F3 to switch to terminal running on run-level 3.

    4. Login as root.

    5. Stop any X servers
    Code:

    init 3

    6. At this point, press enter if there is no login prompt. Login once again as root.

    7. Now run the NVIDIA installer.
    Code:

    sh NVIDIA-Linux-x86-173.14.05-pkg1.run

    8. Follow the instructions, and everything should build

    9. Reboot, and see if you can enable desktop effects in Yast. If not, then as root check the /etc/X11/xorg.conf

    Under devices make sure it looks something like:
    Code:

    Section "Device"
    BoardName "GeForce 7600 GT"
    BusID "1:0:0"
    Driver "nvidia"
    Identifier "Device[0]"
    VendorName "NVidia"
    EndSection

    Note it's the driver part that is important, if yours says NV or nv, change it to nvidia. Everything else will be similar, albeit specific to your board.

    Hope I've got everything there, any problems compiling let me know. Before this driver was out, I had to patch the old driver's code for the 2.6.25.4 kernel.

    Oh one last thing, you can either re-boot to get graphics running or type:

    Code:

    init 5

    or
    Code:

    startx

    at this point, startx will login to KDE as root user.

    Hope this helps
    sol

  3. #3
    dada1958 NNTP User

    Default Re: Nvidia driver issue

    Ok, I installed the 64-bit driver, desktop effect aren't enabled, though xorg.config looks good
    Code:
    Section "Device"
      BoardName    "GeForce 6200 (0x0221)"
      Driver       "nvidia"
      Identifier   "Device[0]"
      Screen       0
      VendorName   "NVidia"
    But this part puzzles me
    Section "Extensions"
    Code:
    Option       "Composite" "off"
    I'll try that one with "on"
    Tnx for the input so far!

  4. #4
    dada1958 NNTP User

    Default Re: Nvidia driver issue

    How can I mark this thread as solved?

  5. #5
    Join Date
    Jan 2008
    Location
    Kenton, TN USA
    Posts
    1,023

    Default Re: Nvidia driver issue

    Thread moved to Pre-Release/Beta
    Last edited by kastorff; 11-Jul-2008 at 08:29.
    Keith Kastorff

  6. #6
    Join Date
    Jan 2008
    Location
    Kenton, TN USA
    Posts
    1,023

    Default Re: Nvidia driver issue

    Quote Originally Posted by dada1958 View Post
    How can I mark this thread as solved?
    Just the way you did works fine.
    Keith Kastorff

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •