Results 1 to 5 of 5

Thread: Yast can't connect to any repository

  1. #1

    Default Yast can't connect to any repository

    Hi everyone,
    i have installed opensuse 10.3 + gnome, but i can't add repositories. Yast can't connect to any repository (for example download.opensuse.org/distribution/10.3/repo/oss/), but this URL is accessible via firefox. During addition of a new repository i receive error.
    Curl error for download.opensuse.org/distribution/10.3/repo/oss/
    Error code:
    Error message: connect() timed out!

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Taiwan
    Posts
    150

    Default Re: Yast can't connect to any repository

    Can you add repo by zypper?
    zypper ar Index of /distribution/10.3/repo/oss oss
    Regards,
    Bryan Yu
    http://lifestory.moqin.com/

  3. #3
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Yast can't connect to any repository

    Hi & welcome...

    I've seen a couple of reports like this. Turned out the proxy was not set or needed to be unset in YaST > Proxy.

    Same for you?

    Cheers,
    Wj
    Have a lot of fun!

  4. #4

    Default Re: Yast can't connect to any repository

    Yes, this is for me. Thank you.

  5. #5
    csbowers NNTP User

    Default Re: Yast can't connect to any repository

    I've been having the same problem with version 10.x and now 11. I have my proxy settings configured correctly in Yast but when I test it I get back:
    Proxy return code: HTTP/1.1 407 Proxy Authentication Required. I have proper credentials configured but it doesn't seem to pass them to the proxy server. Because of this, updating fails. However, Firefox will connect through my proxy server without any problems using the same credentials.

    Any help would be great!

    Chris

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •