Results 1 to 8 of 8

Thread: command line ftp doesn't work

  1. #1

    Default command line ftp doesn't work

    Hi

    I don't know if this is a server or client question yet!

    I've a server with vsftpd. I use it with leechftp, filezilla, dreamweaver, vith some small problems but more or less it works.
    Yesterday I tried to connect with the command line fto on another linux server. The connection was ok but no command (ls,send,put,...) worked!
    I tried also to force active mode and to change client to ncftp but nothing changed....
    Please help!

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: command line ftp doesn't work

    Use a client program like curl, which is designed to do things from the CLI.

  3. #3
    ab@novell.com NNTP User

    Default Re: command line ftp doesn't work

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    With active mode I need to make sure the port on the client is open on
    my firewall. As a simple test, stop your firewall and then try active
    mode again with `ftp -A <ipAddress>`. If that works that explains that
    side of things.

    Passive mode requires a smarter or more-lenient firewall on the FTP
    server side. Try stopping that box's firewall and see if passive works.

    Good luck.






    ken yap wrote:
    | Use a client program like curl, which is designed to do things from the
    | CLI.
    |
    |
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFIdxaQ3s42bA80+9kRAtbjAJ96gz/Gk9u8yIpY2qyHzrxaxO+8HgCcDnNa
    JqgMcllDMqFecsRSoYZu2Ao=
    =nzhS
    -----END PGP SIGNATURE-----

  4. #4

    Default Re: command line ftp doesn't work

    o way. I can't make this ********** ftp work!!

    Some more info
    This is the configuration of the FTP server:
    Code:
    # Example config file /etc/vsftpd.conf
    #
    # The default compiled in settings are fairly paranoid. This sample file
    # loosens things up a bit, to make the ftp daemon more usable.
    # Please see vsftpd.conf.5 for all compiled in defaults.
    #
    # If you do not change anything here you will have a minimum setup for an
    # anonymus FTP server.
    #
    # READ THIS: This example file is NOT an exhaustive list of vsftpd options.
    # Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
    # capabilities.
    
    # General Settings
    #
    # Uncomment this to enable any form of FTP write command.
    #
    write_enable=YES
    #
    # Activate directory messages - messages given to remote users when they
    # go into a certain directory.
    #
    dirmessage_enable=YES
    #
    # It is recommended that you define on your system a unique user which the
    # ftp server can use as a totally isolated and unprivileged user.
    #
    #nopriv_user=ftpsecure
    #
    # You may fully customise the login banner string:
    #
    ftpd_banner="FTP Service"
    #
    # You may activate the "-R" option to the builtin ls. This is disabled by
    # default to avoid remote users being able to cause excessive I/O on large
    # sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
    # the presence of the "-R" option, so there is a strong case for enabling it.
    #
    #ls_recurse_enable=YES
    #
    # You may specify a file of disallowed anonymous e-mail addresses. Apparently
    # useful for combatting certain DoS attacks.
    #
    #deny_email_enable=YES
    #
    # (default follows)
    #
    #banned_email_file=/etc/vsftpd.banned_emails
    #
    # If  enabled,  all  user  and  group  information in
    # directory listings will be displayed as "ftp".
    #
    #hide_ids=YES
    
    # Local FTP user Settings
    # 
    # Uncomment this to allow local users to log in.
    #
    local_enable=YES
    #
    # Default umask for local users is 077. You may wish to change this to 022,
    # if your users expect that (022 is used by most other ftpd's)
    #
    local_umask=022
    #
    # Uncomment to put local users in a chroot() jail in their home directory
    # after login.
    #
    chroot_local_user=YES
    #
    # You may specify an explicit list of local users to chroot() to their home
    # directory. If chroot_local_user is YES, then this list becomes a list of
    # users to NOT chroot().
    #
    #chroot_list_enable=YES
    #
    # (default follows)
    #
    #chroot_list_file=/etc/vsftpd.chroot_list
    #
    # The maximum data transfer rate permitted, in bytes per second, for
    # local authenticated users. The default is 0 (unlimited).
    #
    #local_max_rate=7200
    
    
    # Anonymus FTP user Settings
    #
    # Allow anonymous FTP?
    #
    #anonymous_enable=YES
    #
    # Anonymous users will only be allowed to download files which are
    # world readable.
    #
    #anon_world_readable_only=YES
    #
    # Uncomment this to allow the anonymous FTP user to upload files. This only
    # has an effect if the above global write enable is activated. Also, you will
    # obviously need to create a directory writable by the FTP user.
    #
    #anon_upload_enable=YES
    #
    # Default umask for anonymus users is 077. You may wish to change this to 022,
    # if your users expect that (022 is used by most other ftpd's)
    #
    #anon_umask=022
    #
    # Uncomment this if you want the anonymous FTP user to be able to create
    # new directories.
    #
    #anon_mkdir_write_enable=YES
    #
    # Uncomment this to enable anonymus FTP users to perform other write operations
    # like deletion and renaming.
    #
    #anon_other_write_enable=YES
    #
    # If you want, you can arrange for uploaded anonymous files to be owned by
    # a different user. Note! Using "root" for uploaded files is not
    # recommended!
    #
    #chown_uploads=YES
    #chown_username=whoever
    #
    # The maximum data transfer rate permitted, in bytes per second, for anonymous
    # authenticated users. The default is 0 (unlimited).
    #
    #anon_max_rate=7200
    
    
    # Log Settings
    #
    # Log to the syslog daemon instead of using an logfile.
    #
    syslog_enable=YES
    #
    # Uncomment this to log all FTP requests and responses.
    #
    #log_ftp_protocol=YES
    #
    # Activate logging of uploads/downloads.
    #
    #xferlog_enable=YES
    #
    # You may override where the log file goes if you like. The default is shown
    # below.
    #
    #vsftpd_log_file=/var/log/vsftpd.log
    # 
    # If you want, you can have your log file in standard ftpd xferlog format.
    # Note: This disables the normal logging unless you enable dual_log_enable below. 
    #
    #xferlog_std_format=YES
    #
    # You may override where the log file goes if you like. The default is shown
    # below.
    #
    #xferlog_file=/var/log/xferlog
    #
    # Enable this to have booth logfiles. Standard xferlog and vsftpd's own style log.
    #
    #dual_log_enable=YES
    #
    # Uncomment this to enable session status information in the system process listing.
    #
    #setproctitle_enable=YES
    
    # Transfer Settings
    #
    # Make sure PORT transfer connections originate from port 20 (ftp-data).
    #
    connect_from_port_20=YES
    #
    # You may change the default value for timing out an idle session.
    #
    #idle_session_timeout=600
    #
    # You may change the default value for timing out a data connection.
    #
    #data_connection_timeout=120
    #
    # Enable this and the server will recognise asynchronous ABOR requests. Not
    # recommended for security (the code is non-trivial). Not enabling it,
    # however, may confuse older FTP clients.
    #
    #async_abor_enable=YES
    #
    # By default the server will pretend to allow ASCII mode but in fact ignore
    # the request. Turn on the below options to have the server actually do ASCII
    # mangling on files when in ASCII mode.
    # Beware that turning on ascii_download_enable enables malicious remote parties
    # to consume your I/O resources, by issuing the command "SIZE /big/file" in
    # ASCII mode.
    # These ASCII options are split into upload and download because you may wish
    # to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
    # without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
    # on the client anyway..
    #
    #ascii_upload_enable=YES
    #ascii_download_enable=YES
    #
    # Set to NO if you want to disallow the  PASV  method of obtaining a data
    # connection.
    #
    pasv_enable=NO
    
    # PAM setting. Do NOT change this unless you know what you do!
    #
    pam_service_name=vsftpd
    
    # Set listen=YES if you want vsftpd to run standalone
    #
    #listen=YES
    
    # Set to ssl_enable=YES if you want to enable SSL
    ssl_enable=NO
    From my Mac Dreamweaver ftp clients works, and CyberDuck works only if ftp mode is set to ACTIVE, otherwise it connects and waits until the end of the world....

    From the other server I've tried with "ftp","ncftp" and "wput", and it connects and wait....

    With curl I've tried:
    curl -T <filename> ftp://<user>:<password>@<ftp ip server>/
    but the response is:
    curl: (13) Bad PASV/EPSV response: 550

    I've also tried to force active mode :
    curl --ftp-port - --disable-eprt -T <filename> ftp://<user>:<password>@<ftp ip server>/
    but waits till the end of the world....

    Please help!!!

  5. #5
    ab@novell.com NNTP User

    Default Re: command line ftp doesn't work

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    As mentioned active mode won't work if your client machine has a
    firewall that doesn't know how to account for this type of connection.
    Passive won't work if the server doesn't do the same. While you didn't
    say explicitly I'm assuming you disabled the server firewall for at
    least one of these tests, right?

    Your DreamWeaver is presumably on windows which has a different kind of
    firewall, if any firewall at all. Your "other server" is presumably
    Linux based on the commands you are using. I think this should still
    work. Worst-case scenario, get a LAN trace from both machines when
    trying your connection to see where packets are lost.

    Good luck.






    Alexart74 wrote:
    | o way. I can't make this ********** ftp work!!
    |
    | Some more info
    | This is the configuration of the FTP server:
    |
    | Code:
    | --------------------
    |
    | # Example config file /etc/vsftpd.conf
    | #
    | # The default compiled in settings are fairly paranoid. This sample file
    | # loosens things up a bit, to make the ftp daemon more usable.
    | # Please see vsftpd.conf.5 for all compiled in defaults.
    | #
    | # If you do not change anything here you will have a minimum setup
    for an
    | # anonymus FTP server.
    | #
    | # READ THIS: This example file is NOT an exhaustive list of vsftpd
    options.
    | # Please read the vsftpd.conf.5 manual page to get a full idea of
    vsftpd's
    | # capabilities.
    |
    | # General Settings
    | #
    | # Uncomment this to enable any form of FTP write command.
    | #
    | write_enable=YES
    | #
    | # Activate directory messages - messages given to remote users when they
    | # go into a certain directory.
    | #
    | dirmessage_enable=YES
    | #
    | # It is recommended that you define on your system a unique user
    which the
    | # ftp server can use as a totally isolated and unprivileged user.
    | #
    | #nopriv_user=ftpsecure
    | #
    | # You may fully customise the login banner string:
    | #
    | ftpd_banner="FTP Service"
    | #
    | # You may activate the "-R" option to the builtin ls. This is
    disabled by
    | # default to avoid remote users being able to cause excessive I/O on
    large
    | # sites. However, some broken FTP clients such as "ncftp" and
    "mirror" assume
    | # the presence of the "-R" option, so there is a strong case for
    enabling it.
    | #
    | #ls_recurse_enable=YES
    | #
    | # You may specify a file of disallowed anonymous e-mail addresses.
    Apparently
    | # useful for combatting certain DoS attacks.
    | #
    | #deny_email_enable=YES
    | #
    | # (default follows)
    | #
    | #banned_email_file=/etc/vsftpd.banned_emails
    | #
    | # If enabled, all user and group information in
    | # directory listings will be displayed as "ftp".
    | #
    | #hide_ids=YES
    |
    | # Local FTP user Settings
    | #
    | # Uncomment this to allow local users to log in.
    | #
    | local_enable=YES
    | #
    | # Default umask for local users is 077. You may wish to change this
    to 022,
    | # if your users expect that (022 is used by most other ftpd's)
    | #
    | local_umask=022
    | #
    | # Uncomment to put local users in a chroot() jail in their home
    directory
    | # after login.
    | #
    | chroot_local_user=YES
    | #
    | # You may specify an explicit list of local users to chroot() to
    their home
    | # directory. If chroot_local_user is YES, then this list becomes a
    list of
    | # users to NOT chroot().
    | #
    | #chroot_list_enable=YES
    | #
    | # (default follows)
    | #
    | #chroot_list_file=/etc/vsftpd.chroot_list
    | #
    | # The maximum data transfer rate permitted, in bytes per second, for
    | # local authenticated users. The default is 0 (unlimited).
    | #
    | #local_max_rate=7200
    |
    |
    | # Anonymus FTP user Settings
    | #
    | # Allow anonymous FTP?
    | #
    | #anonymous_enable=YES
    | #
    | # Anonymous users will only be allowed to download files which are
    | # world readable.
    | #
    | #anon_world_readable_only=YES
    | #
    | # Uncomment this to allow the anonymous FTP user to upload files.
    This only
    | # has an effect if the above global write enable is activated. Also,
    you will
    | # obviously need to create a directory writable by the FTP user.
    | #
    | #anon_upload_enable=YES
    | #
    | # Default umask for anonymus users is 077. You may wish to change
    this to 022,
    | # if your users expect that (022 is used by most other ftpd's)
    | #
    | #anon_umask=022
    | #
    | # Uncomment this if you want the anonymous FTP user to be able to create
    | # new directories.
    | #
    | #anon_mkdir_write_enable=YES
    | #
    | # Uncomment this to enable anonymus FTP users to perform other write
    operations
    | # like deletion and renaming.
    | #
    | #anon_other_write_enable=YES
    | #
    | # If you want, you can arrange for uploaded anonymous files to be
    owned by
    | # a different user. Note! Using "root" for uploaded files is not
    | # recommended!
    | #
    | #chown_uploads=YES
    | #chown_username=whoever
    | #
    | # The maximum data transfer rate permitted, in bytes per second, for
    anonymous
    | # authenticated users. The default is 0 (unlimited).
    | #
    | #anon_max_rate=7200
    |
    |
    | # Log Settings
    | #
    | # Log to the syslog daemon instead of using an logfile.
    | #
    | syslog_enable=YES
    | #
    | # Uncomment this to log all FTP requests and responses.
    | #
    | #log_ftp_protocol=YES
    | #
    | # Activate logging of uploads/downloads.
    | #
    | #xferlog_enable=YES
    | #
    | # You may override where the log file goes if you like. The default
    is shown
    | # below.
    | #
    | #vsftpd_log_file=/var/log/vsftpd.log
    | #
    | # If you want, you can have your log file in standard ftpd xferlog
    format.
    | # Note: This disables the normal logging unless you enable
    dual_log_enable below.
    | #
    | #xferlog_std_format=YES
    | #
    | # You may override where the log file goes if you like. The default
    is shown
    | # below.
    | #
    | #xferlog_file=/var/log/xferlog
    | #
    | # Enable this to have booth logfiles. Standard xferlog and vsftpd's
    own style log.
    | #
    | #dual_log_enable=YES
    | #
    | # Uncomment this to enable session status information in the system
    process listing.
    | #
    | #setproctitle_enable=YES
    |
    | # Transfer Settings
    | #
    | # Make sure PORT transfer connections originate from port 20 (ftp-data).
    | #
    | connect_from_port_20=YES
    | #
    | # You may change the default value for timing out an idle session.
    | #
    | #idle_session_timeout=600
    | #
    | # You may change the default value for timing out a data connection.
    | #
    | #data_connection_timeout=120
    | #
    | # Enable this and the server will recognise asynchronous ABOR
    requests. Not
    | # recommended for security (the code is non-trivial). Not enabling it,
    | # however, may confuse older FTP clients.
    | #
    | #async_abor_enable=YES
    | #
    | # By default the server will pretend to allow ASCII mode but in fact
    ignore
    | # the request. Turn on the below options to have the server actually
    do ASCII
    | # mangling on files when in ASCII mode.
    | # Beware that turning on ascii_download_enable enables malicious
    remote parties
    | # to consume your I/O resources, by issuing the command "SIZE
    /big/file" in
    | # ASCII mode.
    | # These ASCII options are split into upload and download because you
    may wish
    | # to enable ASCII uploads (to prevent uploaded scripts etc. from
    breaking),
    | # without the DoS risk of SIZE and ASCII downloads. ASCII mangling
    should be
    | # on the client anyway..
    | #
    | #ascii_upload_enable=YES
    | #ascii_download_enable=YES
    | #
    | # Set to NO if you want to disallow the PASV method of obtaining a
    data
    | # connection.
    | #
    | pasv_enable=NO
    |
    | # PAM setting. Do NOT change this unless you know what you do!
    | #
    | pam_service_name=vsftpd
    |
    | # Set listen=YES if you want vsftpd to run standalone
    | #
    | #listen=YES
    |
    | # Set to ssl_enable=YES if you want to enable SSL
    | ssl_enable=NO
    |
    |
    | --------------------
    |
    |
    | From my Mac Dreamweaver ftp clients works, and CyberDuck works only if
    | ftp mode is set to ACTIVE, otherwise it connects and waits until the
    | end of the world....
    |
    | From the other server I've tried with "ftp","ncftp" and "wput", and it
    | connects and wait....
    |
    | With curl I've tried:
    | curl -T <filename> ftp://<user>:<password>@<ftp ip server>/
    | but the response is:
    | curl: (13) Bad PASV/EPSV response: 550
    |
    | I've also tried to force active mode :
    | curl --ftp-port - --disable-eprt -T <filename>
    | ftp://<user>:<password>@<ftp ip server>/
    | but waits till the end of the world....
    |
    | Please help!!!
    |
    |
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFId5Tn3s42bA80+9kRAgJsAJ9Uuf90UjD3sSl3WbPOsmKYQbC35wCeIgW4
    Lev7cuTJUtdUUm67FGa5Ypc=
    =KyxE
    -----END PGP SIGNATURE-----

  6. #6

    Default Re: command line ftp doesn't work

    Quote Originally Posted by ab@novell.com View Post
    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    As mentioned active mode won't work if your client machine has a
    firewall that doesn't know how to account for this type of connection.
    Passive won't work if the server doesn't do the same. While you didn't
    say explicitly I'm assuming you disabled the server firewall for at
    least one of these tests, right?

    Your DreamWeaver is presumably on windows which has a different kind of
    firewall, if any firewall at all. Your "other server" is presumably
    Linux based on the commands you are using. I think this should still
    work. Worst-case scenario, get a LAN trace from both machines when
    trying your connection to see where packets are lost.

    Good luck.
    It works!! You were right!
    I tried many times switching the server firewall off, but I've never tried with the client! I didn't thought the firewall could stop traffic from outside but in response to requests originated from inside!
    Now I've granted full access from server to client and the active mode works. The passive mode doesn't, but I don't care.
    Thanks a lot to everyone!!

  7. #7
    ab@novell.com NNTP User

    Default Re: command line ftp doesn't work

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Whew.... It was my insanity or yours... I'm glad today I got lucky. ;-)

    Thanks for posting back the result.

    Good luck.





    Alexart74 wrote:
    | ab@novell.com;1837419 Wrote:
    |> -----BEGIN PGP SIGNED MESSAGE-----
    |> Hash: SHA1
    |>
    |> As mentioned active mode won't work if your client machine has a
    |> firewall that doesn't know how to account for this type of connection.
    |> Passive won't work if the server doesn't do the same. While you
    |> didn't
    |> say explicitly I'm assuming you disabled the server firewall for at
    |> least one of these tests, right?
    |>
    |> Your DreamWeaver is presumably on windows which has a different kind
    |> of
    |> firewall, if any firewall at all. Your "other server" is presumably
    |> Linux based on the commands you are using. I think this should still
    |> work. Worst-case scenario, get a LAN trace from both machines when
    |> trying your connection to see where packets are lost.
    |>
    |> Good luck.
    |>
    |>
    | It works!! You were right!
    | I tried many times switching the server firewall off, but I've never
    | tried with the client! I didn't thought the firewall could stop traffic
    | from outside but in response to requests originated from inside!
    | Now I've granted full access from server to client and the active mode
    | works. The passive mode doesn't, but I don't care.
    | Thanks a lot to everyone!!
    |
    |
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFId7vW3s42bA80+9kRAkC+AJ0aiSUkYOvugGzIYmCVe303y6wXlgCdELn2
    rPC7Yo8M3GxGcCrgtQ2SgHw=
    =VdWS
    -----END PGP SIGNATURE-----

  8. #8
    Join Date
    Jul 2008
    Location
    Voorhout, Netherlands
    Posts
    262

    Default Re: command line ftp doesn't work

    Alexart74 wrote:
    > o way. I can't make this ********** ftp work!!
    >
    > Some more info
    > This is the configuration of the FTP server:
    >
    > Code:
    > --------------------

    [snip]
    > # Set to NO if you want to disallow the PASV method of obtaining a data
    > # connection.
    > #
    > pasv_enable=NO


    You will need this set to YES for passive mode FTP.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •