Results 1 to 3 of 3

Thread: Mystery SFTP share enabled, need to turn off.

  1. #1
    edno5071 NNTP User

    Default Mystery SFTP share enabled, need to turn off.

    I have some how managed to end up with a mystery sftp share when I show network:/// in nautilus.


    While it is password protected, this share is at root level for my Opensuse 11 machine so I would like to turn it off, but can not see where the service is.

    I have looked for sftp services in Yast, the services list, in ps -a list but can not see what is starting the share. It persists after a reboot.

    All I can say is that it first appeared when I was trying to get samba to work correctly, but do not remember doing anything that could have created a sftp share and have looked at the samba settings to check.

    Anyone have any ideas on how to turn the share off?

    Thanks

  2. #2
    ab@novell.com NNTP User

    Default Re: Mystery SFTP share enabled, need to turn off.

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    It's probably SSH on that box. If you really don't want it there you
    can disable it on the server by stopping 'sshd' (in most cases) by going
    into Yast and disabling it on startup or you could just enable the
    firewall over port 22. Personally I would just disable the 'root' login
    and leave it there and require Protocol 2 by manipulating the
    /etc/ssh/sshd_config file:

    Uncomment the PermitRootLogin line and set it to 'no' instead of 'yes'.

    Uncomment the Protocol line and remove the ',1' at the end so you only
    allow Protocol 2.

    Restart sshd:
    rcsshd restart

    Good luck.





    edno5071 wrote:
    | I have some how managed to end up with a mystery sftp share when I show
    | network:/// in nautilus.
    |
    |
    | While it is password protected, this share is at root level for my
    | Opensuse 11 machine so I would like to turn it off, but can not see
    | where the service is.
    |
    | I have looked for sftp services in Yast, the services list, in ps -a
    | list but can not see what is starting the share. It persists after a
    | reboot.
    |
    | All I can say is that it first appeared when I was trying to get samba
    | to work correctly, but do not remember doing anything that could have
    | created a sftp share and have looked at the samba settings to check.
    |
    | Anyone have any ideas on how to turn the share off?
    |
    | Thanks
    |
    |
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFIdpru3s42bA80+9kRAli9AJ9vQrdUaY+qGC2pphWxJqvAsnoOKwCghNcB
    Ry0R4LrlBUl0ZVObUk/9mi8=
    =O2pH
    -----END PGP SIGNATURE-----

  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Mystery SFTP share enabled, need to turn off.

    sftp is file transfer on top of the ssh protocol. It's authenticated so doesn't present a hole. If you are sure you won't be using it, you could turn it off. Look for the line Subsystem sftp ... in /etc/ssh/sshd_config and comment it out. I don't know how to do the less drastic step of not advertising it via SLP (I assume), maybe you can blacklist it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •