Results 1 to 4 of 4

Thread: opensuse11 yast/kdebase4 update error

Hybrid View

  1. #1

    Default opensuse11 yast/kdebase4 update error

    Fresh install of opensuse11, i let yast automatically install updates. All of the updates seem to work except the "KDE4-fixes" update. The Summary is "KDE 4 post-release fixes".

    I get this error as soon as the update starts:
    2008-07-10 10:11:59 kdebase4-workspace-devel-4.0.4-24.1.x86_64 remove ok
    2008-07-10 10:11:59 kdebase4-workspace-devel-4.0.4-24.1.x86_64 remove failed
    rpm output:
    error: package kdebase4-workspace-devel-4.0.4-24.1.x86_64 is not installed

    2008-07-10 11:30:31 kdebase4-workspace-devel-4.0.4-24.1.x86_64 remove failed
    rpm output:
    error: package kdebase4-workspace-devel-4.0.4-24.1.x86_64 is not installed



    The problem is, it's correct, i don't have this package installed:
    kdebase4-workspace-devel-4.0.4-24.1
    But i do have:
    kdebase4-workspace-4.0.4-24.2

    I have all of these:
    rpm -qa|grep kdebase4
    kdebase4-workspace-devel-4.0.4-24.2
    kdebase4-openSUSE-11.0-74.2
    kdebase4-workspace-branding-openSUSE-11.0-74.2
    kdebase4-workspace-4.0.4-24.2
    kdebase4-session-4.0.4-6.1
    kdebase4-workspace-ksysguardd-4.0.4-24.2
    kdebase4-4.0.4-18.1
    kdebase4-nsplugin-4.0.4-18.1
    kdebase4-workspace-plasmoids-4.0.1-71.1
    kdebase4-libkonq-4.0.4-18.1
    kdebase4-runtime-4.0.4-20.1



    Thoughts? suggestions? Help?
    BB

  2. #2
    Join Date
    Jun 2008
    Location
    Cleveland USA
    Posts
    138

    Default Re: opensuse11 yast/kdebase4 update error

    Seems like the updater is stuck on the process of removing that package even though it's been uninstalled. Try doing an update from yast software manager by selecting Packages > All Packages > Update If Newer Version Available. After that's done, right click on the zypper updater icon and select Check Now.
    Unintentionally left blank...

  3. #3

    Default Re: opensuse11 yast/kdebase4 update error

    I was able to run the "update if newer version available" part, but still getting the rpm removal error listed above.
    Is there some kind of rescan DB option for the software manager?

  4. #4

    Default Re: opensuse11 yast/kdebase4 update error

    try running zypper from the command line.

    zypper ref && zypper dup

    that should refresh all repos and do a dist-upgrade. Make sure you have the right repos enabled. (unless you want RC1 don't enable factory repos)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •