Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Going INSANE trying to simply change DRIVE PERMISSIONS

  1. #1

    Exclamation Going INSANE trying to simply change DRIVE PERMISSIONS

    trying to suppress my anger!
    Can anyone explain to me why Konquerer, chmod, and chown cannot change drive permissions even though they clearly boast to be able to do so? And also, why the defaults in Linux are set up so that a non-root user cannot connect a new drive to the machine and begin writing to it?

    I have spent months of my free time trying to simply give myself read/write/execute permissions on an external drive. I've gone on multiple forums and have done hours of research. Why does Linux make this so ridiculously IMPOSSIBLE!!?? Shouldn't an individual who buys a new external drive be able to use it? I mean c'mon. The defaults in Linux are ridiculous. You have to jump through hoops to change permissions of a new drive before you can even write to it. What is a drive for if you can't write to it?!

    First, I was told that the reason I couldn't read/write/execute, or even modify the permissions was because it was formatted to NTFS, so I reformatted it to FAT. That didn't do anything. Same thing: non-root users cant write to the drive and it was still impossible to change permissions even After hours of trying chmod and chown (not to mention attempts with the Konqueror GUI). The only way to USE the drive was to be LOGGED IN as ROOT, and we all know that's a bad idea.

    So I formatted it to ext3, thinking that a native format would sit better with my version of OpenSuSe 10.3. Nope. The default permissions are still the same and it is still impossible to change the permissions.

    It baffles me that chmod and chown don't work at all ("permission denied") even in Super User mode, and that the pretty little window in Konqueror that has the nice little dropdown menus, allowing one to change the permissions to a drive, does nothing at all. Just a host of error messages.

    I have changed distros - UBUNTU to DEBIAN to OPENSUSE hoping that one of these would be more friendly to the external drive. No luck.

    My computer whiz - slackware raised - Brother in Law has been killing himself trying to help me out to no avail.

    Anyone want to take a crack at this?

    I'd really appreciate it.

  2. #2

    Default Re: Going INSANE trying to simply change DRIVE PERMISSIONS

    Is it automounted in fstab? You can change the permissions of the drive there. (Although I suspect your brother-in-law will have tried that if you didn't)

  3. #3
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    32,908
    Blog Entries
    15

    Default Re: Going INSANE trying to simply change DRIVE PERMISSIONS

    On Tue, 01 Jul 2008 23:26:04 GMT
    theprinciple <theprinciple@no-mx.forums.opensuse.org> wrote:

    >
    > trying to suppress my anger!
    > Can anyone explain to me why Konquerer, chmod, and chown cannot change
    > drive permissions even though they clearly boast to be able to do so?
    > And also, why the defaults in Linux are set up so that a non-root user
    > cannot connect a new drive to the machine and begin writing to it?
    >
    > I have spent months of my free time trying to simply give myself
    > read/write/execute permissions on an external drive. I've gone on
    > multiple forums and have done hours of research. Why does Linux make
    > this so ridiculously IMPOSSIBLE!!?? Shouldn't an individual who buys a
    > new external drive be able to use it? I mean c'mon. The defaults in
    > Linux are ridiculous. You have to jump through hoops to change
    > permissions of a new drive before you can even write to it. What is a
    > drive for if you can't write to it?!
    >
    > First, I was told that the reason I couldn't read/write/execute, or
    > even modify the permissions was because it was formatted to NTFS, so I
    > reformatted it to FAT. That didn't do anything. Same thing: non-root
    > users cant write to the drive and it was still impossible to change
    > permissions even After hours of trying chmod and chown (not to mention
    > attempts with the Konqueror GUI). The only way to USE the drive was to
    > be LOGGED IN as ROOT, and we all know that's a bad idea.
    >
    > So I formatted it to ext3, thinking that a native format would sit
    > better with my version of OpenSuSe 10.3. Nope. The default permissions
    > are still the same and it is still impossible to change the
    > permissions.
    >
    > It baffles me that chmod and chown don't work at all ("permission
    > denied") even in Super User mode, and that the pretty little window in
    > Konqueror that has the nice little dropdown menus, allowing one to
    > change the permissions to a drive, does nothing at all. Just a host of
    > error messages.
    >
    > I have changed distros - UBUNTU to DEBIAN to OPENSUSE hoping that one
    > of these would be more friendly to the external drive. No luck.
    >
    > My computer whiz - slackware raised - Brother in Law has been killing
    > himself trying to help me out to no avail.
    >
    > Anyone want to take a crack at this?
    >
    > I'd really appreciate it.
    >
    >

    Hi
    Here is an fstab entry for both ntfs and fat

    /dev/sda1 /windows/C ntfs
    ro,users,gid=users,umask=0002,nls=utf8 0
    0 /dev/sda2 /windows/D vfat
    users,gid=users,umask=0002,utf8=true 0 0

    What i would do is use the partitioner in yast and add a label to the
    drive, then it will always mount that way and add fstab options.

    The other thing is to create a directory and change ownership of that
    directory to the user.

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10.0 SP2 x86_64 Kernel 2.6.16.60-0.23-smp
    up 1 day 6:46, 2 users, load average: 0.40, 0.23, 0.13
    GPU GeForce 8600 GTS Silent - Driver Version: 173.14.09


  4. #4

    Default Re: Going INSANE trying to simply change DRIVE PERMISSIONS

    I've had this happen with the occasional pen drive, but I don't have to login as root to write to it as root

    Not sure if you know how to do this (or maybe just never thought of it), so here it is

    In a terminal type su, enter the root password

    When the password's accepted and you're at a root prompt, type konqueror media &

    You're then running that instance of konqueror as root even though you're not logged in as root, and so should be able to add and remove files etc that way

  5. #5
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Going INSANE trying to simply change DRIVE PERMISSIONS

    Quote Originally Posted by theprinciple View Post
    First, I was told that the reason I couldn't read/write/execute, or even modify the permissions was because it was formatted to NTFS, so I reformatted it to FAT. That didn't do anything. Same thing: non-root users cant write to the drive and it was still impossible to change permissions even
    That reason is wrong. FAT filesystems do not have ownership information in the filesystem so the faked-up "ownership" is determined at mount time, and it is logically impossible to change the ownerships because there are none to change.

    If automounting is used, then the account mounting it "owns" the drive. So if you are at the desktop and plug in the drive, the drive will be "owned" by you.

    If you want to share the drive across user accounts, what you need to do is change the automount options so that the group owner is "users" and the umask allows group writing. This is changed in the udev rules I believe, but somebody else will know better than me where to edit.

    NTFS is another kettle of fish. It does have ownership information but I don't know if Linux can change them via ntfs-3g. I don't have an external NTFS drive.

  6. #6

    Cool Re: Going INSANE trying to simply change DRIVE PERMISSIONS

    Thanks to everyone for the quick replies

    Well. I thought I'd solved the problem. I started a kde session as root. I went into Yast (as per the suggestion) and reformatted the external drive. When that was done, navigated to the drive in Konqueror and changed the attributes so that all users can read/write/execute. I also changed the owner and group to that of my personal username.

    Normally when I would do this in a non-root session (but using Super User Konqueror) it would either stall, or the changes would just not take. After executing the changes I'd go back into the properties and they'd be changed back to the defaults. This time, though, it worked!!

    Yay! right? nope. I decided to restart my machine just for good measure and then log in as my personal user. I got a nice surprise. KDE won't boot. I'm stuck in a failsafe terminal session.

    I'm going to have to reinstall Suse

    one more chapter in an ongoing saga. This issue has been plaguing me for months. Unbelievable.

  7. #7
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    32,908
    Blog Entries
    15

    Default Re: Going INSANE trying to simply change DRIVE PERMISSIONS

    On Wed, 02 Jul 2008 02:26:04 GMT
    theprinciple <theprinciple@no-mx.forums.opensuse.org> wrote:

    >
    > Thanks to everyone for the quick replies
    >
    > Well. I thought I'd solved the problem. I started a kde session as
    > root. I went into Yast (as per the suggestion) and reformatted the
    > external drive. When that was done, navigated to the drive in
    > Konqueror and changed the attributes so that all users can
    > read/write/execute. I also changed the owner and group to that of my
    > personal username.
    >
    > Normally when I would do this in a non-root session (but using Super
    > User Konqueror) it would either stall, or the changes would just not
    > take. After executing the changes I'd go back into the properties and
    > they'd be changed back to the defaults. This time, though, it worked!!
    >
    > Yay! right? nope. I decided to restart my machine just for good
    > measure and then log in as my personal user. I got a nice surprise.
    > KDE won't boot. I'm stuck in a failsafe terminal session.
    >
    > I'm going to have to reinstall Suse
    >
    > one more chapter in an ongoing saga. This issue has been plaguing me
    > for months. Unbelievable.
    >
    >

    Hi
    Sounds like the fstab entries are funny, just rem (use a #) any new
    entries out and restart.

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10.0 SP2 x86_64 Kernel 2.6.16.60-0.23-smp
    up 1 day 9:44, 1 user, load average: 0.05, 0.05, 0.09
    GPU GeForce 8600 GTS Silent - Driver Version: 173.14.09


  8. #8
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Going INSANE trying to simply change DRIVE PERMISSIONS

    Don't reinstall Suse -- fix fstab as recommended by malcolmlewis.

    Also, would you like to nominate a filesystem and we could work on that until you get it right. I've seen a couple of valid suggestions in this thread but it might be that you can't see the tree standing in the woods.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  9. #9

    Default Re: Going INSANE trying to simply change DRIVE PERMISSIONS

    Quote Originally Posted by malcolmlewis View Post
    On Wed, 02 Jul 2008 02:26:04 GMT
    theprinciple <theprinciple@no-mx.forums.opensuse.org> wrote:

    >
    > Thanks to everyone for the quick replies
    >
    > Well. I thought I'd solved the problem. I started a kde session as
    > root. I went into Yast (as per the suggestion) and reformatted the
    > external drive. When that was done, navigated to the drive in
    > Konqueror and changed the attributes so that all users can
    > read/write/execute. I also changed the owner and group to that of my
    > personal username.
    >
    > Normally when I would do this in a non-root session (but using Super
    > User Konqueror) it would either stall, or the changes would just not
    > take. After executing the changes I'd go back into the properties and
    > they'd be changed back to the defaults. This time, though, it worked!!
    >
    > Yay! right? nope. I decided to restart my machine just for good
    > measure and then log in as my personal user. I got a nice surprise.
    > KDE won't boot. I'm stuck in a failsafe terminal session.
    >
    > I'm going to have to reinstall Suse
    >
    > one more chapter in an ongoing saga. This issue has been plaguing me
    > for months. Unbelievable.
    >
    >

    Hi
    Sounds like the fstab entries are funny, just rem (use a #) any new
    entries out and restart.

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10.0 SP2 x86_64 Kernel 2.6.16.60-0.23-smp
    up 1 day 9:44, 1 user, load average: 0.05, 0.05, 0.09
    GPU GeForce 8600 GTS Silent - Driver Version: 173.14.09
    Malcom and Swerdna, thanks for your replies.
    I'd already reinstalled SuSe before I got your replies. My brother and law and I were up till 4 am trying to fix the problem. I thought the reinstall would solve everything but it didn't. Here's what happened.

    I reinstalled Suse and decided to format the external drive to FAT32 since that seems to be the format most compatible with both systems. As I've learned, my system is glitched in such a way that any changes I make to ownership, permissions etc don't take unless I am actually in a root session. So I logged in as root, partitioned the drive to FAT and tried to change all the permissions and ownerships. That worked with "owner" and "users" but not with "others". It amazes me that even when logged in to a root session (how much more 'root' can you get?!) I still have "permission denied" messages popping up. Anyway. I figured that giving 'owner' and 'users' read/write/execute permissions was good enough.

    After I did all that, I logged out and back in as my normal user and I thought the problem was solved because I was able to read/write/execute on the drive in both linux and windows (though the drive is schizophrenic in windows, mounting as two different drives simultaneously). So while it was a bit iffy, I thought the problem was solved.

    Now, I will have to explain WHY I am doing all of this in the first place.

    Basically, the external drive is for all my music and image files, which I need to access from both machines. I figured the most elegant solution would be to have this shared drive. Well, after I thought I'd solved the problem, I loaded all my music files back on the drive and then tried to access them with Amarok (I've loved amarok ever since I first used it. I really feel it is a superior player, despite its big footprint). Didn't work. It couldn't see any of the files. I was able to navigate to the mp3s and open them with Konqueror which would shoot them over to Amarok one at a time, but that's just not going to work for me.

    (i wonder if the reason Amarok can't find my files is because I was unable to set the "others" permissions for the drive to full permissions... ?)

    So I am open to suggestions.

    Malcom, If you still think it's fstab, I'll try that.

    Swerdna, you have a good point. I think I just need to stick to a file system till it works. Any suggestions? (fat32 seems to be the best in terms of compatibility)

    thanks again for all the help.

  10. #10
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Going INSANE trying to simply change DRIVE PERMISSIONS

    Fat32 has a limit on file size of about 4Gb, is that a problem?
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •