Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Installed Nvidia driver-- now annoying splash screen

  1. #1

    Unhappy Installed Nvidia driver-- now annoying splash screen

    I don't know how to get rid of it, so I came here for that answer. I installed the nvidia restricted driver in order to get 3D effects and stuff, but now whenever I boot, just before I log in (I have automatic login set up), I see a gray screen with a big, green Nvidia logo. It wouldn't bother me if it wasn't so ugly. How can I get rid of it? Is there a way to choose which splash screens appear during boot? It's after the regular openSUSE bootsplashes.

    Help?

  2. #2
    Join Date
    Jun 2008
    Location
    Bowling Green, KY
    Posts
    157

    Default Re: Installed Nvidia driver-- now annoying splash screen

    Simply run this command as root in terminal.

    Code:
    nvidia-xconfig --no-logo
    Optionally, you can edit the no logo option into your xorg configuration file manually, but I don't remember the option off the top of my head, and this command does the exact same thing.

    Also, on this page it shows that their is a switch to change the logo, but I would sooner just get rid of it.
    lysdestic@suseforums:~>make install --not-war

  3. #3
    Join Date
    Jul 2008
    Location
    ah...on earth certainly !
    Posts
    52

    Default Re: Installed Nvidia driver-- now annoying splash screen

    er...'annoying'?...did you say 'annoying'?

    I thought it looked beautiful !

    Anyway, that's common with all nvidia drivers under opensuse.

  4. #4
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Installed Nvidia driver-- now annoying splash screen

    CurvyTail wrote:

    >
    > er...'annoying'?...did you say 'annoying'?
    >
    > I thought it looked beautiful !
    >
    > Anyway, that's common with all nvidia drivers under opensuse.
    >
    >


    Yup, pretty! You can install your own custom logo to display too! My main
    system is named 'Saturn', so I made an image with a photo of the planet
    Saturn in it. Seeing the planet when I restart X is a good thing, as it
    means that the nvidia drivers are working, X is coming up properly, and all
    is well.

    (Twinview - dual monitors!)

    Loni
    --
    L R Nix
    lornix@lornix.com

  5. #5
    Join Date
    Jun 2008
    Location
    Belgium
    Posts
    10

    Default Re: Installed Nvidia driver-- now annoying splash screen

    Yep, it's there to confirm the nvidia driver is installed and working - not so easy to discern otherwise.

  6. #6
    Join Date
    Jul 2008
    Location
    Sunny Arizona
    Posts
    121

    Question Re: Installed Nvidia driver-- now annoying splash screen

    Does that mean if you are not seeing it the drivers arent working right? My system seems to be working correctly (3D is enabled) but I have no Nvidia splash screen.
    Thank you,
    M13

  7. #7
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Installed Nvidia driver-- now annoying splash screen

    M13 wrote:

    >
    > Does that mean if you are not seeing it the drivers arent working right?
    > My system seems to be working correctly (3D is enabled) but I have no
    > Nvidia splash screen.
    >
    >


    Difficult to say for sure. My 64bit system shows the logo, while my 32bit
    system does not. Both are working very well. I've not had many problems
    with nvidia cards and drivers, and the few times there were issues, it was
    usually a configuration goof on my part when I tried to set it up by hand. I
    know we all hate the phrase, but... "Works for me!" (tm)

    Loni
    --
    L R Nix
    lornix@lornix.com

  8. #8
    Join Date
    Jan 2008
    Location
    N40 44.977 W073 59.356
    Posts
    1,170

    Default Re: Installed Nvidia driver-- now annoying splash screen

    Moving thread from Install/Boot/Login to Applications forum.

  9. #9
    Join Date
    Jan 2008
    Location
    N40 44.977 W073 59.356
    Posts
    1,170

    Default Re: Installed Nvidia driver-- now annoying splash screen

    Quote Originally Posted by redrazor39 View Post
    I don't know how to get rid of it, so I came here for that answer. I installed the nvidia restricted driver in order to get 3D effects and stuff, but now whenever I boot, just before I log in (I have automatic login set up), I see a gray screen with a big, green Nvidia logo. It wouldn't bother me if it wasn't so ugly. How can I get rid of it? Is there a way to choose which splash screens appear during boot? It's after the regular openSUSE bootsplashes.

    Help?
    Move complete.

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,865
    Blog Entries
    15

    Default Re: Installed Nvidia driver-- now annoying splash screen

    On Fri, 11 Jul 2008 03:06:04 GMT
    69 rs ss <69_rs_ss@no-mx.forums.opensuse.org> wrote:

    >
    > redrazor39;1836659 Wrote:
    > > I don't know how to get rid of it, so I came here for that answer. I
    > > installed the nvidia restricted driver in order to get 3D effects
    > > and stuff, but now whenever I boot, just before I log in (I have
    > > automatic login set up), I see a gray screen with a big, green
    > > Nvidia logo. It wouldn't bother me if it wasn't so ugly. How can I
    > > get rid of it? Is there a way to choose which splash screens appear
    > > during boot? It's after the regular openSUSE bootsplashes.
    > >
    > > Help?

    > Move complete.
    >
    >

    Hi
    Add this into your /etc/X11/xorg.conf in the Section "Device".

    Option "NoLogo" "True" # removes nVidia boot logo

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10 SP2 i586 Kernel 2.6.16.60-0.23-default
    up 6:33, 2 users, load average: 0.47, 0.45, 0.71
    GPU GeForce Go 6600 TE/6200 TE Version: 173.14.09


Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •