Results 1 to 4 of 4

Thread: Sudoers not working in Suse 11

  1. #1

    Default Sudoers not working in Suse 11

    Not sure if this is the right place for this

    In 10.3 I had the user I login as added to sudoers for things like running Yast, updates etc as well as some 'run as root' shortcuts I'd added

    Added exactly the same info in Suse 11 and it doesn't work, deleted the entry and tried adding through Yast, still the same

    I even tried adding the user via Yast to have root privileges for ALL commands, still no luck

    Any ideas why?

    Ecky

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Sudoers not working in Suse 11

    There is some suspicion from some previous posts that the YaST sudo management module generates the wrong directives in /etc/sudoers. Better just visudo yourself.

  3. #3
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Sudoers not working in Suse 11

    Ecky wrote:

    >
    > Not sure if this is the right place for this
    >
    > In 10.3 I had the user I login as added to sudoers for things like
    > running Yast, updates etc as well as some 'run as root' shortcuts I'd
    > added
    >
    > Added exactly the same info in Suse 11 and it doesn't work, deleted the
    > entry and tried adding through Yast, still the same
    >
    > I even tried adding the user via Yast to have root privileges for ALL
    > commands, still no luck
    >
    > Any ideas why?
    >
    > Ecky
    >
    >


    Hello Ecky!

    Seems I did something right, and got blogged about...

    A solution for making sudoers work properly in KDE3.5/4 in 11.0

    http://www.benkevan.com/blog/default...do-and-not-su/

    and in this message thread in the 'help.howto' forum/group

    How to solve kdesus prompt for a password in openSUSE 11.0
    (no, no link, I'm using a newsreader, so have no idea how to do that from here
    (yet!))

    Loni

    This is the text of the post:

    Quote:
    ===========================================================
    Did some research, discovered I have TWO versions of kwriteconfig (and
    others!) installed, one for kde3, another for kde4.   imagine it's
    because I'm running 3.5.9, but with some 4.x apps, so I get both runtimes.

    This can cause issues, because the two programs use slightly different
    syntax, the KDE4 kwriteconfig app uses single dash '-' for options while the
    KDE3 version uses double-dash '--'.    grrr!

    Better solution is to actually create the file entry that command is
    supposed to be doing.

    look in .kde/share/config and .kde4/share/config for a file named
    'kdesurc'.

    If it doesn't exist, create a new file named 'kdesurc'.

    Add these two lines to the file:

    [super-user-command]
    super-user-command=sudo

    I did both .kde and .kde4 to make sure I catch whichever kdesu is
    called (v3 or v4).

    This has worked for me, on both 32bit and 64bit systems, opensuse 11.0,
    KDE 3.5.9 installs.   Should also fix KDE4.x systems.
    =================================================================

    --
    L R Nix
    lornix@lornix.com

  4. #4

    Default Re: Sudoers not working in Suse 11

    ken_yap I did try it by editing manually as well as through Yast m8, here's the syntax I added

    username ALL = (root) NOPASSWD: ALL

    I think that's right?


    Hello again lorni

    That seems to make sense and I do have some kde4 apps running on kde 3.5.9

    My time isn't my own for the next 5 or 6 hours so I'll give it a try later, thanks

    Ecky

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •