Results 1 to 5 of 5

Thread: wifi card problem

  1. #1
    jsburch83 NNTP User

    Question wifi card problem

    I have a AR242x a/b/g card. I did what the opensuse pages said and to go get the madwifi drivers and the black list that ath5k driver. I did. The os sees the wifi card fine, but it doesn't assign a wlan0 to the hardware, how do i do that?

  2. #2
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: wifi card problem

    jsburch83 wrote:

    >
    > I have a AR242x a/b/g card. I did what the opensuse pages said and to go
    > get the madwifi drivers and the black list that ath5k driver. I did. The
    > os sees the wifi card fine, but it doesn't assign a wlan0 to the
    > hardware, how do i do that?
    >
    >


    Actually, the Madwifi drivers create 'ath0'. And once Madwifi sees the card,
    it should show up in the Network Devices module of Yast.

    You can verify this in a console, as root:

    # this will show ALL adapters in system, enabled or not
    ifconfig -a

    # this should show setup of wireless card
    iwconfig

    # if above doesn't show anything, try this and look again
    ifconfig ath0 up

    Setting up the card in yast will prompt for essid, key and things. To be
    honest, I've not tried setting up WPA/WPA2. I often run without encryption
    so I can have fun with the local neighborhood kids who try to wardrive.
    You'd be amazed at what you can do to their computers if your system is
    waiting for them... {devilish grin!}

    Loni

    --
    L R Nix
    lornix@lornix.com

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,144
    Blog Entries
    40

    Default Re: wifi card problem

    Quote Originally Posted by lornix View Post
    Actually, the Madwifi drivers create 'ath0'. And once Madwifi sees the card, it should show up in the Network Devices module of Yast. ..... snipped ...
    moderator note - post of lornix moved to address broken NNTP thread.

  4. #4
    Join Date
    Jan 2008
    Location
    N40 44.977 W073 59.356
    Posts
    1,170

    Default Re: wifi card problem

    jsburch83 wrote:
    > I have a AR242x a/b/g card. I did what the opensuse pages said and to go
    > get the madwifi drivers and the black list that ath5k driver. I did. The
    > os sees the wifi card fine, but it doesn't assign a wlan0 to the
    > hardware, how do i do that?
    >
    >

    Thread has been moved to Wireless forum.

  5. #5
    Join Date
    Jan 2008
    Location
    N40 44.977 W073 59.356
    Posts
    1,170

    Default Re: wifi card problem

    Quote Originally Posted by jsburch83 View Post
    I have a AR242x a/b/g card. I did what the opensuse pages said and to go get the madwifi drivers and the black list that ath5k driver. I did. The os sees the wifi card fine, but it doesn't assign a wlan0 to the hardware, how do i do that?
    Move completed.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •