Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Samba settings via swat won't stick

  1. #1
    Join Date
    Jun 2008
    Location
    Deerfield, Massachusetts
    Posts
    183

    Default Samba settings via swat won't stick

    I went into swat, logging in as root, and tried to change the workgroup. When I tried to commit the change, the workgroup went back to blank. I had similar lack of success with other settings. I also wasn't able to create a share.

    What am I missing here?

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Samba settings via swat won't stick

    Quote Originally Posted by pwabrahams View Post
    I went into swat, logging in as root, and tried to change the workgroup. When I tried to commit the change, the workgroup went back to blank. I had similar lack of success with other settings. I also wasn't able to create a share.

    What am I missing here?
    I've never used it -- but if it won't stick -- you might need to be root user to get it to stick
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  3. #3
    Join Date
    Jun 2008
    Location
    Deerfield, Massachusetts
    Posts
    183

    Default Root user

    I assume that when I log into swat as root, that suffices. However, just to be sure, I called Firefox from a root shell and then went to swat from there. It made no difference.

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Samba settings via swat won't stick

    Check your other thread to set the workgroup. Hopefully some experienced soul will show up here and tell you how to use swat -- I cant. But in the meantime the other thread will tell you how to set the workgroup and netbios name.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  5. #5
    Join Date
    Jun 2008
    Location
    Deerfield, Massachusetts
    Posts
    183

    Default Place to set the workgroup is obvious

    The place to set the workgroup shows up conspicuously on the first page of settings. What happens is that I set it to a value and then select Commit. At that point, the change should be accepted. Instead, the workgroup goes back to a blank value.

    A similar thing happens if I attempt to delete a share. The delete is accepted but the share is still there. I can delete shares via Yast, however.

  6. #6
    PV NNTP User

    Default Re: Samba settings via swat won't stick

    pwabrahams wrote:

    >
    > The place to set the workgroup shows up conspicuously on the first page
    > of settings. What happens is that I set it to a value and then select
    > Commit. At that point, the change should be accepted. Instead, the
    > workgroup goes back to a blank value.
    >
    > A similar thing happens if I attempt to delete a share. The delete is
    > accepted but the share is still there. I can delete shares via Yast,
    > however.
    >
    >

    pwabrahams;

    We don't use SWAT very often, but never had a problem with it. Are you
    sure the problem is just not cosmetic? If you have local access,
    check /etc/samba/smb.conf to see if it took your settings. You can
    always, as root, just edit /etc/samba/smb.conf and run "rcsmb restart" so
    that the new config is read. If you need to administer remotely and and
    SWAT is not working try webmin. We've been using webmin for at least two
    years for remote configuration of services.

    You might look at your logs in /var/log to see if anything jumps out why
    SWAT is not working. I have no idea where in the logs it would show up,
    but I would start in /var/log/samba and also /var/log/messages.

    Best of luck;
    --
    P. V.

  7. #7
    Join Date
    Jun 2008
    Location
    Wales, MA
    Posts
    486

    Default Re: Samba settings via swat won't stick

    I can confirm that using swat is broken in openSUSE 11.0.

    I always use swat to configure samba because "for me" it is the easiest and fastest way. It is non-functional under openSUSE 11.0.

    I have tried it on 4 computers and it doesn't work on any of them.

  8. #8
    Will Honea NNTP User

    Default Re: Samba settings via swat won't stick

    brucecadieux wrote:

    >
    > I can confirm that using swat is broken in openSUSE 11.0.
    >
    > I always use swat to configure samba because "for me" it is the easiest
    > and fastest way. It is non-functional under openSUSE 11.0.
    >
    > I have tried it on 4 computers and it doesn't work on any of them.


    Same results here - useless on 4 boxes and I sure miss it.

    --
    Will Honea

  9. #9
    mfarmilo NNTP User

    Default Re: Samba settings via swat won't stick

    I can also confirm that swat doesn't work any more under opensuse 11, on a new install. I've always found it one of the best - and easiest - configuration tools for samba. Now it does exactly as described. If you've done a basic configuration elsewhere then open swat, it shows everything as blanks, and anything you enter then try to commit goes back to blanks. Also, I used to find the kde configuration tool had been getting quite good. Now it (apparently) won't allow me to go into Administrator mode to change samba options. I now appear to have only 2 options that actually work. The first is manually editing smb.conf (ouch). The second is using YAST, which if you look hard enough does actually appear to have all the options there.

  10. #10
    strichards NNTP User

    Default Re: Samba settings via swat won't stick

    Latest on samba.org works correctly.

    add repository us5.samba.org/samba/ftp/Binary_Packages/SuSE/STABLE/11.0/

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •