Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Skype on openSuse 11.0 x86_64

Hybrid View

  1. #1
    jfeit NNTP User

    Default Skype on openSuse 11.0 x86_64

    I have tried to install Skype on x86_64 (11.0).
    The skype-2.0.0.72-suse.i586.rpm installed, but I have no sound.
    Skype output:
    ALSA lib control.c:874snd_ctl_open_conf)
    Cannot open shared library /usr/lib/alsa-lib/libasound_module_ctl_pulse.so

    There is no such lib, but there is /usr/lib64/alsa-lib with that file.

    Probably the lib is sought on a wrong place because 586 version
    is installed?
    Is there Skype for openSuse 11.0 x86_64? I cannot find it.

    Thanks,
    Josef

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Skype on openSuse 11.0 x86_64

    That file is provided by the libasound2-32bit package. Install that and try again.

    Skype works fine on x86_64 once some 32bit packages are installed. I have it working.

  3. #3
    jfeit NNTP User

    Default Re: Skype on openSuse 11.0 x86_64

    It seems I have the lib installed:
    zypper install libasound2-32bit-1.0.16-39.1.x86_64.rpm
    'libasound2-32bit=1.0.16-39.1' is installed

    but the problem persists.

    yes, I have
    skype-2.0.0.72-suse.i586.rpm

    but when I try to install
    libasound2-1.0.16.92-3.1.i586.rpm

    it wants to download 484 MB and downgrade half the system!
    JF

  4. #4

    Default Re: Skype on openSuse 11.0 x86_64

    but when I try to install
    libasound2-1.0.16.92-3.1.i586.rpm

    it wants to download 484 MB and downgrade half the system!
    just don't do that

    I have tried to install Skype on x86_64 (11.0).
    The skype-2.0.0.72-suse.i586.rpm installed, but I have no sound.
    Skype output:
    ALSA lib control.c:874snd_ctl_open_conf)
    Cannot open shared library /usr/lib/alsa-lib/libasound_module_ctl_pulse.so
    this library is in alsa-plugins-pulse package but weird - i have it installed not and skype works true, i have alsa-plugins (only 64-bit)
    install these packages (x86-64 & xxx-32bit) and try again.

    make sure you have installed other skype related packages

  5. #5
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Skype on openSuse 11.0 x86_64

    Quote Originally Posted by jfeit View Post
    I have tried to install Skype on x86_64 (11.0).
    The skype-2.0.0.72-suse.i586.rpm installed, but I have no sound.
    Skype output:
    ALSA lib control.c:874snd_ctl_open_conf)
    Cannot open shared library /usr/lib/alsa-lib/libasound_module_ctl_pulse.so

    There is no such lib, but there is /usr/lib64/alsa-lib with that file.

    Probably the lib is sought on a wrong place because 586 version
    is installed?
    Is there Skype for openSuse 11.0 x86_64? I cannot find it.

    Thanks,
    Josef
    Actually I may have given you wrong advice. The directory /usr/lib/alsa-lib comes from libasound2-32bit, but it seems some files in it come from other packages. In particular /usr/lib64/alsa-lib/libasound_module_ctl_pulse.so comes from alsa-plugins-pulse, so I would think that the 32 bit version would come from alsa-plugins-pulse-32bit. However my Skype doesn't seem to mind that I don't have /usr/lib/alsa-lib/libasound_module_ctl_pulse.so it looks more like your ALSA setup tries to use pulseaudio, which I think shouldn't be needed for Skype? More fun stuff for you to explore.

  6. #6
    night_sentinel NNTP User

    Default Re: Skype on openSuse 11.0 x86_64

    Hello, everyone.

    I have a problem with skype, too, and I would be very grateful, if someone helps me.

    I downloaded the program from its website. The I ran the konsole and typed the command 'rpm -i skype-2.0.0.72-suse.i586.rpm'. I'm sure that is the exact name of the program, because I copied it from its properties. But the konsole answered 'error: open of skype-2.0.0.72-suse.i586.rpm failed: No such file or directory'. Now what?

    Thanks,

    Lily

  7. #7
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Skype on openSuse 11.0 x86_64

    Probably because your console session was not in the same directory as where the file was downloaded. Remember you have to be root to do the install, so you would probably be in /root when you typed that command whereas the RPM would probably be on /home/you/Desktop. So try:

    rpm -i /home/you/Desktop/skype-blah-blah

    Then you will probably find there are some dependencies you have to install first. Make sure you install the 32-bit versions of those dependencies, not the 64-bit versions. I think they will be:

    libqt4-x11-32bit
    libqt4-32bit

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,493
    Blog Entries
    15

    Default Re: Skype on openSuse 11.0 x86_64

    Quote Originally Posted by night sentinel
    Hello, everyone.

    I have a problem with skype, too, and I would be very grateful, if
    someone helps me.

    I downloaded the program from its website. The I ran the konsole and
    typed the command 'rpm -i skype-2.0.0.72-suse.i586.rpm'. I'm sure that
    is the exact name of the program, because I copied it from its
    properties. But the konsole answered 'error: open of
    skype-2.0.0.72-suse.i586.rpm failed: No such file or directory'. Now
    what?

    Thanks,

    Lily
    Hi
    Generally you should start a new thread with your problem, not tack
    onto and existing one

    When running the command you need to do two things use sudo and either
    be in the same directory as the file was downloaded to, or use the full
    path eg

    Code:
    sudo rpm -Uhv /home/<yourusername>/<name_of_the_rpm>
    
    or
    
    cd <to_location_of_file>
    sudo rpm -Uhv <name_of_rpm>
    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
    up 7 days 1:47, 1 user, load average: 0.14, 0.21, 0.24
    GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


  9. #9
    night_sentinel NNTP User

    Default Re: Skype on openSuse 11.0 x86_64

    Thanks a lot. Now I see I have to download these things

    * libQtCore.so.4
    * libQtDBus.so.4
    * libQtGui.so.4
    * libQtNetwork.so.4

    and try again. The strange thing is that I find them only for Mandriva, but I am with Suse 11.

    Whatever, I'll keep on searching. Thanks again.

    Have a nice day/night.

  10. #10
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Skype on openSuse 11.0 x86_64

    No, don't go get those dependencies from outside OpenSUSE, that's asking for trouble. They are all provided by the OpenSUSE packages. Try those two I mentioned. There is another, libqt4-sql-32bit, which I don't think is needed by Skype but I could be wrong and you could install that if there are still missing libQt libraries.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •