Results 1 to 9 of 9

Thread: Cannot automount windows partition

  1. #1

    Default Cannot automount windows partition

    Hello, thank you for your attention

    Ok, Im running opensuse 11.0 and windows xp on dual boot. I want to mount my windows partition from suse permanently. Manual boot works fine.

    I did this:

    HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE 10.x

    My fstab looks fine to me:



    But guess what! At boot it doesnt mount.

    Any ideas? Thanx!

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Cannot automount windows partition

    Quote Originally Posted by sara_miska View Post
    Hello, thank you for your attention

    Ok, Im running opensuse 11.0 and windows xp on dual boot. I want to mount my windows partition from suse permanently. Manual boot works fine.

    I did this:

    HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE 10.x

    My fstab looks fine to me:

    But guess what! At boot it doesnt mount.

    Any ideas? Thanx!
    Looks to me like you need the "force" option, or to reboot to windows and let it "clean" the partition with that groovy filesystem check it does from time to time with the slow horizontal bar, in the boot sequence. It could of course be somethiong else, but give that a try first.
    Last edited by swerdna; 09-Jul-2008 at 13:45.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  3. #3
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Cannot automount windows partition

    As swerdna says...or run 'ntfsfix' to clean a unproperly unmounted NTFS drive (that has been flagged dirty).

    If you have Windows on the same system, booting into that and back to Linux is a better option (safer).
    Have a lot of fun!

  4. #4

    Default Re: Cannot automount windows partition

    I boot into windows all the time, but the problem remains.

    As for the force option - manual mount works without that, so I guess auto mount should, too...

    Booting to and from being a safer option... yeah, and a rather time consuming

  5. #5
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Cannot automount windows partition

    Indeed if a normal manual mount command works, then the NTFS partition is ok (as in not 'dirty').

    What is the exact command you use to mount your drive?
    Maybe there is a small difference in it compared to the names or a path used in fstab?
    Have a lot of fun!

  6. #6

    Default Re: Cannot automount windows partition

    This works:

    mount -t ntfs-3g /dev/sda1 /home/sara/windows_drive

    This doesn't:

    /dev/disk/by-id/scsi-SATA_FUJITSU_MHV2080_NT28T622D49F-part1 /home/sara/windows_drive ntfs-3g defaults 0 0

    This doesn't either:

    /dev/sda1 /home/sara/windows_drive ntfs-3g defaults 0 0

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: Cannot automount windows partition

    The fstab default option will prevent rw mounting as a user. I find the yast partition tool is a convenient way to quickly edit most fstab mounting options. For reference, my windows xp fstab entry:

    /dev/disk/by-id/scsi-SATA_TOSHIBA_MK8032G_X5CX6959T-part1 /windows/C ntfs-3g user,users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8 0 0

  8. #8

    Default Re: Cannot automount windows partition

    In yast partitioner I have now the option "mountable by user" selected, I rebooted the system, but it doesn't mount

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: Cannot automount windows partition

    Open a console and type

    groups

    Are you a member of 'users'?

    The next possible issue that comes to mind is with PolicyKit. Navigate to /usr/share/PolicyKit/policy and do

    cat org.freedesktop.hal.storage.policy

    The system policy for fixed internal storage should look like:

    <action id="org.freedesktop.hal.storage.mount-fixed">
    <description>Mount file systems from internal drives.</description>
    <message>System policy prevents mounting internal media</message>
    <defaults>
    <allow_inactive>no</allow_inactive>
    <allow_active>auth_admin_keep_always</allow_active>
    </defaults>
    </action>
    (The 'auth_admin_keep_always' string could be changed to 'yes' if desired, as with removable drive mounting policy).

    If everything looks ok, we'll need to call in the guru's...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •