Results 1 to 8 of 8

Thread: openSUSE 11 | KDE3 | knetworkmanager doesn't detect wlan

  1. #1

    Default openSUSE 11 | KDE3 | knetworkmanager doesn't detect wlan

    Hello,

    the wired internet connection via router Speedport W700 V worked immediately and without any problems after the installation of openSUSE 11 (notebook SAMSUNG R60plus) and I use KDE 3. The wireless internet connection is sometimes possible. YaST detects an AR242x 802.11abg Wireless PCI Express Adapter. In the majority of cases iwlist ath0 ap does not list my wireless network, also knetworkmanager then only shows the wlans of the neighbourhood. The distance between laptop and router doesn't matter. Unfortunately I do not know under which terms the wireless internet connection worked, but when it worked it worked without any problems (quality of connection about 51%).

    Also for the wireless internet connection I want to use knetworkmanager but my previous workaround (update the sofware of knetworkmanager, update the connections in knetworkmanager) failed. Therefore I ask you to provide support.

    Thank you very much in advance.

    Greetings

    Wolfhard

  2. #2
    Join Date
    Jun 2008
    Location
    London, UK
    Posts
    66

    Default Re: openSUSE 11 | KDE3 | knetworkmanager doesn't detect wlan

    IO have Suse 11.0, KDE 3.5.9 "release 49.1", on and ACER TravelMate with INPROCOMM IPN 2220 adapter.

    I've been using KNetworkmanager and had no trouble until 10.3, then it wouldn't automatically connect to either of my two regular networks. Had to select "Connect to other network" and put in the settings.

    The upgrade to 11.0 has almost fixed this! Now it will try to connect to the last used network, but won't scan if it can't. But all I need to do is click on the KNetworkmanager icon, then click on the name of the network I want to connect to and it works. After that it will continue to connect automatically until I change location.

    All I had to do was add my regular networks to "New connections". This new version of KNetworkmanager is a big improvement, but it still needs a bit of work.

    My install has KNetworkManager & KnetworkManager both v0.7.0, kdenetwork3, kdenetwork3-lan & kdenetwork3-wireless all v3.5.9-39.1. In the past I tried using KNemo as the notification tool, but gave up as KnetworkManager got better.
    Best wishes

    Sid
    HP xw8400, 2x Zeon 5150 @ 2.66GHz, 16Gb RAM, NVidia GeForce 9400GT, 2x Dell 2007FP

  3. #3

    Default Re: openSUSE 11 | KDE3 | knetworkmanager doesn't detect wlan

    Thank you for your reply. During the last two days knetworkmanager worked without problems and I could open the WLAN-connection how you described it. I was very amazed for I didn't change the "openSUSE 11" installation.

    On my notebook there is also an XP-installation which I started the first time since two days this morning. Afterwords I started "openSUSE 11" and knetworkmanager again was not able to open the WLAN-connection. So I've got a notion, that after the usage of XP perhaps some settings have changed and make it impossible to open the WLAN connection with knetworkmanager. Do you imagine, that the usage of XP before starting openSUSE could be a potential reason for the seeming unreliability of knetworkmanager? It is only an assumption for I don't know the logs or protocols where I could check possible changes of settings in the system after using XP.

    Kind regards

    Wolfhard

  4. #4
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: openSUSE 11 | KDE3 | knetworkmanager doesn't detect wlan

    could well be that old XP thing. windows tends not to release network devices on a re-boot. but, from a normal shut-down/start-up & clean boot to SuSE it works normally

    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  5. #5
    Will Honea NNTP User

    Default Re: openSUSE 11 | KDE3 | knetworkmanager doesn't detect wlan

    w langer wrote:

    >
    > Thank you for your reply. During the last two days knetworkmanager
    > worked without problems and I could open the WLAN-connection how you
    > described it. I was very amazed for I didn't change the "openSUSE 11"
    > installation.
    >
    > On my notebook there is also an XP-installation which I started the
    > first time since two days this morning. Afterwords I started "openSUSE
    > 11" and knetworkmanager again was not able to open the WLAN-connection.
    > So I've got a notion, that after the usage of XP perhaps some settings
    > have changed and make it impossible to open the WLAN connection with
    > knetworkmanager. Do you imagine, that the usage of XP before starting
    > openSUSE could be a potential reason for the seeming unreliability of
    > knetworkmanager? It is only an assumption for I don't know the logs or
    > protocols where I could check possible changes of settings in the
    > system after using XP.


    Try two boot sequences here. First, boot XP then reboot (warm start) OS -
    do you get the wireless? Next, boot XP, shut down the laptop, and do a
    boot from power up (cold boot) and see if you get wireless. If the cold
    boot method works, then what is likely is that the XP shutdown routine sets
    a software power down in the wireless hardware while a cold boot brings it
    up active. This wouldn't be the first time I've seen Windows make settings
    changes to hardware that required a cold start to reset.

    --
    Will Honea

  6. #6

    Default Re: openSUSE 11 | KDE3 | knetworkmanager doesn't detect wlan

    I booted XP and rebooted (warm start) OS but didn't get the wireless. Then I shut down the computer with the options "-hP", restarted XP, shut down the laptop and did a boot from power up. But again I didn't get wireless. Tommorrow first I will start the computer with OS from power up. Perhaps then it will get the wireless.

    Wolfhard

  7. #7

    Default Re: openSUSE 11 | KDE3 | knetworkmanager doesn't detect wlan

    Further notice: immediately after reboot from XP (in case of warm start and cold start) OS does not get the wireless. But after a pause (about six hours in this case) when computer was stopped I get wireless immediately after starting the computer with OS from power up.

    Wolfhard

  8. #8

    Default Re: openSUSE 11 | KDE3 | knetworkmanager doesn't detect wlan

    Hello,

    when I do not use an HUB to connect printer and loudspeakers and mouse to the laptop, there are no problems to open the wireless connection via knetworkmangerhas. So it seems, that the USB-HUB "USB 2.0 | 4 Port HUB" from Digitus shows sideeffects when I use it together with my laptop and OS11. So this thread can be closed.

    Wolfhard

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •