Results 1 to 2 of 2

Thread: Java 3d not working in OpenSUSE 10.3

  1. #1

    Default Java 3d not working in OpenSUSE 10.3

    Hallo!I recently installed Java SDK on my OpenSUSE 10.3.Also,I installed Java-3d plus its Cg dependency on my Linux.I am able to run normal java codes but when I try to run java codes that contain graphics syntax that need Java-3d,errors are generated showing that Java-3d libraries are not present.I am sure that my Java-3d codes are accurate since I am able to run them from java-3d environment in Windows.

    How can I solve this problem?

    Please respond to my inquiry as soon as possible and I shall be infinitely grateful.Thanks in advance.

  2. #2
    Join Date
    Jul 2008
    Location
    Germany
    Posts
    17

    Default Re: Java 3d not working in OpenSUSE 10.3

    Hi there!

    Since I'm using Java3d myself, I can only say it definately works...

    So did you get one of those binarys?

    click me

    If you installed one of them it definately should work...if you didn't here is how it works:

    Download a suitable version of j3d from the link above. Open a terminal, be root, and type
    Code:
    sh xxx.bin
    Where xxx is the name of the binary you just downloaded. Then there will be some install dialog and everything will be fine...that's it...

    Then you might want to get some Java3D plugin for eclipse, if you're working with eclipse...
    If you need one I can recommend the following:

    click me

    Hope that might be helpful...

    Cya

    Rittler

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •