Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Wireless adapter (DLink DWL-650+) Not Detected

  1. #1
    Join Date
    Jun 2008
    Location
    Ottawa, Ontario, Canada
    Posts
    72

    Default Wireless adapter (DLink DWL-650+) Not Detected

    In my switch to openSUSE 11 I was hoping for better results with my notebook wireless adapter. That hasn't happened yet.

    Here is the output from lspci -v


    03:00.0 Network controller: Texas Instruments ACX 100 22Mbps Wireless Interface
    Subsystem: D-Link System Inc DWL-650+ PC Card cardbus 22Mbs Wireless Adapter [AirPlus]
    Flags: medium devsel, IRQ 10
    I/O ports at e000 [size=32]
    Memory at f4010000 (32-bit, non-prefetchable) [size=4K]
    Memory at f4000000 (32-bit, non-prefetchable) [size=64K]
    Capabilities: [40] Power Management version 2
    Kernel modules: acx

    There must be a missing piece somewhere. Can someone identify that piece and how I might get it.

    Thank you.

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: Wireless adapter (DLink DWL-650+) Not Detected

    vchapman wrote:
    > 03:00.0 Network controller: Texas Instruments ACX 100 22Mbps Wireless
    > Interface
    > Subsystem: D-Link System Inc DWL-650+ PC Card cardbus 22Mbs Wireless
    > Adapter [AirPlus]
    > Flags: medium devsel, IRQ 10
    > I/O ports at e000 [size=32]
    > Memory at f4010000 (32-bit, non-prefetchable) [size=4K]
    > Memory at f4000000 (32-bit, non-prefetchable) [size=64K]
    > Capabilities: [40] Power Management version 2
    > Kernel modules: acx


    It was recognized and their is a driver named acx. What does the output of
    'dmesg | grep acx' show?

    Larry

  3. #3
    Join Date
    Jun 2008
    Location
    Ottawa, Ontario, Canada
    Posts
    72

    Default Re: Wireless adapter (DLink DWL-650+) Not Detected

    dmesg | grep acx
    acx: this driver is still EXPERIMENTAL
    acx: reading README file and/or Craig's HOWTO is recommended, visit The ACX100/ACX111/TNETW1450 wireless network driver project (Linux, BSD) in case of further questions/discussion
    acx: compiled to use 32bit I/O access. I/O timing issues might occur, such as non-working firmware upload. Report them
    acx: running on a little-endian CPU
    acx: PCI/VLYNQ module v0.3.37 initialized, waiting for cards to probe...
    acx: found ACX100-based wireless network card at 0000:03:00.0, irq:10, phymem1:0xF4010000, phymem2:0xF4000000, mem1:0xe0f24000, mem1_size:4096, mem2:0xe0fa0000, mem2_size:65536
    acx: need to load firmware for acx100 chipset with radio ID 11, please provide via firmware hotplug:
    acx: either one file only (<c>ombined firmware image file, radio-specific) or two files (radio-less base image file *plus* separate <r>adio-specific extension file)
    requesting firmware image 'tiacx100c11'
    acx: firmware image 'tiacx100c11' was not provided. Check your hotplug scripts
    requesting firmware image 'tiacx100'
    acx: firmware image 'tiacx100' was not provided. Check your hotplug scripts
    acx: reset_dev() FAILED
    acx_pci: probe of 0000:03:00.0 failed with error -5
    usbcore: registered new interface driver acx_usb

  4. #4
    Join Date
    Jun 2008
    Location
    Sarasota
    Posts
    301

    Default Re: Wireless adapter (DLink DWL-650+) Not Detected

    Look here:
    Firmware - ACX100/ACX111 wireless network driver project

    [Ubuntu/Kubuntu builds these in on their distro-kits, but openSUSE does not.]

  5. #5
    Join Date
    Jun 2008
    Location
    Ottawa, Ontario, Canada
    Posts
    72

    Default Re: Wireless adapter (DLink DWL-650+) Not Detected

    All of this is beyond my pay grade!! If there is not an easier method, I will purchase a new pccard network adapter.

    Is there an adapter known to work out of the box with openSuse 11.0?

  6. #6
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: Wireless adapter (DLink DWL-650+) Not Detected

    vchapman wrote:
    > All of this is beyond my pay grade!!


    I see what you mean. I'm not a n00b, but it was confusing. From what I read,
    open a terminal and paste in the lines below:

    wget \
    http://web.archive.org/web/200605272...w1/RADIO11.BIN
    wget \
    http://web.archive.org/web/200605272...EN.BIN_1.9.8.b
    mv WLANGEN.BIN_1.9.8.b tiacx100
    mv RADIO11.BIN tiacx100r11
    sudo mv tiacx* /lib/firmware/.


    The line that starts with "sudo" will ask for your root password. After you run
    these commands, reboot and rerun the 'dmesg | grep acx' command. It should no
    longer say that it couldn't find the firmware.

    Larry

  7. #7
    Join Date
    Jun 2008
    Location
    Ottawa, Ontario, Canada
    Posts
    72

    Default Re: Wireless adapter (DLink DWL-650+) Not Detected

    Quote Originally Posted by lwfinger View Post
    vchapman wrote:
    > All of this is beyond my pay grade!!


    I see what you mean. I'm not a n00b, but it was confusing. From what I read,
    open a terminal and paste in the lines below:

    wget \
    http://web.archive.org/web/200605272...w1/RADIO11.BIN
    wget \
    http://web.archive.org/web/200605272...EN.BIN_1.9.8.b
    mv WLANGEN.BIN_1.9.8.b tiacx100
    mv RADIO11.BIN tiacx100r11
    sudo mv tiacx* /lib/firmware/.

    Larry
    The URL's for the two download files somehow get truncated in the web post. This results in the file name for WLANGEN to get truncated. Anyway I downloaded it directly myself. The two files are now sitting in the /lib/firmware/. directory. Neither has the .bin extension. Is this right?

    Here is the output from dmesg | grep acx

    acx: this driver is still EXPERIMENTAL
    acx: reading README file and/or Craig's HOWTO is recommended, visit The ACX100/ACX111/TNETW1450 wireless network driver project (Linux, BSD) in case of further questions/discussion
    acx: compiled to use 32bit I/O access. I/O timing issues might occur, such as non-working firmware upload. Report them
    acx: running on a little-endian CPU
    acx: PCI/VLYNQ module v0.3.37 initialized, waiting for cards to probe...
    acx: found ACX100-based wireless network card at 0000:07:00.0, irq:10, phymem1:0x38010000, phymem2:0x38000000, mem1:0xe0f8a000, mem1_size:4096, mem2:0xe0fc0000, mem2_size:65536
    acx: need to load firmware for acx100 chipset with radio ID 11, please provide via firmware hotplug:
    acx: either one file only (<c>ombined firmware image file, radio-specific) or two files (radio-less base image file *plus* separate <r>adio-specific extension file)
    requesting firmware image 'tiacx100c11'
    acx: firmware image 'tiacx100c11' was not provided. Check your hotplug scripts
    requesting firmware image 'tiacx100'
    acx: firmware size does not match firmware header: 4428 != 168640116, aborting fw upload
    acx: reset_dev() FAILED
    acx_pci: probe of 0000:07:00.0 failed with error -5

  8. #8
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: Wireless adapter (DLink DWL-650+) Not Detected

    vchapman wrote:
    > lwfinger;1836221 Wrote:
    >> vchapman wrote:
    >>> All of this is beyond my pay grade!!

    >> I see what you mean. I'm not a n00b, but it was confusing. From what I
    >> read,
    >> open a terminal and paste in the lines below:
    >>
    >> wget \
    >> http://tinyurl.com/5lr9co
    >> wget \
    >> http://tinyurl.com/5stndw
    >> mv WLANGEN.BIN_1.9.8.b tiacx100
    >> mv RADIO11.BIN tiacx100r11
    >> sudo mv tiacx* /lib/firmware/.
    >>
    >> Larry

    >
    > The URL's for the two download files somehow get truncated in the web
    > post. This results in the file name for WLANGEN to get truncated.
    > Anyway I downloaded it directly myself. The two files are now sitting
    > in the /lib/firmware/. directory. Neither has the .bin extension. Is
    > this right?
    >
    > Here is the output from dmesg | grep acx
    >
    > acx: this driver is still EXPERIMENTAL
    > acx: reading README file and/or Craig's HOWTO is recommended, visit
    > 'The ACX100/ACX111/TNETW1450 wireless network driver project (Linux,
    > BSD)' (http://acx100.sf.net) in case of further questions/discussion
    > acx: compiled to use 32bit I/O access. I/O timing issues might occur,
    > such as non-working firmware upload. Report them
    > acx: running on a little-endian CPU
    > acx: PCI/VLYNQ module v0.3.37 initialized, waiting for cards to
    > probe...
    > acx: found ACX100-based wireless network card at 0000:07:00.0, irq:10,
    > phymem1:0x38010000, phymem2:0x38000000, mem1:0xe0f8a000,
    > mem1_size:4096, mem2:0xe0fc0000, mem2_size:65536
    > acx: need to load firmware for acx100 chipset with radio ID 11, please
    > provide via firmware hotplug:
    > acx: either one file only (<c>ombined firmware image file,
    > radio-specific) or two files (radio-less base image file *plus*
    > separate <r>adio-specific extension file)
    > requesting firmware image 'tiacx100c11'
    > acx: firmware image 'tiacx100c11' was not provided. Check your hotplug
    > scripts
    > requesting firmware image 'tiacx100'
    > acx: firmware size does not match firmware header: 4428 != 168640116,
    > aborting fw upload
    > acx: reset_dev() FAILED
    > acx_pci: probe of 0000:07:00.0 failed with error -5


    No, the files should not have a .bin extension. The driver wanted tiacx100, but
    the one we loaded last time is not correct.

    Do you have a CD with the Windows driver? If so, the following is supposed to work:

    Copy the files from the directory /DRIVER/PCI CARD/WINXP on the CD to
    /lib/firmware and rename as them as follows:

    ACXGEN.BIN to tiacx100 This may be WLANGEN.bin.
    TIACXRMX.BIN to tiacx100r0D
    TIACXRFM.BIN to tiacx100r11

    If you do not have a Windows CD, you can get the driver from

    http://drivers.softpedia.com/progDow...oad-20733.html

    (I hope that URL doesn't get mangled.) What you want is the
    "dwl650+_drivers_307.zip. Unpacked, it provides the above files from Drivers/WinXP.

    If you cannot get the Windows driver, send me a PM (to lwfinger) with your
    E-mail address and I'll send the files to you. I have the ZIP file here.

    Larry


  9. #9
    Join Date
    Jun 2008
    Location
    Ottawa, Ontario, Canada
    Posts
    72

    Default Re: Wireless adapter (DLink DWL-650+) Not Detected

    Well it seems that nothing is ever as it should be! I do have the disk with the WinXP drivers. However, the file names do not match up. (Another however) they are close. So I have AIRPLUS.BIN, APLUSGEN.BIN, APLUSMX.BIN, APLUSRFM.BIN, & APLUSRMX.BIN.

    So I will make some assumptions about matching the ends of the file names with the information you have provided to see if that works.

  10. #10
    Join Date
    Jun 2008
    Location
    Ottawa, Ontario, Canada
    Posts
    72

    Default Re: Wireless adapter (DLink DWL-650+) Not Detected

    Here is what I am going to try:

    linux-o5jr:/media/VIC'S2GB/Drivers # mv APLUSGEN.BIN tiacx100
    linux-o5jr:/media/VIC'S2GB/Drivers # mv APLUSRMX.BIN tiacx100r0D
    linux-o5jr:/media/VIC'S2GB/Drivers # mv APLUSRFM.BIN tiacx100r11

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •