Results 1 to 8 of 8

Thread: Fixed IP (no DHCP)

  1. #1

    Default Fixed IP (no DHCP)

    Can anyone confirm the following issues (al of which used to work in OpenSuse10.3) I encounter in OpenSuse 11.0

    The context : I have to connect my laptop on a private network with no DHCP, so I have to type in my IP in YAST myself. Next I have to send a broadcast (UDP datagrams) and will receive from dedicated devices on that network their response (also broadcast).

    So this I what I used to do :

    1) Go into YAST and type in your own IP address / subnetmask
    Example : 192.168.3.1/255.255.255.0
    Then click on finish --> starts writing the settings.

    BUT at Activate network services I get an error on every software repository I have in Yast ?? This does not happen in OpenSuse 10.3. [download of all *.xml fails]

    2) once Yast has finished I went in to console and "ifconfig" used to show me the new settings in OpenSuse 10.3, but not in OpenSuse 11.0, NO IP address, NO subnet.
    Logging off/on doesn't help. 'rcnetwork restart' doesn't help either. I really have to reboot to have my new settings.

    3) little test : ping to one of those devices (since I know it's IP address) : OK

    4) have my software program send the broadcast and listen for the answers.
    In Opensuse 10.3 I had to do as root first "route add default eth0" [even then this was strange to me, and stupid], so I do the same now. But my program doesn't get any broadcast answer. [Will wireshark this to get better idea of what is going on]

    so in the end I decide to give up and go back to dhcp on with the network cable of the regular network plugged-in
    ==> same issues with the respositories, same issue that NO IP, and a reboot is required.

    I hope I am doing something terribly wrong and someone can tell me. If not, I can only conclude, though I like OpenSuse, that OpenSuse 11.0 contains many many bugs [I have discovered much more other issues :-) ] and it can be argued on the usability level.

    kind regards

  2. #2
    ab@novell.com NNTP User

    Default Re: Fixed IP (no DHCP)

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    1. The failure I can't explain conclusively, but if you are having
    network problems anything relying on the network should fail.

    2. Can you post the output of your 'ifconfig' command? I assume your
    network cable was plugged in at this time, right?

    3. You can ping... that's interesting. Whatever you are pinging must
    be on your local network and not across any routers. Can you ping your
    gateway? Your DNS server(s)? google.com?

    4. Why is adding a gateway stupid? If you're configuring your IP
    manually you could do this in Yast just a couple options below where you
    put in your IP address. If you do not have a gateway you will not ever
    be able to get online. This is just how TCP works. No gateway, no
    leaving your local network.

    You mentioned your network didn't have a DHCP server so I don't see what
    switching back to DHCP is going to give you. Any errors you see this
    way I would expect. A reboot is not required, though, for this to be
    implemented. Exiting Yast alone is enough, but 'rcnetwork restart' will
    do it as well.

    Good luck.





    killerbot wrote:
    | Can anyone confirm the following issues (al of which used to work in
    | OpenSuse10.3) I encounter in OpenSuse 11.0
    |
    | The context : I have to connect my laptop on a private network with no
    | DHCP, so I have to type in my IP in YAST myself. Next I have to send a
    | broadcast (UDP datagrams) and will receive from dedicated devices on
    | that network their response (also broadcast).
    |
    | So this I what I used to do :
    |
    | 1) Go into YAST and type in your own IP address / subnetmask
    | Example : 192.168.3.1/255.255.255.0
    | Then click on finish --> starts writing the settings.
    |
    | BUT at Activate network services I get an error on every software
    | repository I have in Yast ?? This does not happen in OpenSuse 10.3.
    | [download of all *.xml fails]
    |
    | 2) once Yast has finished I went in to console and "ifconfig" used to
    | show me the new settings in OpenSuse 10.3, but not in OpenSuse 11.0, NO
    | IP address, NO subnet.
    | Logging off/on doesn't help. 'rcnetwork restart' doesn't help either. I
    | really have to reboot to have my new settings.
    |
    | 3) little test : ping to one of those devices (since I know it's IP
    | address) : OK
    |
    | 4) have my software program send the broadcast and listen for the
    | answers.
    | In Opensuse 10.3 I had to do as root first "route add default eth0"
    | [even then this was strange to me, and stupid], so I do the same now.
    | But my program doesn't get any broadcast answer. [Will wireshark this
    | to get better idea of what is going on]
    |
    | so in the end I decide to give up and go back to dhcp on with the
    | network cable of the regular network plugged-in
    | ==> same issues with the respositories, same issue that NO IP, and a
    | reboot is required.
    |
    | I hope I am doing something terribly wrong and someone can tell me. If
    | not, I can only conclude, though I like OpenSuse, that OpenSuse 11.0
    | contains many many bugs [I have discovered much more other issues :-) ]
    | and it can be argued on the usability level.
    |
    | kind regards
    |
    |
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFIdNWR3s42bA80+9kRAmy8AJ9HnenKGONjXbH96Tb6eHT/A0ofwQCeLRys
    9DsMg1ccRsdHDLZUmIObzqo=
    =PxL4
    -----END PGP SIGNATURE-----

  3. #3

    Default Re: Fixed IP (no DHCP)

    some more information on my use case.

    We develop software for embedded devices. Those devices are IP addressable., they are connected to a switch. So sometimes my laptop is on the regular network (DHCP driven) and sometimes I connect the laptop to that private network (devices network) which does not have a DHCP, so I have to make sure I choose a IP/subnet in the correct range. So I do this through YAST manually. I do not provide a gateway since I am on the private network directly.

    so :
    * after exiting YAST or rcnetwork restart --> ipconfig does not give an IP. [will post feedback on this later on]
    * after a reboot ipconfig shows me my laptop now has the IP I have entered in YAST.

    Broadcast works again but after manually "route add default eth0" as root.
    Why is this not done automatically, In Winblows specifying IP/subnet (optional Default gateway) this works out of the box. It is hard to explain to users they should do that route thing.

    SO issues boil down to :
    - reboot required now
    - wants to get access to repos (just because I set my IP !!!)
    - not user friendly way to allow broadcast messages

  4. #4
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,453

    Default Re: Fixed IP (no DHCP)

    Go into YaST, Network Settings and on the global options tab set Network
    Setup Method to Traditional Method with ifup.
    Reconfigure your interface via YaST.

    I ran into the same issues when using static IP's and Network Manager which
    seems to screw up when static IP's are involved. Also note along the bottom
    of Global Options tab a checkbox for Change Default Route via DHCP...odd
    place for it.



  5. #5

    Default Re: Fixed IP (no DHCP)

    Thanks : that 'ifup' solved the issues about :
    - contacting the repos
    - new ip address immediately known

    However my broadcast still fails if I don't do the 'route add default eth0' myself. I tried to uncheck that "Change Default Route via DHCP", but at first I didn't see any benefit nor drawback from it.

    So it seems that the new (no ifup) got broken in OpenSuse 11, since on my OpenSuse 10.2/3 it was also turned on.

    Darn regressions :-(

  6. #6
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,453

    Default Re: Fixed IP (no DHCP)

    > However my broadcast still fails if I don't do the 'route add default
    > eth0' myself.


    Not surprising. Network manager seems to get serious heartburn
    over anything statically assigned. It's very DHCP assuming.
    Normally clearing and reassigning everything in YaST once you've deactivated
    network manager and switched to ifup straightens it out. Glad you got it
    working.



  7. #7

    Default Re: Fixed IP (no DHCP)

    And we are back ;-)
    Some side effect of switching to the 'ifup' way. Now I am unable to reach the internet thought my wireless connection.
    I get an ip address from my router, I can ping my router, I can see mu router's configuration website, but I can't reach the outside world.
    So for the moment I switched back to the non-ifup way, and then I can connect to the internet again.
    Any ideas of what would be missing in my ifup configuration?

  8. #8
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,453

    Default Re: Fixed IP (no DHCP)

    > And we are back ;-)
    > Some side effect of switching to the 'ifup' way. Now I am unable to
    > reach the internet thought my wireless connection.
    > I get an ip address from my router, I can ping my router, I can see mu
    > router's configuration website, but I can't reach the outside world.
    > So for the moment I switched back to the non-ifup way, and then I can
    > connect to the internet again.
    > Any ideas of what would be missing in my ifup configuration?


    Sorry haven't gotten back with you. Was on vacation.
    Do you have a default gateway in your route table when using ifup?
    Become 'root' and type 'route' and see what default is set to. It should
    be the address of your router. If not, there is a tab in YaST when you are
    setting the network settings dealing with Routing. That is where you set
    the default gateway. You can force it from the command line also, but I'd
    suggest sticking with YaST so it doesn't get overwritten at some point.

    Also when using ifup, can you do name resolution using dig or nslookup?
    Check that you have a populated DNS in /etc/resolv.conf. This file should
    have a nameserver entry in it. If it is empty you need to reconfigure eth0
    or whatever interface you are using with YaST and make sure you have DNS
    entries. Inability to set DNS entries is what gave me problems with
    NetworkManager.

    Unfortunately getting all of the information set-up is a bit unclear due to
    all of the bits you need being dispersed over multiple tabs. Although it
    makes sense logically, it's not conducive to 'task oriented' workflow which
    at least for me, is how I work and I've seen others that work in this
    manner also stumble on these network configuration tabs. The problems with
    Network Manager and the organization of these configuration settings seems
    to make for the perfect storm for some.




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •