Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Cannot start OpenSuse 11 after changing to Metacity

  1. #1
    Join Date
    Jul 2008
    Posts
    10

    Exclamation Cannot start OpenSuse 11 after changing to Metacity

    Hello,
    This is my first post. I am a newbie. I have been using suse 11 for about 3 weeks now and I love it. But I have a serious problem.

    I normally run KDE 3.0 but I wanted to try something different. I was using enlightenment which worked great and then I logged out. I then tried to set my windows manager to Metacity.

    It attempted to enter the GUI but failed. Ever since I did that I can no longer get into any GUI on suse and I don't know how to change the default back to KDE.

    Basically what happens regardless of whether I run failsafe or the standard version the system starts but I eventually just reach a blank screen and the X cursor appears and then a mouse cursor appears and then it just sits there. I can move the mouse around but nothing happens.

    I have tried entering the terminal and using yast to change my window manager but it has not helped.

    Any advice would be greatly appreciated and if you need any more info please ask me.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,336
    Blog Entries
    15

    Default Re: Cannot start OpenSuse 11 after changing to Metacity

    On Wed, 09 Jul 2008 05:06:04 GMT
    cm25 <cm25@no-mx.forums.opensuse.org> wrote:

    >
    > Hello,
    > This is my first post. I am a newbie. I have been using suse 11 for
    > about 3 weeks now and I love it. But I have a serious problem.
    >
    > I normally run KDE 3.0 but I wanted to try something different. I was
    > using enlightenment which worked great and then I logged out. I then
    > tried to set my windows manager to Metacity.
    >
    > It attempted to enter the GUI but failed. Ever since I did that I can
    > no longer get into any GUI on suse and I don't know how to change the
    > default back to KDE.
    >
    > Basically what happens regardless of whether I run failsafe or the
    > standard version the system starts but I eventually just reach a blank
    > screen and the X cursor appears and then a mouse cursor appears and
    > then it just sits there. I can move the mouse around but nothing
    > happens.
    >
    > I have tried entering the terminal and using yast to change my window
    > manager but it has not helped.
    >
    > Any advice would be greatly appreciated and if you need any more info
    > please ask me.
    >
    >

    Hi
    In Yast goto System->/etc/sysconfig editor and under
    desktop->Display manager set the DISPLAYMANAGER variable to kdm3 and in
    the Window manager section set the DEFAULT_WM variable to startkde3.

    Else you could manually edit the files /etc/sysconfig/displaymanager
    and /etc/sysconfig/windowmanager.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 i686 Kernel 2.6.25.9-0.2-pae
    up 2:28, 2 users, load average: 0.22, 0.28, 0.37
    GPU GeForce Go 6600 TE/6200 TE Version: 173.14.09


  3. #3
    Join Date
    Jul 2008
    Posts
    10

    Default Re: Cannot start OpenSuse 11 after changing to Metacity

    I tried that because I thought it would help but no luck unfortunately. I didn't even have to change the values because they were already set correctly. Strange.

  4. #4

    Default Re: Cannot start OpenSuse 11 after changing to Metacity

    from the command line if you aren't in an xsession

    As root you should be able to type

    kdm

    that should get you the familiar login screen with the options to the left between the many window managers and environments you have installed

  5. #5
    Join Date
    Jul 2008
    Posts
    10

    Default Re: Cannot start OpenSuse 11 after changing to Metacity

    I tried that also after I pressed ctrl-alt-f3 to get to the terminal. So I don't know if I was still in an x-session or not. I typed in kdm and nothing happened.

    When I am at the bootloader how do I make suse just load to the terminal and not try and load an x-session?

  6. #6
    Join Date
    Jul 2008
    Posts
    10

    Angry Re: Cannot start OpenSuse 11 after changing to Metacity

    Another update

    So I launched to the command line by putting in "init 3" at the failsafe boot options and then type in kdm and the system once again went to the blank screen with the mouse cursor and just sat there.

    I also tried to type in startkde from the command line and it failed. The first message that came up was "cannot access display." So I am not sure if any of this means anything.

    Thanks for the help so far.

  7. #7

    Default Re: Cannot start OpenSuse 11 after changing to Metacity

    I made the same error. My problem was that my user profile had "Automatic login" turned on. That meant that whatever I did would revert back to the previous login parameters; in this case the Matacity blank screen.

    My solution was to go to the boot splash screen (I had to insert the program DVD) and on the boot parameter line write "init 3" I then logged in as root and gave the command "startx" which gave me the root desktop. Since this was a different user login, there was no problem. I then opened YaST and went to the Users section. There I looked up my profile and deslected "Automatic Login" When I finished the process, closed YaST and rebooted, the login splash screen opened. Under session I chose the KDE session I wanted and then logged in. I had my desktop once more!

    To avoid problems in the future, I've decided to avoid using automatic login.

  8. #8
    Join Date
    Jul 2008
    Posts
    10

    Talking Thank you! It works!

    That totally worked. Thank you so much. What a weird problem. I wonder why metacity doesn't work, maybe because I don't have gnome installed. I thought I read that metacity depended on gnome.

    Thank you again.

  9. #9

    Default Re: Cannot start OpenSuse 11 after changing to Metacity

    As a future thing if you keep it so you don't auto log in then you can flip environments easily.

    I have had times where I had a KDE issue, so I would just start into icewm to resolve an issue at the time. You can still do a lot of that stuff from the command line but it is more of a pain

  10. #10

    Default Re: Thank you! It works!

    Glad I was able to help.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •