Results 1 to 4 of 4

Thread: turn off desktop effects - kde4 turns while screen

  1. #1
    Join Date
    Jul 2008
    Location
    Palampur Himachal India
    Posts
    16

    Default turn off desktop effects - kde4 turns while screen

    hi!
    i fiddled with kde4 (opensuse-11) desktop effects, enabled a few desktop effects - i think i turned on with opengl...
    and then all screen turned white... my all other users are logging properly but with the root login, kde4 is dead!

    i tried to recover it but couldnot do that...
    finally i did a simple thing - renamed the .kde4 directory in /root

    mv .kde4 .kde4.orig

    and desktop recovered- KDE came out of its hibernation!!
    but i know thats not a decent way of clearing things...
    can anyone suggest how to recover from such a situation, please

    thankx!
    -vaibhav
    Experience is a hard teacher. She gives the test first and the lessons afterwards!!

  2. #2
    Join Date
    Jun 2008
    Location
    Amsterdam
    Posts
    57

    Default Re: turn off desktop effects - kde4 turns while screen

    You can find an alternative solution (turning KDE4 Desktop Effects off from the command line, rather than deleting the .kde4 directory) here: Re: [Solved] Desktop Effects crashed KDE 4

    I added this post so people that find this thread via a search engine (like I did) can find a solution.

  3. #3
    Join Date
    Jul 2008
    Location
    Palampur Himachal India
    Posts
    16

    Thumbs up Re: turn off desktop effects - kde4 turns while screen

    hi!
    that was fantastic! thank you for writing that solution..

    The thing that still haunts me that what exactly goes wrong when desktop effects are enabled! KDE being such a superb window manager should not ideally behave like that!

    nevertheless, with this solution, atleast people can go ahead fiddling with settings without worrying much about the consequences!

    Thank you once again for posting that!

    regards
    vaibhav
    Experience is a hard teacher. She gives the test first and the lessons afterwards!!

  4. #4
    Join Date
    Jun 2008
    Location
    Amsterdam
    Posts
    57

    Smile Re: turn off desktop effects - kde4 turns white screen

    You are very much welcome.

    I don't know about you but I suspect my problems are related to me having an ATI X1400 video card (with the latest drivers for 3D acceleration) which is currently being discussussed in this topic: ATI+Desktop Effects = White

    I did get it working at one point (with older drivers) but I forgot how. I think I installed Compiz-Fusion with the 1-click installer rather than trying to get the KDE4 built in Desktop Effects working.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •