Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: CUPS does not work together with OpenSuSE 11.0

  1. #1
    Join Date
    Jul 2008
    Location
    Ottobrunn SouthEast of Munich
    Posts
    30

    Default CUPS does not work together with OpenSuSE 11.0

    Hi Folks,

    I have big troubles with cups.

    I upgraded
    from OpenSuSE 10.3 to 11.0

    The basic problem might be a network problem.
    After modifying the MTU from 1492 to 1500 as requested by the sysconfig messages,I have even troubles opening the URL: http://localhost

    At Installing the Printer inside YaST results in an eror:

    cups(File)DoRequest error client-error-bad-request

    Any ideas?

    - Willy

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,798

    Default Re: CUPS does not work together with OpenSuSE 11.0

    Quote Originally Posted by WillyFoobar View Post
    I have even troubles opening the URL: http://localhost
    Maybe it will not solve your problem, but CUPS is at http://localhost:631/
    Henk van Velden

  3. #3
    Join Date
    Jan 2008
    Location
    Kenton, TN USA
    Posts
    1,023

    Default Re: CUPS does not work together with OpenSuSE 11.0

    Thread moved to Network/Internet
    Last edited by kastorff; 09-Jul-2008 at 09:21.
    Keith Kastorff

  4. #4
    Join Date
    Jul 2008
    Location
    Ottobrunn SouthEast of Munich
    Posts
    30

    Default Re: CUPS does not work together with OpenSuSE 11.0

    when I connect to
    http://localhost:631
    I get the error message....

    404 Not Found

    What is the problem....

    Yours,
    Willy

  5. #5
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: CUPS does not work together with OpenSuSE 11.0

    what does ' service cups status ' (run as root) return? Is it running?

    edit: http://localhost would not return anything if you don't have apache (or other http daemon) running.
    Cups runs it's own little web service , but that's only on port 631.

    To double check, you can ping to localhost?
    Have a lot of fun!

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,798

    Default Re: CUPS does not work together with OpenSuSE 11.0

    The statement (as root):
    Code:
    netstat -an | grep LISTEN | grep tcp
    should give you (among others) a line:
    Code:
    tcp        0      0 0.0.0.0:631             0.0.0.0:*               LISTEN
    else GRUB is not even running.
    Henk van Velden

  7. #7
    Join Date
    Jul 2008
    Location
    Ottobrunn SouthEast of Munich
    Posts
    30

    Default Re: CUPS does not work together with OpenSuSE 11.0

    #ping localhost
    indicates connection established
    (
    64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.192 ms
    )

    calling
    #service cups status
    Checking for cupsd: running

    indicates that cups is running

    when I use konqueror to show:

    http://localhost

    I get the error

    "Beim Laden von http://localhost ist folgender Fehler aufgetreten:
    Keine Verbindung zu Rechner localhost.

    What is wrong???

  8. #8
    Join Date
    Jul 2008
    Location
    Ottobrunn SouthEast of Munich
    Posts
    30

    Default Re: CUPS does not work together with OpenSuSE 11.0

    Calling
    netstat -an | grep LISTEN | grep tcp

    gives...
    tcp 0 0 127.0.0.1:6560 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:55555 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN
    tcp 0 0 :::22 :::* LISTEN
    tcp 0 0 ::1:631 :::* LISTEN
    tcp 0 0 ::1:25 :::* LISTEN

    but if I use konqueror to fetch:

    http://localhost:631

    i get the error :

    404 Not Found

    this is not surprising, as

    http://localhost

    does not work either.....


    What is wrong....

    Willy

  9. #9
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: CUPS does not work together with OpenSuSE 11.0

    WillyFoobar wrote:

    >
    > Calling
    > netstat -an | grep LISTEN | grep tcp
    >
    > gives...
    > tcp 0 0 127.0.0.1:6560 0.0.0.0:*
    > LISTEN
    > tcp 0 0 127.0.0.1:55555 0.0.0.0:*
    > LISTEN
    > tcp 0 0 0.0.0.0:111 0.0.0.0:*
    > LISTEN
    > tcp 0 0 0.0.0.0:22 0.0.0.0:*
    > LISTEN
    > tcp 0 0 127.0.0.1:631 0.0.0.0:*
    > LISTEN
    > tcp 0 0 127.0.0.1:25 0.0.0.0:*
    > LISTEN
    > tcp 0 0 :::22 :::*
    > LISTEN
    > tcp 0 0 ::1:631 :::*
    > LISTEN
    > tcp 0 0 ::1:25 :::*
    > LISTEN
    >
    > but if I use konqueror to fetch:
    >
    > http://localhost:631
    >
    > i get the error :
    >
    > 404 Not Found
    >
    > this is not surprising, as
    >
    > http://localhost
    >
    > does not work either.....
    >
    >
    > What is wrong....
    >
    > Willy
    >
    >


    The (german!) error message you posted said "no connection to localhost". Is
    the firewall running (usually is on default install), is there a port opened
    for cups (631). If you used the printer setup module in yast, it *should* be
    open, but it might have hiccuped.

    Easiest way is to turn off firewall, again, found in the yast -> security &
    users section.

    http://localhost
    contacts apache, if it's not running, no pages will be found.

    http://localhost:631
    contacts the cups server. it has nothing to do with apache and serves pages
    from it's own private directories.

    Loni
    --
    L R Nix
    lornix@lornix.com

  10. #10
    Join Date
    Jul 2008
    Location
    Ottobrunn SouthEast of Munich
    Posts
    30

    Smile Re: CUPS does not work together with OpenSuSE 11.0

    Hello All,

    i solved the problem by brute force.

    I reinstalled my OpenSuSE 11.0 completely new. The old root partition was deleted.

    After freeing the the Cups Port in the Firewall,
    I had no problem to get connected to
    http://localhost:631

    YaST was able to initialize the printer this time.

    Thanks a lot for your help...

    This thread may be considered as closed.

    Yours,
    Willy

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •