Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Desktop size too large

  1. #1
    robfish NNTP User

    Default Desktop size too large

    I have a problem with my Acer AL1916W monitor with openSuse 11.
    The monitor is detected correctly, as is the video card (Albatron 6800GE) and the correct resolution is set (1440x900) but the desktop is too high. The width seems Ok but to see the top of the desktop I have to move the mouse all the way to the top then to see the bottom I have to move the mouse all the way to the bottom.
    I have installed the nvidia driver but that did not help.
    This also happens with the LiveCD.
    Until I know I can fix this I have gone back to Mepis as my distro (but I really would like to use Suse 11).

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Desktop size too large

    you should be able to change it in YaST, try this trail

    YaST -> Hardware (on left) -> Graphics Card & Monitor (on the right)
    -> then check/adjust info on card/monitor/resloution/colors then -> OK

    BEFORE you click again read what is in that new window AND this (because
    a NEW screen is gonna pop up when you click the next button and you
    can't read it then:

    your screen is gonna go black for some seconds and then when the new
    screen comes up, there will be a little window in the middle with TWO
    tabs....one named "Change Position" and one named "Change Size" you need
    to go to the "Change Size" tab and click on the bottom set of little
    up/down sizing arrows (the bottom arrows point toward each other and
    will make the display smaller) until your monitor is exactly filled top
    to bottom....NOTICE that when you get the display exactly the right size
    there will be a little square box in EACH of the display's four
    corners...note, it MAY also be necessary to make adjustments in the size
    tab AND the position tab to get the four corner boxes perfectly in the
    corners...

    when done press "save"..

    -> Test -> Save -> and marvel at your new display....and, let us know
    how your adventure turned out..

    --
    DenverD (Linux Counter 282315)
    A Texan in Denmark

  3. #3
    robfish NNTP User

    Default Re: Desktop size too large

    Thanks for the suggestion but it seems that each click/step is too large to be able to get the screen to fit the monitor.
    What is weird is that all of the auto detected settings, including size, are correct.
    Never mind, back to Mepis until 11.1 is launched I suppose.

  4. #4
    Join Date
    Jun 2008
    Location
    Skogås Sweden
    Posts
    638

    Default Re: Desktop size too large

    There seems to be a problem with xorg setting a to big
    virtual screen size with certain drivers. This can be corrected
    with yast. Go to yast>system>/etc/sysconfig editor>
    desktop>display manager>displaymanager_randr_mode_auto

    Set the value to 1440x900_60 or 1440x900_75 if your display
    supports 75 hz for that resolution. This will not set the
    correct size for the login screen, but that's not a real
    problem? You can also run a test from the command line to
    see if xrandr can set the correct resolution:

    xrandr -s 1440x900

    And you don't need to be root to run that!

  5. #5

    Default Re: Desktop size too large

    I seem to be having the exact same problem here, also with an acer screen @ 1440x900 and an nvidia graphics card with the drivers installed.

    hank_se:
    xrandr -s 1440x900 manages to correct the screen to looking proper, however changing the article in yast did not make it permanent - a reboot brought me to the same problem. Any idea how I can go about making this a permanent change?

  6. #6
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,236

    Default Re: Desktop size too large

    Just a shot in the dark:

    In nvidia proprietary driver configuration utility (KMenu > Configuration > NVidia X Server Settings, if you are using KDE) there is an advanced option in the X Server Display Configuration tab to set a larger desktop size, so you can pan it at your native resolution. Check if it's not set by mistake.

    Note: you have to start the utility as root to make any changes permanent, or it will not be able to overwrite xorg.conf.

  7. #7

    Default Re: Desktop size too large

    brunomcl:

    I double-checked that, but that's not the problem.

  8. #8
    Tod NNTP User

    Default Re: Desktop size too large

    > I double-checked that, but that's not the problem.

    Go there again, and CHANGE something, anything, then change it back to what you
    want.

    I did that and it fixed my problem (exactly like yours wanting 1400x900 with
    nvidia but getting something like 1400x1200 or???).

    However, it will not stay fixed. The next time you boot it will be too big
    again. To fix it, launch nvidia-settings as root...change something, change it
    back and then click on 'apply' and 'Save to X Configuration File' and 'Quit'.

  9. #9

    Default Re: Desktop size too large

    Thanks for the suggestion Tod, but my current macgyver fix seems to be working, only reverts after reboot. Right now i'm looking a more permanent solution...

  10. #10
    upgrade-broke-it NNTP User

    Default Re: Desktop size too large

    > Thanks for the suggestion Tod, but my current macgyver fix seems to be
    > working, only reverts after reboot. Right now i'm looking a more
    > permanent solution...


    Do not overlook: launch nvidia-settings AS ROOT and save. Doing so, will keep
    what you want boot after boot.

    (In other words: READ Tod's last paragraph, _again_.)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •