Results 1 to 9 of 9

Thread: suse 10.3 not booting into gui

  1. #1
    deepakkol NNTP User

    Question suse 10.3 not booting into gui

    Hi
    I installed the open suse 10.3 from live dvd but i am new to linux and i do not have any idea.
    After the install the system is booting into text mode and asks fro user name and passowrd.
    After that I am total blank. I feel that it does not recognise my ati 3870 graphic card.
    Need help..........

  2. #2
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: suse 10.3 not booting into gui

    Hi deepakkol,

    To get your GUI try logging in as root at the console login and run 'sax2 -r' and reboot after saving the configuration to get basic graphics up and running.

    After that you might want to try installing the ATI driver (if you have not done so already). See here for some pointers on ATI install on openSUSE : ATI - openSUSE

    Let us know how you go!

    Cheers,
    Wj
    Have a lot of fun!

  3. #3
    deepakkol NNTP User

    Exclamation Re: suse 10.3 not booting into gui

    Hi Wj,
    Thanks for the reply.
    I did try out what you mentioned.
    This is what happened
    It recognised my laser mouse and then it said "failed to start server". A log has been created in SaX.log.
    Also I do not know how to save the configuration as I am like very very new to this.

  4. #4
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: suse 10.3 not booting into gui

    Give it one more try like this:

    1) (Re)Boot your system and at the first boot screen enter ' init 3 ' as boot option (this makes sure the system boots to console level, also called runlevel 3).
    2) At the login prompt, login as root
    3) Run Sax using the generic vesa driver ' sax2 -r -m 0=vesa '
    (should at least give you a normal GUI)
    4) Reboot the system normally to see if you now have a GUI

    If this fails again post the contents of /var/log/SaX.log

    Cheers,
    Wj
    Have a lot of fun!

  5. #5

    Default Re: suse 10.3 not booting into gui

    I was going to suggest checking out sax2 there too, so that is a good suggestion

    More sax2 options of what you can try here

    SDB:Black screen after boot - openSUSE

  6. #6
    deepakkol NNTP User

    Unhappy Re: suse 10.3 not booting into gui

    Hi Guys
    I tried the same as mentioned by you.
    What it does is say the same thing and error log created.
    On trying to access the log it says permission denied although I am logged in as root.

    Help

  7. #7
    deepakkol NNTP User

    Default Re: suse 10.3 not booting into gui

    Do you think that if I install open suse 11.0 this issue will get resolved?

  8. #8
    deepakkol NNTP User

    Default Re: suse 10.3 not booting into gui

    I ran the live cd for open suse 10.3 aqnd it boots in gui with low graphics, I tried installing from there but it could not install.

    I have downloaded the ati driver file from ati website.
    It has the extension - .run
    When I try to open it, I can see the code. I assumed it would be an executable file.
    So
    HELP...........

  9. #9
    Join Date
    Jun 2008
    Location
    Oregon, US
    Posts
    109

    Default Re: suse 10.3 not booting into gui

    You have to run it as an executable file. You need to do either of the following:
    1:
    >cd (to where the .run file is)
    >chmod +x ati*.run (this will make the file executable)
    >./ati[TAB] (the tab will autocomplete the filename)

    2:
    >cd (to where the .run file is)
    >sh ati[TAB]

    Either one of those should work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •