Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: XMAME???

  1. #1

    Default XMAME???

    Hi peoples, im still newish to OpenSuse. I have all of the extra
    repositories enabled... eg packman etc etc, and I can't seem to find Xmame. I use to use sdl mame with kxmame frontend on debian based distro's, is there any other repositories for Suse that is not in their by default that may have it?
    cheers
    I have searched about this topic, and looks like the only thing to do is to compile it myself from what i've read, but i would rather not unless it is my last resort.

    kaddy

  2. #2

    Default Re: XMAME???

    Nevermind. found it in the Build Service
    doesn't run that great :s and the sound is choppy, but im workin on it.

  3. #3

    Default Re: XMAME???

    hmmmm, it don't work well. I just found this tutorial
    Xmame Or Xmess? - openSUSE Forums

    but its for gnome, can anyone translate it to a "how to"
    for Kde 3.5x

    I downloaded the packages i need manually, but like this guy said, it failed when trying
    to install them 1 by 1, somehow u gotta install both packages at once. Can anybody help me with this
    in kde?
    thanx
    Last edited by kaddy; 01-Jul-2008 at 08:09. Reason: update msg

  4. #4
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: XMAME???

    if they are rpm's you downloaded, pop them in a folder of your desire, open a console,cd to the folder,su to root & issue the command
    Code:
    rpm -Uhv *.rpm
    & press enter. that *should* sort you out

    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  5. #5
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    32,942
    Blog Entries
    15

    Default Re: XMAME???

    On Tue, 01 Jul 2008 15:16:04 GMT
    kaddy <kaddy@no-mx.forums.opensuse.org> wrote:

    >
    > hmmmm, it don't work well. I just found this tutorial
    > 'Xmame Or Xmess? - openSUSE Forums' (http://tinyurl.com/5r8wxq)
    >
    > but its for gnome, can anyone translate it to a "how to"
    > for Kde 3.5x
    >
    > I downloaded the packages i need manually, but like this guy said, it
    > failed when trying
    > to install them 1 by 1, somehow u gotta install both packages at once.
    > Can anybody help me with this
    > in kde?
    > thanx
    >
    >

    Hi
    I would look at downloading the src rpm's and rebuild them for your
    system. It will tell you during the build if it's missing dependancies.

    rpmbuild --rebuild <name-of_rpm>
    When the build is finished, scroll back a bit and you will see where
    the rpms were placed.

    Then you can install them via the rpm -Uhv command

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10.0 SP2 x86_64 Kernel 2.6.16.60-0.23-smp
    up 23:06, 1 user, load average: 0.44, 0.29, 0.30
    GPU GeForce 8600 GTS Silent - Driver Version: 173.14.09


  6. #6

    Default Re: XMAME???

    @ deltaflyer44
    I tried what u suggested, and it came back with the same error:

    linux-uqw8:/home/kaddy/Desktop/test # rpm -Uhv *.rpm
    warning: xmame-base-0.106-1.i586.rpm: Header V3 DSA signature: NOKEY, key ID 5e00df4c
    error: Failed dependencies:
    xmame >= 0.106 is needed by xmame-base-0.106-1.i586

    And to the other guy, I tried what u suggested also and i got these errors

    error: Bad exit status from /var/tmp/rpm-tmp.92518 (&#37;prep)


    RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.92518 (%prep)
    linux-uqw8:/home/kaddy/Desktop #

    I wish that somebody would put all the needed xmame packages in a repo so it can be easily installed by the package manager like on other distro's even Pclinux has the rpm's. But ahwell.


  7. #7

    Default Re: XMAME???

    IT WORKED!!!!!!!!!!!

    My apologies, I had 1 package that was wrong. I was trying to install sdlmame and xmame base at the same time, however i realised that i needed to install xmame-sdl and xmame base at the same time, and it WORKED!!!!!!!!

    I've tried my roms and they work PERFECT!!!!!!!!!!!
    THANKYOU
    Hope this helps somebody else!
    kaddy

  8. #8

    Default Re: XMAME???

    oh, i should mention. I had Kxmame frontend installed aswell, and i had to go into 'directories' tab within kxmame, and make sure that the executable was pointing at xmame-sdl which was in /usr/bin/xmame-sdl

    ps
    i had to get my packages from RPM Search
    In the openSuse BuildService we only had sdlmame, which runs like Poo.
    Xmame base/Xmame-sdl run perfect! and Kxmame is the best gui that i have encountered for xmame


  9. #9

    Default Re: XMAME???

    From someone that could package XMAME, but that doesn't really knows too much about MAME.
    Here says:
    How’s this related to XMAME?
    XMAME is not currently under development and SDLMAME is it’s official MAMEdev-approved replacement.
    Latest SDLMAME version is 0.125u8, the same that te one from the official MAME.

    The last thing about XMAME I'm able to find is x.mame.net (http://x.mame.net right now doesn't works, and Google cache doesn't gives anything newer).
    The version there is 0.106. The same available at Debian -- Packages (I don't see SDLMAME for Debian).

    So, what do you exactly mean when you say "sdlmame, which runs like Poo"? And why should I package a MAME port from 2006 when there exists a package for an actual MAME port?

  10. #10

    Default Re: XMAME???

    lol. All i know is, i have tried "sdlmame" and it runs all my roms sloooowwwwwwwww, and its not just me, mates of mine have had the same problem with sdlmame. All i know is, that xmame-sdl runs ALOOTTTT! better. and i've tried it on multiple pc's, different hardware. So i know for a fact that Xmame-sdl runs great.
    Don't ask me why, howcome this that or wotever
    It just works.... I dunno why sdlmame runs ****.

    kaddy

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •