Results 1 to 6 of 6

Thread: OS 10.3 or OS 11.0 & Asus A8V-MX & Sata hard drive

  1. #1
    chescopy NNTP User

    Question OS 10.3 or OS 11.0 & Asus A8V-MX & Sata hard drive

    If someone had installed os 10.3 or 11.0 on an asus a8v-mx, please explain the order the modules were loaded, so the hard drive was detected.
    I know is something in the kernel, and related to libata and vt 8251, since 10.2, which doesn't include that module, can be installed.

    I've tried many options, in the bios, with sata, or ahci, and using brokenmodules and insmod at boot parameter, also jumper on the disk(sata, sata II)but still the hard drive is not detected.

    I don't know however, if this is generic of other distros with the same kernel, or if only suse and the order de modules are loaede.

    TIA

  2. #2
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,429

    Default Re: OS 10.3 or OS 11.0 & Asus A8V-MX & Sata hard drive

    This is just a wild guess, but . . . do you need to load the via82cxxx module at installation? On the installation menu, use the Driver F key, follow the process, choose this module.

    It's not a matter of the order in which the modules are loaded (although that can be a factor in the normal boot up). In the case of installation, openSUSE is using linuxrc, which has built in common controller modules which it loads, and it will load additional modules as requested (above). Once all the modules are loaded, it hands off to the installation process.

  3. #3
    chescopy NNTP User

    Default Re: OS 10.3 or OS 11.0 & Asus A8V-MX & Sata hard drive

    Ok, i don't know the F key, because i thought it uses a floppy, with some propietary driver?.

    Anyway, two main devices appear listed:

    vt82c586/yada/8233/8235/yada
    For this, modules available are pata via, via82cxxx, pata_acpi, ata_generic, ide_pci_generic

    I could block either with brokenmodules, but whatever i block, does not work.

    vt8251 ahci/sata 4 port sata controller
    The list of this is ahci, pata_acpi, ata_generic, ide_pci_generic.
    In suse 10.2, loads ahci, and the sata disk, is detected.
    But, starting with 10.3, loads ahci, but the disk, is not detected.

    So i was wrong talking about order, but the modules are related.

    In suse 10.2, libata does no exist, in 11.0 or 10.3, libata always appears related, for modules i choose.

  4. #4
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,429

    Default Re: OS 10.3 or OS 11.0 & Asus A8V-MX & Sata hard drive

    This isn't going to help, but just for ref, under the Driver F key you can select "yes", then the installation shell will fail and drop you into the linuxrc manual installation menu from where you can navigate to and select modules to be loaded that were not automatically picked up by linuxrc initially.

    With the 2.6.18 (if memory serves) kernel in 10.3, libata takes over functionality previously in other modules. Support for your controllers was added in 2.6.14 (ALT Linux Sisyphus - kernel-image-std-def)

    Take a look at this Gentoo page, ref a cousin board of yours, same controllers. Now, this is a kernel config so not all modules are named explicitly. I see ahci, via82cxxx, and "scsi disk support" which I would guess is sd_mod and/or scsi_mod. And, he indicates that *all* VT8251 boards need to have this kernel argument added: pci=nomsi (perhaps that's what you're missing).

    Asus A8V-XE Socket 939 Motherboard - Gentoo Linux Wiki

    Hope that helps. Otherwise, I'm afraid you're going to have to do some more digging. This is a good place to start. And, of course, google is your friend:

    Main Page - ata Wiki

  5. #5
    chescopy NNTP User

    Thumbs up Re: OS 10.3 or OS 11.0 & Asus A8V-MX & Sata hard drive

    Thank you very much mingus, the page in the gentoo wiki, got the solution, pci=nomsi.
    With only that option, i installed 11.0, and now i'm posting from it,

    Thanks again.

  6. #6
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,429

    Default Re: OS 10.3 or OS 11.0 & Asus A8V-MX & Sata hard drive

    Quote Originally Posted by chescopy View Post
    Thank you very much mingus, the page in the gentoo wiki, got the solution, pci=nomsi.
    With only that option, i installed 11.0, and now i'm posting from it,

    Thanks again.
    You are quite welcome. I know this was a tough one - my compliments on keeping your patience.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •