Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: X Error of failed request: BadAlloc (insufficient resources

  1. #1
    seaxom NNTP User

    Default X Error of failed request: BadAlloc (insufficient resources

    Hi,
    I've Opensuse 11 and an Intel Graphic Card.

    Everytime I try to play a video using VLC; or any other video application (mplayer, tomtem).. the system crahes.

    I've got the following error:

    X Error of failed request: BadAlloc (insufficient resources for operation)
    Major opcode of failed request: 142 (XVideo)
    Minor opcode of failed request: 19 ()
    Serial number of failed request: 84
    Current serial number in output stream: 85

    After searching google I found that it is a bug related to the Xorg, and some sites are pointing to fix, but the site is unavailable: http://beta.suse.com/private/sndirsch/bug345131/

    Can someone help me?

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Rome, Italy
    Posts
    248

    Default Re: X Error of failed request: BadAlloc (insufficient resou

    Hi. It is a bug in Xorg. Edit the file /etc/X11/Xorg.conf. Reach the section "device" and add those lines:
    Option "Videoram" "65536"

    Option "Cachelines" "1980" then halt and restart x server

  3. #3
    Join Date
    Jun 2008
    Location
    Vancouver, B.C.
    Posts
    61

    Default Re: X Error of failed request: BadAlloc (insufficient resou

    Are you using visual effect (compiz)? If so, turn it off, and the problem should disapear. There are other posts on this topic on the forum if you do a search.

    I ran into this problem myself

    -c

  4. #4
    Join Date
    Jan 2008
    Location
    Kenton, TN USA
    Posts
    1,023

    Default Re: X Error of failed request: BadAlloc (insufficient resou

    Thread moved to Applications
    Last edited by kastorff; 08-Jul-2008 at 11:20.
    Keith Kastorff

  5. #5
    Join Date
    Jun 2008
    Location
    Rome, Italy
    Posts
    248

    Default Re: X Error of failed request: BadAlloc (insufficient resou

    I'm running Compiz+emerald on an intel 945gm. I had the same problem even with 3d effects off. But now it works like usual. Just add those two lines to xorg.conf.It is a known bug in xorg about the intel video cards.
    Last edited by bcrisciotti; 08-Jul-2008 at 11:44. Reason: Not complete/precise

  6. #6
    Join Date
    Jun 2008
    Location
    Vancouver, B.C.
    Posts
    61

    Default Re: X Error of failed request: BadAlloc (insufficient resou

    really? is your video working after your fix with compiz on?

  7. #7
    Join Date
    Jun 2008
    Location
    Rome, Italy
    Posts
    248

    Default Re: X Error of failed request: BadAlloc (insufficient resou

    Yes it is working perfectly after the changes i made to xorg.conf. I found it on a fedora forum and since it is not related to the distro but on x it works!
    Last edited by bcrisciotti; 09-Jul-2008 at 12:44. Reason: Typo

  8. #8
    Join Date
    Jun 2008
    Location
    Vancouver, B.C.
    Posts
    61

    Default Re: X Error of failed request: BadAlloc (insufficient resou

    Quote Originally Posted by bcrisciotti View Post
    Hi. It is a bug in Xorg. Edit the file /etc/X11/Xorg.conf. Reach the section "device" and add those lines:
    Option "Videoram" "65536"

    Option "Cachelines" "1980" then halt and restart x server
    I am currious what the 65536 and 1980 refer to?

  9. #9

    Default Re: X Error of failed request: BadAlloc (insufficient resou

    Quote Originally Posted by ghostwind View Post
    I am currious what the 65536 and 1980 refer to?
    Just read "man intel"

  10. #10
    gnd NNTP User

    Default Re: X Error of failed request: BadAlloc (insufficient resou

    Quote Originally Posted by RedDwarf View Post
    Just read "man intel"
    Hello all. I have the same problem. Im running openSuse 11 on Fujitsu-Siemens amilo Si2636.

    lspci -vvv shows:

    Code:
    00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
            Subsystem: Fujitsu Siemens Computers Device 111f
            Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
            Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
            Latency: 0
            Interrupt: pin A routed to IRQ 16
            Region 0: Memory at fc000000 (64-bit, non-prefetchable) [size=1M]
            Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
            Region 4: I/O ports at 1800 [size=8]
            Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
                    Address: 00000000  Data: 0000
            Capabilities: [d0] Power Management version 3
                    Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                    Status: D0 PME-Enable- DSel=0 DScale=0 PME-
                    Bridge: PM- B3+
    i did what you recommended - i changed the Xorg.conf. Doesnt help. I also read the manpages for the Intel driver. There its written that:

    The VideoRam option, which in the past had been necessary to allow more than some small amount of memory to be allocated, is now ignored.
    So thats probably why it doesnt help.
    VLC runs ok when i turn of the desktop effects.

    BUT dont tell me that a power-ridden machine like this (Intel Core2Duo T8300 @ 2.4Ghz with integrated Intel Gl960 with 256MB RAM) CANT handle movie playback and a few ****** window effects AT ONCE.

    Why isnt this submitted as a bug yet ??

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •