Results 1 to 6 of 6

Thread: Yast package manager broken

  1. #1
    Join Date
    Jun 2008
    Location
    Rome, Italy
    Posts
    248

    Default Yast package manager broken

    So guys to make a long story short: suddenly after 6 months of very good work yast freezes when managing packages. I have a lot of repositories in it. At launch yast refreshes those repo regularly but at the end of this process it freezes when it shows 'initializing' and the only way to stop it is a kill. Nothing has been done in the last month, i mean upgrading, so simply decided to die. I tried also in a console (x stopped, init 3) but the thing remains the same. Someone ever had am experience like this or any kind of solution?thanks

  2. #2

    Default Re: Yast package manager broken

    It's also possible that your rpm database has gone south. If that is the case you should execute 'rpmdb --rebuilddb' as root. I've also experienced trouble with yast, but I've received an error about corrupt database. Maybe this might also be the source of your problem. On the other hand you could try to remove nearly everything as repository and only leave the stock repositories intact. After success try adding the extra repositories and see if you success.

  3. #3
    Join Date
    Jun 2008
    Location
    Rio de Janeiro
    Posts
    100

    Default Re: Yast package manager broken

    Hi bcrisciotti,

    Well I believe that what you are noticing on Yast can have something to do also with all the problems I get on my GNOME desktop after recent updates through software-updater-applet.
    First of all it is necessary I supply further details of my linux configuration:

    O.S. openSUSE 10.3
    HW: HP Pavillion laptop
    CPU: AMD Turion 64

    After one of the last software updates, whereby have been updated gdm, gnome-screensaver, gtk2, gtk2-32bits, libgnome-kbd,libxklavier...,etc, by rebooting the system, I noticed that GNOME Desktop was not working anymore.
    After a long time spent to find a solution, I downgrade to the previous versions of (what I think) the most relevant pkgs.
    Actually GNOME DT is up again but it is still suffering some broken issue, as for example that Evolution GPG it is not usable due the fact I cannot input the pin code to sign the email.
    I also registered a BUG of this problem :https://bugzilla.novell.com/show_bug.cgi?id=406967
    but until now I have not get any relevant instructions to restore my system.
    Furthermore now I am very scared to use Yast again.
    BR

  4. #4
    Join Date
    Jun 2008
    Location
    Rome, Italy
    Posts
    248

    Default Re: Yast package manager broken

    So those are the news. I rebuilded the rpm database. Something has changed. Now i can reach the package management, but just before i get this error:
    SQL logic error or missing database.
    So it's a problem related to mysql.But it's running! Any idea?

  5. #5
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Yast package manager broken

    As you have rebuilt the rpm database also rebuild the zypper database itself. Might fix this. To do this open a console and as root;

    Code:
    cd /var/cache/zypp
    rm zypp.db
    zypper refresh
    hope that helps,
    Wj

    ps. this is valid for 10.3 , 11.0 works a tad different due to the new satsolver.
    Have a lot of fun!

  6. #6
    Join Date
    Jun 2008
    Location
    Rome, Italy
    Posts
    248

    Default Re: Yast package manager broken

    SOLVED! Thanks to all for this geat help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •